Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd May 2013, 22:13
MON@H Rasta MON@H Rasta is offline
Junior Member
 
Join Date: Apr 2013
Posts: 15
Thanks: 4
Thanked 3 Times in 3 Posts
Default Enable directory listing on ISPConfig (nginx)

Hi. Help me to enable directory listing, please.

My configuration:
Ubuntu 13.04
ISPConfig 3.0.5.2
Nginx 1.2.6

I've added a web site to ISPConfig, uploaded folder with file and added nginx directive, but no luck... Getting error "403 Forbidden"
Attached Images
  

Last edited by MON@H Rasta; 2nd May 2013 at 22:15.
Reply With Quote
The Following User Says Thank You to MON@H Rasta For This Useful Post:
AbannyvabVask (9th December 2013)
Sponsored Links
  #2  
Old 4th May 2013, 09:24
MON@H Rasta MON@H Rasta is offline
Junior Member
 
Join Date: Apr 2013
Posts: 15
Thanks: 4
Thanked 3 Times in 3 Posts
Default

I will be grateful for any help...
Reply With Quote
The Following User Says Thank You to MON@H Rasta For This Useful Post:
AbannyvabVask (23rd December 2013)
  #3  
Old 6th May 2013, 20:28
MON@H Rasta MON@H Rasta is offline
Junior Member
 
Join Date: Apr 2013
Posts: 15
Thanks: 4
Thanked 3 Times in 3 Posts
Red face

I don't know what was wrong, but it's working now!
Must be that I added subdir to directive, not just var/www/mywebsite/web but var/www/mywebsite/web/folder

Last edited by MON@H Rasta; 6th May 2013 at 20:41.
Reply With Quote
  #4  
Old 6th May 2013, 20:36
MON@H Rasta MON@H Rasta is offline
Junior Member
 
Join Date: Apr 2013
Posts: 15
Thanks: 4
Thanked 3 Times in 3 Posts
Unhappy

And it's not working again after resaving site options. I can't get it
Reply With Quote
The Following User Says Thank You to MON@H Rasta For This Useful Post:
AbannyvabVask (12th October 2013)
  #5  
Old 6th May 2013, 22:26
MON@H Rasta MON@H Rasta is offline
Junior Member
 
Join Date: Apr 2013
Posts: 15
Thanks: 4
Thanked 3 Times in 3 Posts
 
Exclamation

GOT IT!!!
To use autoindex, you should add a custom dir, root dir (./web) will not be accessable. So in the end of configuration you should open
Code:
http://yoursite/customdir/

Settings below...

nginx Directives
Code:
location / {
	autoindex on;
}
Attached Images
 

Last edited by MON@H Rasta; 6th May 2013 at 22:39.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ftp problems timeout reny2000 General 6 23rd December 2009 11:09
Error compilation ISPConfig 2.2.34? severnet Installation/Configuration 5 20th December 2009 16:43
add web site serr57 Installation/Configuration 18 13th April 2008 11:40
Installation Error, Debian 3.1 yogi183 Installation/Configuration 6 23rd February 2007 16:11
PHP error chrno Installation/Configuration 2 7th September 2006 13:27


All times are GMT +2. The time now is 08:09.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.