Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 5th May 2013, 19:48
nunor nunor is offline
Junior Member
 
Join Date: Oct 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default Sites & Ispconfig panel not workign after upgrade

Hi,

I've upgraded Ubuntu server to 13.04.
Upgrade went fine, but all my websites & the ispconfig panel (on port 8080) are not reachable anymore.

I receive ERROR 500 - Internal Server Error! when trying to open the sites.
Strange is that all static domains & subdomains (without php) are working fine.
I checked the "The Perfect Server - Ubuntu 13.04" to be sure no additional steps has to be done, but I found nothing.

When I reload apache2 I have following warning (which I didn't had before)

[Sun May 05 19:44:58 2013] [warn] NameVirtualHost *:443 has no VirtualHosts
[Sun May 05 19:44:58 2013] [warn] NameVirtualHost *:80 has no VirtualHosts
... waiting [Sun May 05 19:44:59 2013] [warn] NameVirtualHost *:443 has no VirtualHosts
[Sun May 05 19:44:59 2013] [warn] NameVirtualHost *:80 has no VirtualHosts

Has anyone a clue what could be the issue?

Many thanks in advance,
Nuno



After some searching it looks like it's related to mod_fcgid. Is there any way to disable mod_fcgid?

below error.log from apache:
[Sun May 05 20:24:08 2013] [error] [client 85.93.202.65] Premature end of script headers: index.php
[Sun May 05 20:46:47 2013] [notice] caught SIGTERM, shutting down
[Sun May 05 20:46:48 2013] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
[Sun May 05 20:46:48 2013] [notice] Digest: generating secret for digest authentication ...
[Sun May 05 20:46:48 2013] [notice] Digest: done
[Sun May 05 20:46:48 2013] [notice] FastCGI: process manager initialized (pid 9802)
[Sun May 05 20:46:48 2013] [notice] Apache/2.2.22 (Ubuntu) DAV/2 mod_fastcgi/mod_fastcgi-SNAP-0910052141 mod_fcgid
/2.3.7 PHP/5.4.9-4ubuntu2 mod_ssl/2.2.22 OpenSSL/1.0.1c configured -- resuming normal operations
[Sun May 05 20:47:11 2013] [notice] caught SIGTERM, shutting down
[Sun May 05 20:47:12 2013] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
[Sun May 05 20:47:12 2013] [notice] Digest: generating secret for digest authentication ...
[Sun May 05 20:47:12 2013] [notice] Digest: done
[Sun May 05 20:47:12 2013] [notice] FastCGI: process manager initialized (pid 9860)
[Sun May 05 20:47:13 2013] [notice] Apache/2.2.22 (Ubuntu) DAV/2 mod_fastcgi/mod_fastcgi-SNAP-0910052141 mod_fcgid
/2.3.7 PHP/5.4.9-4ubuntu2 mod_ssl/2.2.22 OpenSSL/1.0.1c configured -- resuming normal operations

Last edited by nunor; 5th May 2013 at 21:27.
Reply With Quote
Sponsored Links
  #2  
Old 6th May 2013, 11:56
SamTzu SamTzu is offline
HowtoForge Supporter
 
Join Date: Apr 2007
Location: Helsinki
Posts: 426
Thanks: 33
Thanked 55 Times in 38 Posts
Send a message via Skype™ to SamTzu
 
Default

[warn] is just a warning. It wont affect the control panel.
Your problem is with your SSL certificate. Did someone try to add SSL for the server? Have you configured additional IP addresses that those SSL's need?
Try running the php -q update.php for ISPConfig again to fix/re-install your controlpanel cert.
__________________

Sami Mattila
Internet-Content

Telephone:
00358942833310
Email: firstname.lastname@internet-content.org
Shop: http://shop.internet-content.net
Site: http://www.internet-content.net
Blog: http://www.internet-content.net/en/blog
FB: https://www.facebook.com/internetcontent

Reply With Quote
Reply

Bookmarks

Tags
ispconfig 3, ubuntu 13.04

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Missing control panel after upgrade to 3.0.2.2 rputnins Installation/Configuration 1 26th August 2014 19:45
Bug? in how Ispconfig 3 does upgrade installs. Devan879 General 2 21st November 2010 09:52
Ispconfig 3.0.2.1 upgrade : Quota and SSL gjaouen Installation/Configuration 1 23rd April 2010 11:01
ISPConfig Upgrade 2.2.23 --> 2.2.29 Fails giganet Installation/Configuration 2 23rd December 2008 22:43
Upgrade has taken ISPConfig offline, help! indie1982 Installation/Configuration 2 9th September 2008 20:18


All times are GMT +2. The time now is 02:43.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.