Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Tips/Tricks/Mods

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 24th April 2013, 10:33
kextra1 kextra1 is offline
Senior Member
 
Join Date: Apr 2008
Posts: 121
Thanks: 12
Thanked 10 Times in 6 Posts
 
Default Mobile Phone Email & ISPConfig 2 HOWTO

Hello guys,

For quite awhile I could receive email on my mobile phone but I couldn't get the outgoing mail with ISPConfig 2 configuration to work period.

I'm running the following:

ISPConfig 2
Debian
Postfix
Courier
RoundCube Webmail

To fix the "Mobile Cell Phone Mail" outgoing problem that plagued me with the ISPConfig 2 setup simply follow the instructions listed below.

1. Edit /etc/postfix/master.cf

Add the following line:

submission inet n - n - - smtpd

2. Enter the Android or iPhone "Email" app

Enter your email address/username as normal, but click on "Manual" setup to continue.

3. Make sure the incoming port is 110, set SSL(accept any)

4. Make sure outgoing port is 25, set SSL(accept any), then make sure you UNCHECK the checkmark box that says "requires authentication".

If you followed the "Perfect Setup Tutorial" you're all gravy, otherwise if you set a postfix password enter the credentials, however most of you probably use other types of mail security methods like me & this default method will work on all mobile phone mail with the default mobile email application.

YOU'RE DONE!
--
I'm not sure why it wouldn't let me send outgoing mail on my mobile with the correct settings until I added the "submissive" line with the "n - n" or two n's where they're supposed to go inside of the "master.cf" file in /etc/postfix.

It doesn't make any friggin sense to me why it wouldn't work without the "submissive" line in the master.cf especially because we're not using:

port 587

for outgoing mail....we're still using port 25..... so it still makes no sense but it's a fix tested & confirmed.
--
I've read all the documentation on debian/postfix/courier forums, everything was correct before...all mail & webmail worked normally, however for the LIFE of me it would not work on the default android phone & iphone mobile email app until I applied this little mod.

It's one of those WIERD little ISPConfig 2 issues I could not get working until now. For an entire year my customers had to go to webmail on their mobile phones. Unfortunately I didn't even have a smartphone until recently. I lost $9,800 on two bids because of not being able to SOLVE this little problem in time. Sucks bawlz right.... that's why I'm posting...like I said though, it doesn't make sense why this works now & didn't before but it DOES! That's the main thing .

Plus the fact that there is no migration script to move ISPConfig 2 to ISPConfig 3. It hurt, yet by absolute ACCIDENT, I tried this one line configuration mod & it WORKED!

If this little mod/fix helps just ONE person & keeps them from pulling their hair out & banging their head against the wall I'll be happy.

I am loyal to ISPConfig...and encourage ALL of you to SHARE absolutely ALL of the code & modules made for ISPConfig 2 & ISPConfig 3. Spread it out to the masses so we can learn it, build on it, make it better.

Do not just take, but give to the ISPConfig 2 & 3 community members. Even if it's a small little thing like in this post that was resolved. Post it. Help others. Your fellow ISPConfig peeps! Support with ispconfig is few & far between when a crucial "NEED TO HAVE THIS FIXED TODAY" issue arises. All we have is each other.

We are family.

Respekt & Peace

--Kextra1

Quote: Rastafari Jangalah motef

"ALL Information should be free to the masses! We don't need bits of knowledge, it doesn't work like that. We need ALL of it. Every bit trickling down the collective tree of intellect. If we had superior knowledge & know how, perhaps we could weed out the ignorant, the misguided, the religious zealot, and the straight up fuqtard dumb asses (yes that's you isla/\/\ tards) that need to be put down & fed to the pigs."
Reply With Quote
The Following 2 Users Say Thank You to kextra1 For This Useful Post:
bamlesqtivanova6307 (1st June 2013), Williamsl (10th July 2014)
Sponsored Links
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ispconfig and dovecot email quota not updated after email erased ftkyiu Installation/Configuration 7 4th June 2014 10:53
No dns zone files created? sjau Installation/Configuration 7 13th March 2012 14:15
All files gone after changing quota to 0 spynode General 17 19th January 2012 15:41
Email problem 'Cannot set my user or group id.' (using ISPConfig 3 + OpenSuSE 11.2) urosm Installation/Configuration 5 19th June 2010 23:41
hotmail rejects outgoing email nzimas Server Operation 3 1st May 2009 04:39


All times are GMT +2. The time now is 08:28.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.