Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 19th April 2013, 17:59
danhansen@denmark danhansen@denmark is offline
Senior Member
 
Join Date: Mar 2013
Posts: 255
Thanks: 55
Thanked 4 Times in 4 Posts
Exclamation ISPconfig 3 - Mailserver Warning

Hi,

Anybody that can tell me what these 2 warnings from the mail-log mean - Can't receive mail by the way:

Relay access denied
warning: dict_nis_init: NIS domain name not set - NIS lookups disabled

It's the "relay" warning which is the reason I can't receive the mails, I guess..

In the ISPconfig CP "System > Server Config > Mail" there is an "error" when I leave the site:

ERROR
Please specify valid RBL hostnames.


Added: zen.spamhaus.org - Error message in ISPconfig CP went away. but still not receiving any mail...

Have been reading several sites, tutotials and manuals - but still I am very much i doubt. Is it in the shell there need to be changes or is it in the ISPconfig3 CP? Heres some of the sites I found regarding this problem:

1. ISPconfig3 Manual: page 189 "4.7.6.4 Relay Recipients"
2. ISPconfig3 Manual: page 225 "Server > Server Config > Mail" Relay Host/Relay User
3. http://beginlinux.com/server_trainin...-server-set-up "4. Configure Relays"
4. http://www.howtoforge.com/forums/showthread.php?t=53319 Where the mydestination line in your main.cf was the problem
5. http://docs.oracle.com/cd/E19563-01/...avb/index.html "18.7.4 To Use DNS Lookups Including RBL Checking for SMTP Relay Blocking"

Could nr "5" be a solution to the second error message - and then maybe both error messages are related?:

warning: dict_nis_init: NIS domain name not set - NIS lookups disabled


Checked for blacklisting:
Code:
 	Blacklist 	Reason	TTL	ResponseTime	Hide
 OK	AHBL 			62	
 OK	ASPEWS 			31	
 OK	BACKSCATTERER 			62	
 OK	BARRACUDA 			62	
 OK	BBFHL1 			47	
 OK	BBFHL2 			47	
 OK	BLOCKLIST.DE 			62	
 OK	BSB 			16	
 OK	BURNT-TECH 			16	
 OK	CASA-CBL 			218	
 OK	CASA-CBLPLUS 			234	
 OK	CBL 			31	
 OK	CHOON 			234	
 OK	DNS-SERVICIOS 			140	
 OK	EFnet RBL 			31	
 OK	IMP-SPAM 			140	
 OK	INPS_DE 			296	
 OK	INTERSERVER 			47	
 OK	ivmSIP 			16	
 OK	ivmSIP24 			16	
 OK	JIPPG 			156	
 OK	LASHBACK 			47	
 OK	MAILSPIKE-BL 			140	
 OK	MAILSPIKE-Z 			140	
 OK	NIXSPAM 			328	
 OK	NOMOREFUNN 			140	
 OK	NoSolicitado 			16	
 OK	PSBL 			94	
 OK	RATS-Dyna 			16	
 OK	RATS-NoPtr 			78	
 OK	RATS-Spam 			78	
 OK	REDHAWK 			62	
 OK	SEM-BACKSCATTER 			47	
 OK	SEM-BLACK 			16	
 OK	SORBS-DUHL 			47	
 OK	SORBS-SPAM 			47	
 OK	SORBS-WEB 			47	
 OK	SPAMCANNIBAL 			47	
 OK	SPAMCOP 			47	
 OK	Spamhaus-ZEN 			62	
 OK	TRUNCATE 			109	
 OK	UCEPROTECTL1 			47	
 OK	UCEPROTECTL2 			47	
 OK	UCEPROTECTL3 			62	
 OK	WPBL 			0
Please point me in the right direction o)


Kind Regards,
Dan
---------------------------------------------------------------------------------------------------------------------------------
Internet Service Information:
Internet Line/Used only for Internet-Servers.
Static/Fixed public IP
All ports opened in router --> "ispserverip"
Primary nameserver --> ns1.myprimarynameserver.tld
Secondary nameserver --> ns2.somedanishdomainservice.tld

System Information:
Ubuntu Server 12.04 (upgraded - do-release-upgrade*)
ISPconfig 3 v.3.0.5.2 (Single Server Setup)
Primary nameserver - BIND
SquirrelMail version 1.4.22 - Courier IMAP/POP3
Database: MySQL Serverversion: 5.5.29-0ubuntu0.12.04.2

Tutorial: "The Perfect Server - ISPConfig3 - Ubuntu Server 10.04"
Downloaded Manual for ISPConfig3 by Falko Timme
* Note's regarding "Release Upgrade": /etc/networks/interfaces added dns-nameservers
8.8.8.8 8.8.4.4 according to "The Perfect Server - ISPconfig3 - Ubuntu 12.04"
---------------------------------------------------------------------------------------------------------------------------------

Last edited by danhansen@denmark; 20th April 2013 at 03:30. Reason: Additional information regarding the problem...
Reply With Quote
Sponsored Links
  #2  
Old 20th April 2013, 20:47
SamTzu SamTzu is offline
HowtoForge Supporter
 
Join Date: Apr 2007
Location: Helsinki
Posts: 438
Thanks: 34
Thanked 56 Times in 39 Posts
Send a message via Skype™ to SamTzu
Default

It's a warning, not an error. You eliminate it by removing
NIS lookups.

First, find out what setting is using NIS:

$ postconf | grep nis:

This outputs something like

alias_maps = hash:/etc/aliases nis:mail.aliases
or
alias_maps = hash:/etc/mail/aliases nis:mail.aliases

Then, disable NIS lookups (as root):

# postconf -e alias_maps=hash:/etc/aliases
or
# postconf -e alias_maps=hash:/etc/mail/aliases

The exact command depends on "postconf | grep nis:" output.


First thing you should do is to check if SMTP is up and running.
On mail server you can check this with this command...

Quote:
netstat -tapn
Can you see SMTP? (Usually on port 25.)
If that is up then you are most likely dealing with a DNS problem (NIS lookups seem to indicate that anyway.)
__________________

Sami Mattila
Internet-Content

Telephone:
00358942833310
Email: firstname.lastname@internet-content.org
Shop: http://shop.internet-content.net
Site: http://www.internet-content.net
Blog: http://www.internet-content.net/en/blog
FB: https://www.facebook.com/internetcontent


Last edited by SamTzu; 20th April 2013 at 20:51.
Reply With Quote
The Following User Says Thank You to SamTzu For This Useful Post:
danhansen@denmark (21st April 2013)
  #3  
Old 21st April 2013, 17:16
danhansen@denmark danhansen@denmark is offline
Senior Member
 
Join Date: Mar 2013
Posts: 255
Thanks: 55
Thanked 4 Times in 4 Posts
 
Default

Hi Sam,

Thanks for your reply.
I will try that command right now to see what I can learn from that.

Thanks for the fix above.
__________________
Kind Regards
Dan

__________________________________________________ _______
Fixed IP/WAN
DMZ -> "ispserverip"
Primary NameServer -> ns1.myprimarynameserver.tld
Secondary NameServer -> ns2.somedomainservice.tld

Ubuntu Server 12.04.4
ISPconfig 3 v.3.0.5.2 (Single Server Setup)
NameServer: BIND v.9.8.1-P1
SquirrelMail: v.1.4.22
MailServer: PostFix v.2.9.6 - IMAP/POP3 Dovecot v.2.0.19
Database: MySQL Server v.5.5.29-0ubuntu0.12.04.2
Tutorial: "ThePerfectServer-ISPconfig3-Ubuntu12.04"
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't receive mails baicunko Server Operation 12 3rd August 2011 23:02
Control Panel - E-mail Tab is empty domi-nik General 15 14th April 2011 19:17
Fail2ban attacker Toucan General 2 6th October 2010 00:00
Email problem 'Cannot set my user or group id.' (using ISPConfig 3 + OpenSuSE 11.2) urosm Installation/Configuration 5 19th June 2010 23:41
Error when install ISPConfig 2 with components built from source X-admin Installation/Configuration 5 30th April 2010 14:22


All times are GMT +2. The time now is 21:57.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.