Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 20th April 2013, 16:05
danhansen@denmark danhansen@denmark is online now
HowtoForge Supporter
 
Join Date: Mar 2013
Posts: 228
Thanks: 50
Thanked 5 Times in 5 Posts
 
Exclamation ISPconfig 3 - Postfix - warning: dict_nis_init: NIS domain name not set - NIS lookups

Hi,

Anybody who can confirm this fix - please remember, its an ISPconfig Server:

Problem:
warning: dict_nis_init: NIS domain name not set - NIS lookups disabled

Solution maybe?:
Nov 21 10:21:13 web postfix/smtpd[30732]: warning: dict_nis_init: NIS
domain name not set - NIS lookups disabled


It's a warning, not an error. You eliminate it by removing
NIS lookups.
First, find out what setting is using NIS:

$ postconf | grep nis:

This outputs something like
alias_maps = hash:/etc/aliases nis:mail.aliases
or
alias_maps = hash:/etc/mail/aliases nis:mail.aliases

Then, disable NIS lookups (as root):

# postconf -e alias_maps=hash:/etc/aliases
or
# postconf -e alias_maps=hash:/etc/mail/aliases

The exact command depends on "postconf | grep nis:" output



Looking forward to hear from anyone
__________________
Kind Regards
Dan

__________________________________________________ _______
Fixed IP/WAN
DMZ -> "ispserverip"
Primary NameServer -> ns1.myprimarynameserver.tld
Secondary NameServer -> ns2.somedomainservice.tld

Ubuntu Server 12.04.4
ISPconfig 3 v.3.0.5.2 (Single Server Setup)
NameServer: BIND v.9.8.1-P1
SquirrelMail: v.1.4.22
MailServer: PostFix v.2.9.6 - IMAP/POP3 Dovecot v.2.0.19
Database: MySQL Server v.5.5.29-0ubuntu0.12.04.2
Tutorial: "ThePerfectServer-ISPconfig3-Ubuntu12.04"
Reply With Quote
Sponsored Links
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
PHP warnings after upgrade to ISP config 3.03 stevegjacobs Installation/Configuration 5 30th October 2010 14:31
Being Spammed/Hacked/Probed not sure PLEASE HELP! kresser General 10 29th October 2010 17:25
Email problem 'Cannot set my user or group id.' (using ISPConfig 3 + OpenSuSE 11.2) urosm Installation/Configuration 5 19th June 2010 22:41
Sending mail ISPConfig 3 but not receivind catza Installation/Configuration 20 19th May 2010 12:47
Ftp problems timeout reny2000 General 6 23rd December 2009 11:09


All times are GMT +2. The time now is 10:52.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.