#1  
Old 11th April 2013, 10:34
asterinux asterinux is offline
Junior Member
 
Join Date: Aug 2012
Posts: 18
Thanks: 5
Thanked 1 Time in 1 Post
Default BIND Problem

Hi Guys,


Im stuck in configuring my DNS to work with ISPConfig 3.0.5.1. I can say that my dns is working because i can dig / nslookup the records that i added to the zone. But the zone that was created by ISPConfig GUI, I cant dig or nslookup into it. In my /etc/named.conf file i included the named.conf.local which is used by ISPConfig.

/etc/named.conf

PHP Code:
include "/etc/named/rfc1912.zones";
include 
"/etc/named/root.key";
include 
"/etc/named/lab.domain.com.zones";
#####include "/var/named/chroot/etc/named.conf.local";
include "/etc/named.conf.local"
/etc/named.conf.local

PHP Code:
zone "ez.machines.domain.com" {
        
type master;
        
allow-transfer {none;};
        
file "/var/named/data/pri.ez.machines.domain.com";
}; 
...i cant dig/nslookup the records in ez.machines.domain.com zone. By the way im using BIND 9.8.2rc1-RedHat-9.8.2-0.17.rc1.el6.3 chrooted. Would like to know if i am missing something in the setup.

Thanks.
Reply With Quote
Sponsored Links
  #2  
Old 12th April 2013, 11:38
asterinux asterinux is offline
Junior Member
 
Join Date: Aug 2012
Posts: 18
Thanks: 5
Thanked 1 Time in 1 Post
Default its solved!

just to update this thread,, its solved.

what i did is, i create an empty file /var/named/chroot/etc/named.conf.local and link it to /etc/named.conf.local

PHP Code:
ll /etc/named.conf.local
lrwxrwxrwx 1 root root 38 Apr 12 17
:16 /etc/named.conf.local -> /var/named/chroot/etc/named.conf.local 
... and after reloading, creating new zone under the ISPConfig GUI, i can now dig and ping the record ive created.


Let me know if this is the right thing to do.
Reply With Quote
  #3  
Old 14th April 2013, 16:07
Transmaniacon MC Transmaniacon MC is offline
Junior Member
 
Join Date: Mar 2013
Posts: 8
Thanks: 2
Thanked 0 Times in 0 Posts
 
Default

Quote:
Originally Posted by asterinux View Post
...
Let me know if this is the right thing to do.
I too am interested.

Thanks.
Reply With Quote
Reply

Bookmarks

Tags
bind 9, iscpconfig

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Permission Denied Bind Slave Server Problems wxman Server Operation 17 22nd March 2014 12:30
Email problem 'Cannot set my user or group id.' (using ISPConfig 3 + OpenSuSE 11.2) urosm Installation/Configuration 5 19th June 2010 22:41
bind problem. domain.com doesn't resolve to domain.net bob808 Server Operation 4 29th April 2009 12:07
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 12:20
bind problem flourishing General 2 10th December 2005 13:06


All times are GMT +2. The time now is 04:33.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.