Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 31st October 2013, 22:35
agrothe agrothe is offline
Junior Member
 
Join Date: Oct 2012
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation Can log in via pop3 but not smtp - debian wheezy

I followed this wheezy howto to setup my Debian Wheezy server. I made an alteration in also installing apache2 and configuring nginx to reverse proxy php pages to apache2 and that works great.

I created an SSL certificate from startssl and followed this guide in setting up my cert. My ISPConfig panel now uses the signed cert so I'm assuming it was installed correctly.

I created an email is ISPConfig and when I setup the email on my Android Galaxy S2x, I used IMAP, typed in my server address and chose TLS (accept all certs) and it passed the incoming server settings just fine. I chose the same for "outgoing" settings and get this message "Unable to connect to email server to verify your account information. No response from server".

Code:
Mxtoolbox reports:

Connecting to 199.217.118.33
10/31/2013 3:50:41 PM Connection attempt #1 - Unable to connect after 15 seconds. [15.02 sec]
10/31/2013 3:51:01 PM Connection attempt #2 - Unable to connect after 15 seconds. [15.03 sec]

MXTB-PWS3v2 35054ms
maillog reports

Code:
Oct 31 15:40:33 topaz postfix/master[22549]: daemon started -- version 2.9.6, configuration /etc/postfix
Oct 31 15:45:01 topaz dovecot: imap-login: Disconnected (disconnected before greeting, waited 0 secs): user=<>, rip=127.0.0.1, lip=127.0.0.1, secured, session=</hEQhg/qQgB/AAAB>
Oct 31 15:45:01 topaz dovecot: pop3-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=127.0.0.1, lip=127.0.0.1, secured, session=<308Qhg/q8AB/AAAB>
Oct 31 15:45:01 topaz postfix/smtpd[22652]: connect from localhost[127.0.0.1]
Oct 31 15:45:01 topaz postfix/smtpd[22652]: lost connection after CONNECT from localhost[127.0.0.1]
Oct 31 15:45:01 topaz postfix/smtpd[22652]: disconnect from localhost[127.0.0.1]
Oct 31 15:45:01 topaz postfix/pickup[22550]: C71A250813D8: uid=0 from=<root>
Oct 31 15:45:01 topaz postfix/cleanup[22682]: C71A250813D8: message-id=<20131031204501.C71A250813D8@topaz.bordereastcreative.com>
Oct 31 15:45:01 topaz postfix/qmgr[22551]: C71A250813D8: from=<root@***.us.unmetered.com>, size=653, nrcpt=1 (queue active)
Oct 31 15:45:02 topaz dovecot: imap(info@haikuofmine.com): Disconnected: IMAP session state is inconsistent, please relogin. in=97 out=872
/etc/dovecot/dovecot.conf (partial):

Code:
listen = *,[::]
protocols = imap pop3
auth_mechanisms = plain login
disable_plaintext_auth = no
log_timestamp = "%Y-%m-%d %H:%M:%S "
mail_privileged_group = vmail
ssl_cert = </etc/postfix/smtpd.cert
ssl_key = </etc/postfix/smtpd.key
## must be re-added after an ISPConfig update!!!
ssl_ca = < /usr/local/ispconfig/interface/ssl/startssl.chain.class1.server.crt
/etc/postfix/main.cf (partial):

Code:
# TLS parameters
smtpd_tls_cert_file = /etc/postfix/smtpd.cert
smtpd_tls_key_file = /etc/postfix/smtpd.key
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
hostname:

Code:
topaz:/etc/postfix# hostname
topaz
topaz:/etc/postfix# hostname -f
topaz.bordereastcreative.com
telnet:

Code:
topaz:/etc/postfix# telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
220 topaz.bordereastcreative.com ESMTP Postfix


C:\Users\andrew>telnet topaz.bordereastcreative.com 25
Connecting To topaz.bordereastcreative.com...Could not open connection to the ho
st, on port 25: Connect failed

C:\Users\andrew>telnet topaz.bordereastcreative.com 587
Connecting To topaz.bordereastcreative.com...Could not open connection to the ho
st, on port 587: Connect failed
Code:
topaz:/etc/postfix# iptables -nL | grep 587
ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0            tcp dpt:587
PAROLE     tcp  --  0.0.0.0/0            0.0.0.0/0            tcp dpt:587
Not sure what else to try. Suggestions greatly appreciated.
Reply With Quote
Sponsored Links
  #2  
Old 1st November 2013, 03:10
Quaxth Quaxth is offline
Senior Member
 
Join Date: Sep 2013
Location: Samut Prakan, Thailand
Posts: 440
Thanks: 48
Thanked 34 Times in 31 Posts
Send a message via Skype™ to Quaxth
Default

Quote:
hostname:

Code:
topaz:/etc/postfix# hostname
topaz
topaz:/etc/postfix# hostname -f
topaz.bordereastcreative.com
If I'm not wrong, the outcome of hostname and hostname -f must be exactly the same, in your case both should be "topaz.bordereastcreative.com" without quotes.

Check the settings in /etc/hosts
__________________
*************
Have a nice day.
Reply With Quote
  #3  
Old 1st November 2013, 13:55
agrothe agrothe is offline
Junior Member
 
Join Date: Oct 2012
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Quaxth View Post
If I'm not wrong, the outcome of hostname and hostname -f must be exactly the same, in your case both should be "topaz.bordereastcreative.com" without quotes.

Check the settings in /etc/hosts
I thought that only the -f option need the FQDN. I modified it to have both, did a reboot to ensure it was picked up but still unable to connect via SMTP.

I have a feeling the port is blocked at some level as I can't telnet to it, but can't figure out where its being blocked.
Reply With Quote
  #4  
Old 1st November 2013, 14:11
Quaxth Quaxth is offline
Senior Member
 
Join Date: Sep 2013
Location: Samut Prakan, Thailand
Posts: 440
Thanks: 48
Thanked 34 Times in 31 Posts
Send a message via Skype™ to Quaxth
Default

May you try to change the SMTP Port to Port 26. Some ISP's blocking Port 25 if not used with their own SMTP Server.
__________________
*************
Have a nice day.
Reply With Quote
  #5  
Old 1st November 2013, 14:29
agrothe agrothe is offline
Junior Member
 
Join Date: Oct 2012
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Quaxth View Post
May you try to change the SMTP Port to Port 26. Some ISP's blocking Port 25 if not used with their own SMTP Server.
My ISP is most certainly blocking port 25 but I'm using port 587 (TLS) and disconnected my phone from my home wifi as I know my cell phone provider doesn't block port 25.

Trying port 587 on my laptop doesn't work either, as I thought maybe its just my phone being crazy.
Reply With Quote
  #6  
Old 1st November 2013, 14:32
agrothe agrothe is offline
Junior Member
 
Join Date: Oct 2012
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default

FYI, google just sent a delivery status:

Code:
Technical details of temporary failure:
The recipient server did not accept our requests to connect. Learn more at http://support.google.com/mail/bin/answer.py?answer=7720
[(10) topaz.bordereastcreative.com. [199.217.118.33]:25: Connection refused]
[(100) mail.haikuofmine.com. [199.217.118.33]:25: Connection refused]
Is it possible a firewall besides iptables is blocking the ports?
Reply With Quote
  #7  
Old 1st November 2013, 15:21
Quaxth Quaxth is offline
Senior Member
 
Join Date: Sep 2013
Location: Samut Prakan, Thailand
Posts: 440
Thanks: 48
Thanked 34 Times in 31 Posts
Send a message via Skype™ to Quaxth
Default

Could be a firewall problem.

Did in your install Bastille running? Check in ISPConfig CP under the System Tab System -->Firewall. Look that the ports your need are set correctly, if not add them. You could also stop the Bastille Firewall using:
Code:
/etc/init.d/bastille-firewall stop
If you use any other firewall, also inside your Modem/Router you'll have to check that settings as well.
__________________
*************
Have a nice day.
Reply With Quote
  #8  
Old 1st November 2013, 16:17
Quaxth Quaxth is offline
Senior Member
 
Join Date: Sep 2013
Location: Samut Prakan, Thailand
Posts: 440
Thanks: 48
Thanked 34 Times in 31 Posts
Send a message via Skype™ to Quaxth
Default

Please use English language only. If you're not capable of that, translate using Google Translate http://translate.google.com/

Thanks.
__________________
*************
Have a nice day.
Reply With Quote
  #9  
Old 1st November 2013, 17:55
agrothe agrothe is offline
Junior Member
 
Join Date: Oct 2012
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Quaxth View Post
Could be a firewall problem.

Did in your install Bastille running? Check in ISPConfig CP under the System Tab System -->Firewall. Look that the ports your need are set correctly, if not add them. You could also stop the Bastille Firewall using:
Code:
/etc/init.d/bastille-firewall stop
If you use any other firewall, also inside your Modem/Router you'll have to check that settings as well.
I stopped bastille, with no luck, I may need to check if the hostname is properly set in all places though, if any setting got just topaz instead of topaz.domainname.com I might have an issue there. I'll check that later and report.
Reply With Quote
  #10  
Old 1st November 2013, 23:14
agrothe agrothe is offline
Junior Member
 
Join Date: Oct 2012
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

I stopped bastille and tried ufw, then stopped that too but still cannot telnet to 587 at all.
I can telnet to 22, 110 but not any of the smtp ports, 25, 587,465,443.

I'm at a loss as to what this could be.
Reply With Quote
Reply

Bookmarks

Tags
dovecot, postfix, smtp, wheezy

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting Email Working ISPConfig3 Squirrelmail and Courier etc Ian Wilson Installation/Configuration 17 19th June 2013 22:58
Installation just stops, and dies. cosmicsafari Installation/Configuration 3 19th July 2011 10:24
MyDNS Segfaults crypted General 19 22nd July 2010 22:49
No ftp login for ispconfig-webuser agri Installation/Configuration 12 19th March 2007 10:06
e-mail problem!!! Debian 3.1 maroonworks Installation/Configuration 18 6th December 2005 14:42


All times are GMT +2. The time now is 20:40.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.