Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 4th November 2013, 00:03
davblos davblos is offline
Junior Member
 
Join Date: Nov 2013
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default https redirects to apache test page

Hi,

I am having trouble setting up SSL on a website.

I have followed the SSL setup instructions, pretty straight forward, and verified that my certificate is working correctly using various cert checkers online.

The problem is that when I try to access https://mydomain.com.au i get redirected to the apache test page. When I try to access any specific page ( https://mydomain.com.au/anypage ) I get a Forbidden error.

My server has been setup using "The Perfect Server - CentOS 6.4 x86_64".

The only log error I can find is in ssl_error_log:

"client denied by server configuration: /var/www/mydomain.com.au/web"

Any ideas?


Thanks,

Dave.
Reply With Quote
Sponsored Links
  #2  
Old 5th November 2013, 12:08
Croydon Croydon is offline
ISPConfig Developer
 
Join Date: Jul 2007
Location: Koblenz, Germany
Posts: 932
Thanks: 16
Thanked 263 Times in 208 Posts
 
Default

The "client denied by server configuration" error is most likely due to an misconfigured .htaccess or vhost/apache config.

One possibility is, that one of the directories /var/www /var/www/mydomain.com.au has "deny from all" set.

Try to check the vhost of your domain if there is a directive for access control like "Order deny,allow" etc.

If your mentioned path /var/www/mydomain.com.au is NOT a symlink you might want to try adding something like this to your vhost file:

<Directory /var/www/mydomain.com.au/web>
Order deny,allow
allow from all
</Directory>

Maybe this already solves the issue.
__________________
Marius Cramer

pixcept KG
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with send/ receive mail in ISPconfig freesqrt Installation/Configuration 20 12th July 2012 04:43
Apache rewrites home page to another denmaddog Installation/Configuration 1 1st May 2011 22:35
Postfix not... doing anything. torg HOWTO-Related Questions 2 18th January 2010 01:46
squid and https passthrough Xitron Installation/Configuration 0 5th November 2009 19:40
New Site Shows Apache Default page not uploaded index.html mojosound Installation/Configuration 35 18th April 2006 11:59


All times are GMT +2. The time now is 22:13.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.