Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 1st April 2013, 21:38
msp msp is offline
Member
 
Join Date: Aug 2011
Posts: 41
Thanks: 2
Thanked 2 Times in 2 Posts
Default Nginx: where to put URL re-write rules, etc.

I am trying to move my websites from a server running ISPConfig3/Apache to a new server running ISPConfig3/nginx.

Most of my sites run ModX Evolution, with URL re-writing.

After a bit of research, I have added the following directives to the "nginx directives" box under the Options tab for the website in ISPConfig3:

Code:
# nginx configuration

location /manager {
}

location /assets {
}

location ~ \.(jpg|jpeg|png|gif|ico)$ {
}

location / {
  if ($http_user_agent ~* "^.*internal\ dummy\ connection.*$"){
    return 403;
  }
  if (!-e $request_filename){
    rewrite ^(.*)$ /index.php?q=$1 break;
  }
}
Unfortunately, it's not working.

Have I put this in the correct place?
Reply With Quote
Sponsored Links
  #2  
Old 2nd April 2013, 12:20
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,189
Thanks: 829
Thanked 5,418 Times in 4,260 Posts
 
Default

Quote:
Have I put this in the correct place?
Yes, thats the correct place.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
mail stop on one account provell General 10 26th November 2009 21:29
LB1 Not Taking Over Shared IP Using Heartbeat 2.1.3 On FC10 64Bit asyadiqin Installation/Configuration 5 11th February 2009 20:11
ISPConfig Installation error linuxuser1 Installation/Configuration 4 26th February 2008 06:38
ERROR: The PHP binary coming with ISPConfig does not work properly on your system! qvindesland Installation/Configuration 22 21st May 2007 16:05
ISPConfig 2.2.10 released till General 70 7th March 2007 18:25


All times are GMT +2. The time now is 15:21.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.