Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd April 2013, 11:40
zkvvoob zkvvoob is offline
Junior Member
 
Join Date: Apr 2013
Posts: 11
Thanks: 3
Thanked 0 Times in 0 Posts
Question Cannot access IPSConfig 3 control panel

Hi guys,

I followed "The Perfect Server" guide (http://www.howtoforge.com/perfect-se...ot-ispconfig-3) to the letter. Everything (except for mailman, which I chose not to install) seems to be working properly, no errors displayed whatsoever.

However, I can't access IPSConfig: neither through my OutsideIP:8080, nor through LocalIP:8080. All the virtual hosts that I have configured in Apache2 do load fine.

I am relatively new to Linux and I'm not sure how to troubleshoot this issue. Please advise how to proceed.

Thanks!
Reply With Quote
Sponsored Links
  #2  
Old 2nd April 2013, 12:17
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,169
Thanks: 829
Thanked 5,412 Times in 4,255 Posts
Default

So the problem occurred after a ispconfig update? You describe that you have already vhosts so you must have been able to access ispconfig before to create them as ispconfig requires a empty server on installation.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 2nd April 2013, 12:21
zkvvoob zkvvoob is offline
Junior Member
 
Join Date: Apr 2013
Posts: 11
Thanks: 3
Thanked 0 Times in 0 Posts
Default

So, it would appear that the problem might be the fact that I did not install ISPConfig on an empty server?

In my case I had configured LAMP, set up Apache with virtual hosts and carried on with my websites happily for some time - until I decided to add a mailserver and couldn't do it the command-line way, so I elected to finish the guide and install ISPConfig as well.

In other words, there's no way to rectify this with some small changes to the current setup without going through a complete OS reinstall?
Reply With Quote
  #4  
Old 2nd April 2013, 12:24
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,169
Thanks: 829
Thanked 5,412 Times in 4,255 Posts
Default

Quote:
So, it would appear that the problem might be the fact that I did not install ISPConfig on an empty server?
Yes, that might be the case as your manual configuration conflicts now with ispconfig.

It is possible to fix that most likely without a reinstall but it requires some debugging of the apache configuration. Please post the output of:

netstat -tap

and

iptables -L
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 2nd April 2013, 12:27
zkvvoob zkvvoob is offline
Junior Member
 
Join Date: Apr 2013
Posts: 11
Thanks: 3
Thanked 0 Times in 0 Posts
 
Default

Thank you for the assistance, till! Here are the outputs:

Code:
netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 localhost:9000          *:*                     LISTEN      2691/php-fpm.conf)
tcp        0      0 localhost:10024         *:*                     LISTEN      1497/amavisd (maste
tcp        0      0 localhost:10025         *:*                     LISTEN      2792/master
tcp        0      0 *:mysql                 *:*                     LISTEN      1075/mysqld
tcp        0      0 *:submission            *:*                     LISTEN      2792/master
tcp        0      0 *:http                  *:*                     LISTEN      3454/apache2
tcp        0      0 *:webmin                *:*                     LISTEN      2957/perl
tcp        0      0 *:81                    *:*                     LISTEN      3454/apache2
tcp        0      0 *:ssmtp                 *:*                     LISTEN      2792/master
tcp        0      0 *:ssh                   *:*                     LISTEN      918/sshd
tcp        0      0 localhost:ipp           *:*                     LISTEN      582/cupsd
tcp        0      0 *:smtp                  *:*                     LISTEN      2792/master
tcp        0      0 *:https                 *:*                     LISTEN      3454/apache2
tcp        0      0 *:1723                  *:*                     LISTEN      2797/pptpd
Code:
iptables -L
Chain INPUT (policy ACCEPT)
target     prot opt source               destination
fail2ban-dovecot-pop3imap  tcp  --  anywhere             anywhere             multiport dports pop3,pop3s,imap2,imaps
fail2ban-pureftpd  tcp  --  anywhere             anywhere             multiport dports ftp
fail2ban-ssh  tcp  --  anywhere             anywhere             multiport dports ssh

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination

Chain fail2ban-dovecot-pop3imap (1 references)
target     prot opt source               destination
RETURN     all  --  anywhere             anywhere

Chain fail2ban-pureftpd (1 references)
target     prot opt source               destination
RETURN     all  --  anywhere             anywhere

Chain fail2ban-ssh (1 references)
target     prot opt source               destination
RETURN     all  --  anywhere             anywhere
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Lost access to control panel on port 8080 Jeff Usher Installation/Configuration 3 24th February 2013 23:26
Can't access control panel using :8080 ali123 General 1 24th October 2010 12:42
Cannot access ISPConfig control panel via https:www.domain.com:81 isengaurd Installation/Configuration 2 27th September 2010 23:00
Webmin upgrade lishaw1968 Installation/Configuration 15 26th August 2010 15:23
[SOLVED] no access to control panel (port 81) atrias Installation/Configuration 6 22nd June 2008 23:21


All times are GMT +2. The time now is 11:48.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.