Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 9th August 2006, 23:37
iratik iratik is offline
Junior Member
 
Join Date: Aug 2006
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Default Email username and password do not work

I typed a 2 page post and it lost it because of a session timeout, please increase the session timeout.

I have just completed the "Ubuntu Dapper 6.06 LTS Perfect ISP Config" Setup. Verbose from boot cd to the ISP Config display of the address the utility was accessible from in 5 hours, no error messages, no typos, no mistakes.

After that, i copied the pkg url of uebimaui webmail and pasted into the update manager url field , selected url and the webmail component was installed successfully.

The following are instructions for exposing a bug in ISPConfig/Webmail
: ISP Config is not properly integrated with UebiMaui Email

From the blank installation with the webmail plugin installed (no clients, no sites, no hosting plans, nothing)
Click on "New Client"
Enter test for title, company and all other fields on "Master Data" except website and leave it http://
Click Site Management
Click New
Click Next
title: test
Domain: example.com
click create dns-mx
click mailuser login (These are the two options i guessed were pertinent to the webmail working or not)
click User&Email

Click new

Real Name: Test User
Email Address: webtest
Username: web4_test
Password: webtest
Click Save
(You will be back at ISP Site)
Click Save
Click Tools
Click Webmail

Enter webtest@example.com
Enter webtest as the password
Voila, the bug reveals itself
(No possible combination of users will work)
Tried
web1_webtest@example.com
webtest
test@example.com

Last edited by iratik; 9th August 2006 at 23:49.
Reply With Quote
Sponsored Links
  #2  
Old 10th August 2006, 11:39
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,991
Thanks: 825
Thanked 5,375 Times in 4,222 Posts
Default

You must send an email to the account first before you are able to login, the Maildir is created by postfix when the first email arrives.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 10th August 2006, 18:31
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Originally Posted by iratik
I typed a 2 page post and it lost it because of a session timeout, please increase the session timeout.
Please check "Remember me" when you log in. Then this doesn't happen.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 10th August 2006, 20:37
iratik iratik is offline
Junior Member
 
Join Date: Aug 2006
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Default Mail does not deliver properly?

Is there something wrong with my configuration?
If i set up example.com and send an email to (using sendmail) user1@example.com and look inside /var/mail
I see that the mail did not deliver to the correct maildir.

The maildir is created for user1, but empty - user1@example.com cannot login
Reply With Quote
  #5  
Old 11th August 2006, 10:23
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,991
Thanks: 825
Thanked 5,375 Times in 4,222 Posts
Default

If you use maildirs in ISPConfig, the maildirs where never created in /var/mail, the maildirs where created in the home directories of the users.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 11th August 2006, 15:13
iratik iratik is offline
Junior Member
 
Join Date: Aug 2006
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Question Improper Maildir Setup

I appreciate all your help on this, ISPConfig seems like the best option for what were trying to do.

There are no user directories under /home

admin
adminispconfig
ftp

and thats it. I'm not sure which configuration file might be off. But i'm guessing something in the MTA is amis.

# See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific: Specifying a file name will cause the first
# line of that file to be used as the name. The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

# TLS parameters
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache
# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = lonestart.loadmax.com
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
#mydestination = lonestart.loadmax.com, localhost.loadmax.com, , localhost
relayhost =
mynetworks = 127.0.0.0/8
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
inet_protocols = all
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
smtpd_sasl_auth_clients = yes
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject _unauth_destination
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom

virtual_maps = hash:/etc/postfix/virtusertable

mydestination = /etc/postfix/local-host-names


ISP Config is set up on a local machine in our network behind a router.
The hostname of that machine is "lonestart" and the domain iss "loadmax.com"

Something must be wrong here, is there anything I can do here to get mail working?
Reply With Quote
  #7  
Old 11th August 2006, 16:37
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

You can find the homedirs of the users created by ISPConfig in /etc/passwd. If you check these homedirs, you should find Maildir there.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 11th August 2006, 16:43
iratik iratik is offline
Junior Member
 
Join Date: Aug 2006
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs down No mail found in directory, is there something wrong with MTA


root@lonestart:/var/www/web7/user# ls -R web7_devolt
web7_devolt:
web

web7_devolt/web:
index.html
root@lonestart:/var/www/web7/user#


Am I mailing to the right address - according to the ispc config
it should be Thomas.Devol@loadmax.com but that doesn't work and neither does devolt@loadmax.com or web7_devolt@loadmax.com
Mail did end up in /var/mail/admin

Whats wrong?
Reply With Quote
  #9  
Old 11th August 2006, 17:22
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
 
Default

Did you enable Maildir under Management -> Server -> Settings -> Email in ISPConfig?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
UebiMiau locks out after server receives email sbecker Installation/Configuration 2 25th March 2006 00:00
Using different username for email dstme General 3 16th November 2005 17:27
Case Sensitive username for email Hellbound General 5 16th September 2005 15:10
Mail not accepting username and password! nformosa General 9 14th September 2005 09:58
Wrong username and password iceberg General 9 25th August 2005 21:48


All times are GMT +2. The time now is 15:57.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.