Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 22nd March 2013, 09:24
heri heri is offline
Junior Member
 
Join Date: May 2006
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default New mail filter crashes sys_datalog queue

Helo,
i tried to add a new mail filter (Email>Email Mailbox>Mail Filter>Add new Filter).
After saving the cron job crashes, leaving a lock file.
Looking in the sys_datalog queue i found something like this
Quote:
'a:2:{s:3:"old";a:33:{s:11:"mailuser_id";s:1:"1";s :10:"sys_userid";s:1:"2";s:11:"sys_groupid";s:1:"2 ";s:13:"sys_perm_user";s:4:"riud";s:14:"sys_perm_g roup";s:4:"riud";s:14:"sys_perm_other";s:0:"";s:9: "server_id";s:1:"1";s:5:"email";s:20:"info@xxxxxxx xxxxx.xx";s:5:"login";s:20:"info@xxxxxxxxxxxx.xx"; s:8:"password";s:34:"$1$62C/xxxxxxxxxxxxxxxxxxxxxxxxxx.";s:4:"name";s:12:"xxxx xxxxxxxx";s:3:"uid";s:4:"5000";s:3:"gid";s:4:"5000 ";s:7:"maildir";s:31:"/var/vmail/xxxxxxxxxxxx.xx/info";s:5:"quota";s:10:"8388608000";s:2:"cc";s:0:" ";s:7:"homedir";s:10:"/var/vmail";s:13:"autoresponder";s:1:"n";s:24:"autoresp onder_start_date";s:19:"0000-00-00 00:00:00";s:22:"autoresponder_end_date";s:19:"0000-00-00 00:00:00";s:21:"autoresponder_subject";s:19:"Out of office reply";s:18:"autoresponder_text";s:0:"";s:9:"move_ junk";s:1:"n";s:17:"custom_mailfilter";s:366:"### BEGIN FILTER_ID:6\r\n\r\n`test -e "$DEFAULT/.Junk" && exit 1 || exit 0`\r\nif ( $RETURNCODE != 1 )\r\n{\r\n `maildirmake -f "Junk" $DEFAULT`\r\n `chmod -R 0700 "$DEFAULT/.Junk"`\r\n `echo "INBOX.Junk" >> $DEFAULT/courierimapsubscribed`\r\n}\r\nif (/^Subject: \\[\\*\\*\\*SPAM\\*\\*\\*\\]/:h)\r\n{\r\nexception {\r\nID6EndFolder = "$DEFAULT/.Junk/"\r\nto $ID6EndFolder\r\n}\r\n}\r\n### END FILTER_ID:6\r\n";s:7:"postfix";s:1:"y";s:6:"access ";s:1:"n";s:11:"disableimap";s:1:"n";s:11:"disable pop3";s:1:"n";s:14:"disabledeliver";s:1:"n";s:11:" disablesmtp";s:1:"n";s:12:"disablesieve";s:1:"n";s :10:"disablelda";s:1:"n";s:14:"disabledoveadm";s:1 :"n";}s:3:"new";a:33:{s:11:"mailuser_id";s:1:"1";s :10:"sys_userid";s:1:"2";s:11:"sys_groupid";s:1:"2 ";s:13:"sys_perm_user";s:4:"riud";s:14:"sys_perm_g roup";s:4:"riud";s:14:"sys_perm_other";s:0:"";s:9: "server_id";s:1:"1";s:5:"email";s:20:"info@xxxxxxx xxxxx.xx";s:5:"login";s:20:"info@xxxxxxxxxxxx.xx"; s:8:"password";s:34:"$1$62C/xxxxxxxxxxxxxxxxxxxxxxxxxx.";s:4:"name";s:12:"xxxx xxxxxxxx";s:3:"uid";s:4:"5000";s:3:"gid";s:4:"5000 ";s:7:"maildir";s:31:"/var/vmail/xxxxxxxxxxxx.xx/info";s:5:"quota";s:10:"8388608000";s:2:"cc";s:0:" ";s:7:"homedir";s:10:"/var/vmail";s:13:"autoresponder";s:1:"n";s:24:"autoresp onder_start_date";s:19:"0000-00-00 00:00:00";s:22:"autoresponder_end_date";s:19:"0000-00-00 00:00:00";s:21:"autoresponder_subject";s:19:"Out of office reply";s:18:"autoresponder_text";s:0:"";s:9:"move_ junk";s:1:"n";s:17:"custom_mailfilter";s:349:"### BEGIN FILTER_ID:6\n\n`test -e "$DEFAULT/.Junk" && exit 1 || exit 0`\nif ( $RETURNCODE != 1 )\n{\n `maildirmake -f "Junk" $DEFAULT`\n `chmod -R 0700 "$DEFAULT/.Junk"`\n `echo "INBOX.Junk" >> $DEFAULT/courierimapsubscribed`\n}\nif (/^Subject: \\[\\*\\*\\*SPAM\\*\\*\\*\\]/:h)\n{\nexception {\nID6EndFolder = "$DEFAULT/.Junk/"\nto $ID6EndFolder\n}\n}\n### END FILTER_ID:6\n";s:7:"postfix";s:1:"y";s:6:"access"; s:1:"n";s:11:"disableimap";s:1:"n";s:11:"disablepo p3";s:1:"n";s:14:"disabledeliver";s:1:"n";s:11:"di sablesmtp";s:1:"n";s:12:"disablesieve";s:1:"n";s:1 0:"disablelda";s:1:"n";s:14:"disabledoveadm";s:1:" n";}}'
in the data field.
I assume that the problem is either a missing escaping or an encoding problem (maybe the "`" sign?)

The system: ispconfig 3.0.5.1, Debian 6, Courier
Reply With Quote
Sponsored Links
  #2  
Old 25th March 2013, 17:25
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,461
Thanks: 813
Thanked 5,244 Times in 4,110 Posts
 
Default

Please make a bugreport in the bugtracker with the exact values that you entered into the different fields of the mailfilter so we can verify and fix that.

http://bugtracker.ispconfig.org
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Tags
courier, filter, ispc3

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 3 Send/Receive mail not working. Acidut General 6 4th April 2010 11:24
localhost postfix/master: fatal: bind 127.0.0.1 port 125: Permission denied g18c Installation/Configuration 4 24th March 2009 17:39
Filtering emails using Spamassassin and Clamav for Exchange 2000 Server Rocky Server Operation 19 11th March 2008 08:27
Postfix reject connections gabrix Server Operation 27 25th January 2007 08:37
Can not recieve mail with de virtual mail adress Mounir Installation/Configuration 9 24th July 2006 23:16


All times are GMT +2. The time now is 10:03.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.