Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 27th March 2013, 16:15
j0nte j0nte is offline
Junior Member
 
Join Date: Mar 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Postfix does not notify on error

First off, postfix works fine if I use an adress that exists.
But if I send a email to a user/adress that does not exist I would want them to get a reply with that.
This is my mail.log
Code:
Mar 27 14:56:40 control postfix/smtpd[3419]: connect from mail-qe0-f49.google.com[209.85.128.49]
Mar 27 14:56:40 control postfix/smtpd[3419]: Anonymous TLS connection established from mail-qe0-f49.google.com[209.85.128.49]: TLSv1 with cipher ECDHE-RSA-RC4-SHA (128/128 bits)
Mar 27 14:56:40 control postfix/smtpd[3419]: NOQUEUE: reject: RCPT from mail-qe0-f49.google.com[209.85.128.49]: 450 4.1.1 <test@mydomain.com>: Recipient address rejected: User unknown in virtual mailbox table; from=<myname@gmail.com> to=<test@mydomain.com> proto=ESMTP helo=<mail-qe0-f49.google.com>
Mar 27 14:56:40 control postfix/smtpd[3419]: disconnect from mail-qe0-f49.google.com[209.85.128.49]

What I want is to get something like this to the sender:
Mail Delivery Subsystem <mailer-daemon@googlemail.com>
Delivery to the following recipient failed permanently:

example@domain.tld

Technical details of permanent failure:
Google tried to deliver your message, but it was rejected by the server for the recipient domain doman.tld by smtp.domain.tld. [1.2.3.4].

The error that the other server returned was:
550 5.1.1 <example@domain.tld>: Recipient address rejected: User unknown

----- Original message -----

Any help is appreciated.
Reply With Quote
Sponsored Links
  #2  
Old 28th March 2013, 13:30
pititis pititis is offline
Senior Member
 
Join Date: Dec 2010
Location: München
Posts: 364
Thanks: 39
Thanked 89 Times in 68 Posts
Default

You don't need do nothing. That message should be sent from mail-qe0-f49.google.com[209.85.128.49] to the sender.
Reply With Quote
  #3  
Old 29th March 2013, 16:16
j0nte j0nte is offline
Junior Member
 
Join Date: Mar 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by pititis View Post
You don't need do nothing. That message should be sent from mail-qe0-f49.google.com[209.85.128.49] to the sender.
I just noticed that it does, but after around 24-28 hours.
Is there any configuration issue here?
I would want the sender to get notified instantly!
Here is what I got in return.
Quote:
This is an automatically generated Delivery Status Notification

THIS IS A WARNING MESSAGE ONLY.

YOU DO NOT NEED TO RESEND YOUR MESSAGE.

Delivery to the following recipient has been delayed:

asdasdas@xxxx.re

Message will be retried for 1 more day(s)

Technical details of temporary failure:
Google tried to deliver your message, but it was rejected by the server for the recipient domain xxxx.re by mail.xxxx.re. [1.2.3.4].

The error that the other server returned was:
450 4.1.1 <asdasdas@xxxxx.re>: Recipient address rejected: User unknown in virtual mailbox table
Reply With Quote
  #4  
Old 30th March 2013, 00:54
pititis pititis is offline
Senior Member
 
Join Date: Dec 2010
Location: München
Posts: 364
Thanks: 39
Thanked 89 Times in 68 Posts
 
Default

They are the sender, so you can't control this. It's an issue from them.
Reply With Quote
The Following User Says Thank You to pititis For This Useful Post:
sistemas (15th April 2013)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix/courier/Centos 6 cant send email to external email servers maxtorzito Installation/Configuration 14 7th October 2011 11:56
Postfix SMTP Auth to Dovecot Not Working -- HELP! Scratchpad Server Operation 6 12th April 2011 14:29
All my mail is going to /var/mail/vmail _sluimers_ Installation/Configuration 21 10th January 2011 14:21
localhost postfix/master: fatal: bind 127.0.0.1 port 125: Permission denied g18c Installation/Configuration 4 24th March 2009 18:39
Installation Fails... :( cyberstorm Installation/Configuration 1 15th January 2006 19:07


All times are GMT +2. The time now is 10:24.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.