Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 14th March 2013, 22:17
SaintGermain SaintGermain is offline
Junior Member
 
Join Date: Mar 2013
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default Chrooting Apache2 With mod_chroot On Debian Squeeze

Hello,

I am becoming crazy with this problem.
I am trying to setup Apache 2.2.16 in a chroot with Debian Squeeze.

I followed the howto step by step using the symlink methods and then I couldn't access my website because of this error:
Quote:
Symbolic link not allowed or link target not accessible: /var/www
So I tried removing the symlink and directly put the directory in /var/www/var/www.
I then got an error:
Quote:
client denied by server configuration: /var
I checked that permissions for /var/www/var/www are OK.
I am accessing my website through the following url http://localhost/toto

Here is my httpd.conf (I don't use VirtualHost):
Quote:
Alias /toto /var/www/toto
<Directory /var/www/toto>
Options All
AllowOverride All
order allow,deny
allow from all
</Directory>
<Directory />
Order allow,deny
Options All
Allow from all
AllowOverride All
</Directory>
Can someone please help understand this problem ?

Thanks !
Reply With Quote
Sponsored Links
  #2  
Old 19th March 2013, 09:10
almere almere is offline
ISPConfig Developer
 
Join Date: Nov 2012
Location: Netherlands, Rotterdam
Posts: 231
Thanks: 20
Thanked 39 Times in 34 Posts
Send a message via Skype™ to almere
Default

Hi there.

Try to set Options FollowSymLinks in your apache config
Reply With Quote
  #3  
Old 19th March 2013, 10:47
SaintGermain SaintGermain is offline
Junior Member
 
Join Date: Mar 2013
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hello !

I have already tried FollowSymLinks and I have the same error message (Symbolic link not allowed or link target not accessible: /var/www ).

That's why I choose to directly move my website directory in the chroot in order to skip this problem: toto website directory is now directly in /var/www/var/www/toto (and I even left a copy in /var/www/toto in case I have misunderstood something).

So I am still a little confused why it still not work ?

Thanks for the help !
Reply With Quote
  #4  
Old 19th March 2013, 10:49
almere almere is offline
ISPConfig Developer
 
Join Date: Nov 2012
Location: Netherlands, Rotterdam
Posts: 231
Thanks: 20
Thanked 39 Times in 34 Posts
Send a message via Skype™ to almere
Default

Quote:
Originally Posted by SaintGermain View Post
Hello !

I have already tried FollowSymLinks and I have the same error message (Symbolic link not allowed or link target not accessible: /var/www ).

That's why I choose to directly move my website directory in the chroot in order to skip this problem: toto website directory is now directly in /var/www/var/www/toto (and I even left a copy in /var/www/toto in case I have misunderstood something).

So I am still a little confused why it still not work ?

Thanks for the help !
/var/www/var/www/toto
I see it for the first time... Do you have any errors in apache error log?
Reply With Quote
  #5  
Old 19th March 2013, 11:04
SaintGermain SaintGermain is offline
Junior Member
 
Join Date: Mar 2013
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes the following error:
Quote:
client denied by server configuration: /var
Reply With Quote
  #6  
Old 19th March 2013, 11:11
almere almere is offline
ISPConfig Developer
 
Join Date: Nov 2012
Location: Netherlands, Rotterdam
Posts: 231
Thanks: 20
Thanked 39 Times in 34 Posts
Send a message via Skype™ to almere
Default

Quote:
Originally Posted by SaintGermain View Post
Yes the following error:
Try this

Code:
<Directory /var>
  Order allow,deny
  Allow from all
</Directory>
Reply With Quote
  #7  
Old 19th March 2013, 11:14
SaintGermain SaintGermain is offline
Junior Member
 
Join Date: Mar 2013
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I think I already tried that with the same error but I am not sure anymore.
I will try again in 8 hours (not at home right now) and keep you updated !

Thanks !
Reply With Quote
  #8  
Old 19th March 2013, 21:48
SaintGermain SaintGermain is offline
Junior Member
 
Join Date: Mar 2013
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

I'll be damned, it works !!

Now I have to understand why it was not covered by the directive:

Code:
<Directory />
  Order allow,deny
  Options All
  Allow from all
  AllowOverride All
</Directory>
But thank you so much ! I have been stuck on this problem for hours !
Reply With Quote
Reply

Bookmarks

Tags
apache, chroot, debian

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Using mod_spdy With Apache2 On Debian Squeeze probs Ovidiu HOWTO-Related Questions 3 11th July 2012 18:19
Installation just stops, and dies. cosmicsafari Installation/Configuration 3 19th July 2011 10:24
[debian 5 + ispconfig 3] Unable to send mail tanakskool HOWTO-Related Questions 6 4th November 2009 18:20
Bind Failed christoph2k HOWTO-Related Questions 4 28th April 2007 00:57
e-mail problem!!! Debian 3.1 maroonworks Installation/Configuration 18 6th December 2005 14:42


All times are GMT +2. The time now is 00:50.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.