Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 14th March 2013, 14:32
msp msp is offline
Member
 
Join Date: Aug 2011
Posts: 41
Thanks: 2
Thanked 2 Times in 2 Posts
Default The Perfect Server - what to do when server already installed?

Apologies if this has been covered before here. It's quite hard with this topic to know what search terms to use on the forum!

I'm doing a clean install of ISPConfig3 and want to follow the "Perfect Server" guide for Debian Squeeze 6.0 (BIND & Dovecot).

Problem is it runs through the installation from CD or ISO (i.e. the full screen, menu based installation), and as part of this process it does lots of things e.g. configuring apt..., whereas my VPS is deployed as a 'vanilla install' of some sort. They simply give you the option of which distribution to install, set the disk size, root password, swap disk, and that's it.

Is there a process guide for installing The Perfect Server from a distro that has already been installed?

Hope the above makes sense

Mat

Last edited by msp; 14th March 2013 at 17:09.
Reply With Quote
Sponsored Links
  #2  
Old 14th March 2013, 20:20
pdxvwerik pdxvwerik is offline
Junior Member
 
Join Date: Mar 2013
Posts: 16
Thanks: 2
Thanked 5 Times in 1 Post
Default

I had the same issue, but with CentOS.

It really was no problem. Just go through the process and follow the instructions carefully. Pretend that it is a clean minimal install.

If you have issues when completing the install, note those issues, you may need to uninstall ISPConfig and go through the process again noting things to change as you go, ie: apt-get remove sendmail (as an example) before you continue with the walkthrough.

Note, if you are using godaddy's vps, you have to use 'relayhost=['servernamehere']' as the relay host. Remember the brackets, they are important.

I was unable to find a mod_ruby.so for CentOS/64 bit and I skipped configuring Apache with Ruby with no apparent consequences outside of being unable to offer Ruby as an option.

GL
Reply With Quote
  #3  
Old 19th March 2013, 02:26
darinpeterson darinpeterson is offline
HowtoForge Supporter
 
Join Date: Nov 2011
Posts: 153
Thanks: 35
Thanked 13 Times in 13 Posts
Default

This is no problem, and just about anywhere you get a VPS, dedicated server, or other, they are going to install some default that they have for you. My service provider was good enough to allow me to tell them how I wanted it installed. If you can do this, just ask for the basic system with an ssh server.

It doesn't matter though. If they provided you with something already, just use this howto: http://www.howtoforge.com/perfect-se...ispconfig-3-p3, starting on page 3 as I marked and follow. In general, you should be fine. If a package is already installed, it won't reinstall it, and things that aren't installed will be installed.

Good luck!

Darin
Reply With Quote
  #4  
Old 19th March 2013, 13:11
msp msp is offline
Member
 
Join Date: Aug 2011
Posts: 41
Thanks: 2
Thanked 2 Times in 2 Posts
 
Default

Thanks GL & Darin,

I'll try the above!

Regards,

Mat

Last edited by msp; 19th March 2013 at 13:17.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig3 mail doesn't work pehden Installation/Configuration 20 9th December 2013 14:05
Virtual Users+Postfix+Courier+CentOS problem telnet localhost 25 stinson HOWTO-Related Questions 11 5th February 2011 13:57
Webmail problems with only one domain? compner Installation/Configuration 14 16th February 2010 16:59
Problems with Yum following The Perfect Server - CentOS 5.3 x86_64 Guide GOPalmer HOWTO-Related Questions 7 1st July 2009 14:20
subdomain and mail relay configuration aranthorn Installation/Configuration 24 3rd September 2007 22:53


All times are GMT +2. The time now is 02:33.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.