Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #21  
Old 10th August 2006, 09:37
todvard todvard is offline
Member
 
Join Date: Aug 2005
Posts: 85
Thanks: 1
Thanked 6 Times in 5 Posts
Default

do the procmail package installed properly? do you have formail utility on your PATH?
Reply With Quote
Sponsored Links
  #22  
Old 10th August 2006, 09:47
Ben Ben is offline
Moderator
 
Join Date: Jul 2006
Posts: 1,029
Thanks: 7
Thanked 62 Times in 56 Posts
Default

Quote:
Originally Posted by todvard
do the procmail package installed properly? do you have formail utility on your PATH?
don't know if it installed properly how to I check that the best?

I will check the path thing
Reply With Quote
  #23  
Old 10th August 2006, 10:09
todvard todvard is offline
Member
 
Join Date: Aug 2005
Posts: 85
Thanks: 1
Thanked 6 Times in 5 Posts
Default

if you are using debian or ubuntu just reinstall it:
Code:
apt-get --reinstall install procmail
Reply With Quote
  #24  
Old 10th August 2006, 11:02
Ben Ben is offline
Moderator
 
Join Date: Jul 2006
Posts: 1,029
Thanks: 7
Thanked 62 Times in 56 Posts
Default

reinstall worked fine, formail is in the path I guess, which finds it without any problems.
Reply With Quote
  #25  
Old 10th August 2006, 13:21
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Send a message via Skype™ to Hans
Default The contents of the required files

@Todvart: apt-get --reinstall install procmail worked fine.

Quote:
Originally Posted by till
It seems that the sender is not set with the complete domain name.

Whats in the file .autoresponder.rc in the home directory of an autoresponder that does not function properly?
The contents of autoresponder.rc.master:

SHELL=/bin/sh # for other shells, this might need adjustment
EMAIL=`formail -zxTo:`

:0 Whc: vacation.lock
# Perform a quick check to see if the mail was addressed to us
#* $^To:.*\<$\LOGNAME\>
# Don't reply to daemons and mailinglists
* !^FROM_DAEMON
# Mail loops are evil
* !^X-Loop: ${EMAIL}
| formail -rD 8192 {PFAD}/.vacation.cache

:0 ehc # if the name was not in the cache
| (formail -rI"From: {EMAIL_ADDRESS}" -I"Precedence: junk" \
-A"X-Loop: ${EMAIL}" ; \
cat {PFAD}/.vacation.msg \
) | $SENDMAIL -oi -t


My contents of the users .autoresponder.rc file which is within the users home dir:

SHELL=/bin/sh # for other shells, this might need adjustment
EMAIL=`formail -zxTo:`

:0 Whc: vacation.lock
# Perform a quick check to see if the mail was addressed to us
#* $^To:.*\<$\LOGNAME\>
# Don't reply to daemons and mailinglists
* !^FROM_DAEMON
# Mail loops are evil
* !^X-Loop: ${EMAIL}
| formail -rD 8192 /var/www/web5/user/test/.vacation.cache

:0 ehc # if the name was not in the cache
| (formail -rI"From: test@mydomain.tld" -I"Precedence: junk" \
-A"X-Loop: ${EMAIL}" ; \
cat /var/www/web5/user/test/.vacation.msg \
) | $SENDMAIL -oi -t


An .vacation.msg exits in the users home dir as well:
The contents of this file is the autorespondermessage as it should contain, so that's ok too.

An .vacation.cache exists in the users home dir too:
The contents of this file is:

sender@domain.tld^@^@


So the mentioned files above seems to be ok, it is a miracle to me that the autoresponder is not sent to emailaddresses outsite my server!

What can i do/check else to make it work?
I have to mention that the files .vacation.msg and .vacation.cache are hidden files. Is this ok?
__________________
Hans

BB-Hosting | Quality Web Hosting since 2005

Last edited by Hans; 10th August 2006 at 13:24.
Reply With Quote
  #26  
Old 11th August 2006, 19:59
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Send a message via Skype™ to Hans
Default Strange behaviour | autoresponder ISPConfig 2.2.6

I am still trying to get my autoresponder to work. and I discovered something very strange:

When i send an email with an emailaddress (at my server) to the mailbox with the autoresponder enabled (also on my server) the autoresponder works great!

When i send an email with hotmail to to the mailbox with the autoresponder enabled (on my server) the autoresponder works great too!

When i send an email with my private emailadress from my ADSL-provider at home, which is XS4ALL, the autoresponder does NOT function.
A message with a postfix error appears: No thank you rejected: need fully-qualified address (in reply to RCPT TO command)

When i send an email with another emailaddress at domain operamail.com the autoresponder does not function too, but the process behaves like there is no autoresponder enabled. With other words: The message arrives, but no autoresponder is send.

(I was thinking that my autoresponder did not function for external mailaddresses, for Hotmail it works!) For my other external emailaddresses it fails AND the behaviour is not the same!

I really do not understand anymore.
__________________
Hans

BB-Hosting | Quality Web Hosting since 2005
Reply With Quote
  #27  
Old 11th August 2006, 21:32
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Send a message via Skype™ to Hans
Default

A few hours later now...
I did some tests again.

Now even with a hotmailaddress it does not work.
No delivery failures. Looks like the autoresponder is disabled, but it is not!

At least the autoresponder functioned once.

Can anyone help me out?
__________________
Hans

BB-Hosting | Quality Web Hosting since 2005

Last edited by Hans; 11th August 2006 at 21:39.
Reply With Quote
  #28  
Old 12th August 2006, 03:32
jockstrap jockstrap is offline
Member
 
Join Date: Jul 2006
Posts: 55
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hans - not sure if you know this - I didn't till TILL told me.

The auto responder only sends the reply once! per "from" email. Stores that email in the .vacation.cache file... so you will only ever get one autoresponder reply from any one email addy!

from V2.2.5 - the change was supposed to delete .vacation.cache when you turn off autoresponder and set it back when you turn it back on - that way clearing the cache so if you have a new message, the pervious email will now get it "only once" again...

Hope this makes sense...


If you want a reply every time an email is sent I think you can remove the "D" switch from the following line in the .autoresponder file

| formail -rD 8192 /var/www/web5/user/test/.vacation.cache

change to

| formail -r 8192 /var/www/web5/user/test/.vacation.cache

Last edited by jockstrap; 12th August 2006 at 03:35.
Reply With Quote
  #29  
Old 12th August 2006, 12:59
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Send a message via Skype™ to Hans
Smile

Ok, thank you very much!

That explains a little more. I check this out!
__________________
Hans

BB-Hosting | Quality Web Hosting since 2005
Reply With Quote
  #30  
Old 12th August 2006, 14:27
jockstrap jockstrap is offline
Member
 
Join Date: Jul 2006
Posts: 55
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

@ Falko and Till

I created a new virtual guest and installed V2.2.6 fresh and roundcubemail.
Seems autoresponder is working from sites such as hotmail, gmail, my work ,etc but not from my local lan email servers - this is where all my testing was done before and so why I was saying autoresponder is not working. I can not still understand why my mail server on another server (windows 2000) does not get the reply back - i can only think its becasue they are hosts on the same domain and some sort of netowrk confusion going on?????? anyway - any external mail gets responded to so i'm sort of happy now

Oh - and my roundcubemail is working sweet! I think it should be the default email client in your package - it's so much nicer than the others - lol

Last edited by jockstrap; 12th August 2006 at 14:30.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 2.2.4 released till General 25 18th July 2006 13:04
ISPConfig 2.2.3 released till General 16 14th June 2006 00:42
ISPConfig 2.2.1 released till General 11 28th May 2006 10:39
ISPConfig 2.3.1-dev released till General 0 8th May 2006 22:18
ISPConfig 2.0.8 released till General 6 29th August 2005 10:43


All times are GMT +2. The time now is 06:10.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.