Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 9th August 2006, 15:00
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,446
Thanks: 813
Thanked 5,216 Times in 4,089 Posts
Default

Quote:
Originally Posted by jockstrap
Mail log shows message received and passed to correct user and then forwarded to adminisconfig@localhost - and that's it! no errors I can see, just no autoresponder... and still an empty vacation.cache file!
Is the autoresponder procmail script included in the .procmailrc file in the users home directory? Is the autoresponder script there?

If yes, please try to send a second email.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Sponsored Links
  #12  
Old 9th August 2006, 15:17
jockstrap jockstrap is offline
Member
 
Join Date: Jul 2006
Posts: 55
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes - it's there..

MAILDIR=$HOME/Maildir/
DEFAULT=$MAILDIR
ORGMAIL=$MAILDIR

INCLUDERC=/var/www/web1/user/twadmin/.mailsize.rc
## INCLUDERC=/var/www/web1/user/twadmin/.quota.rc
## INCLUDERC=/var/www/web1/user/twadmin/.antivirus.rc
## INCLUDERC=/var/www/web1/user/twadmin/.local-rules.rc
## INCLUDERC=/var/www/web1/user/twadmin/.html-trap.rc
## INCLUDERC=/var/www/web1/user/twadmin/.spamassassin.rc
INCLUDERC=/var/www/web1/user/twadmin/.autoresponder.rc

What has changed from V2.2.4 --> 5 that may have stopped it working you think ?

got me stumpped! I've even chmodded the entire web1 directory and sub-dirs to 777 so that i can rule out permissions... still no .vacation.cache created nor any email replied to!


Getting this in the mail.log;

postfix/local[27805]: A4123C9C020: to=<twadmin@xxx.com>, orig_to=<admin@xyz.com>,
relay=local, delay=0, status=sent (delivered to command: /usr/bin/procmail -f-)

is the end correct ??? -f- ???

Last edited by jockstrap; 9th August 2006 at 15:45.
Reply With Quote
  #13  
Old 9th August 2006, 17:16
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Send a message via Skype™ to Hans
Arrow Autoresponder is functioning for 50%

I just upgraded two servers from ISPConfig 2.2.5 to 2.2.6 without any problems. So that's good!

On these Debian 3.1 servers, I have no .vacation.cache file in the /var/www/web1/user/userid directory either.

I have the following situation:
When i send an email from an emailaddress from a domain on my server to the mailbox with the autoresponder enabled, the autoresponder works as it should be.

When i send an email from a domain which is NOT on my server, the autoresponder does not function:
The message is bounced back with a Postfix message: Domain name required for sender address test (in reply to MAIL FROM command)

I think the MTA does not look to the whole emailadres like username@domain.tld but only to username. The MTA can not find the username (of course) because it is an emailaddress outsite my server.


How, can i fix this problem?
__________________
Hans

BB-Hosting | Quality Web Hosting since 2005

Last edited by Hans; 9th August 2006 at 18:23.
Reply With Quote
  #14  
Old 9th August 2006, 18:21
Ben Ben is offline
Moderator
 
Join Date: Jul 2006
Posts: 1,029
Thanks: 7
Thanked 62 Times in 56 Posts
Default

Quote:
Originally Posted by Hans
I just upgraded two servers from ISPConfig 2.2.5 to 2.2.6 without any problems. So that's good!

On these Debian 3.1 servers, I have no .vacation.cache file in the /var/www/web1/user/userid directory either.

I have the following situation:
When i send an email from an emailaddress from a domain on my server to the mailbox with the autoresponder enabled, the autoresponder works as it should be.

When i send an email from a domain which is NOT on my server, the autoresponder does not function.

How, can i fix this problem?
Yes, I can confirm that, usign 2.2.5. Only mails sent from zones hosted on th same machine get a response, from antoher server they don't.
Reply With Quote
  #15  
Old 9th August 2006, 18:27
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Send a message via Skype™ to Hans
Default

Ok thanks Ben,

But then we one more thing to do.
I will have a look as well:

I found an article at http://www.knowplace.org/pages/howto...mail_howto.php

Can this be usefull for our ISPConfig-servers?
__________________
Hans

BB-Hosting | Quality Web Hosting since 2005

Last edited by Hans; 9th August 2006 at 19:14.
Reply With Quote
  #16  
Old 9th August 2006, 19:05
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,446
Thanks: 813
Thanked 5,216 Times in 4,089 Posts
Default

Quote:
Originally Posted by Hans
How, can i fix this problem?
It seems that the sender is not set with the complete domain name.

Whats in the file .autoresponder.rc in the home directory of an autoresponder that does not function properly?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #17  
Old 9th August 2006, 19:11
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,446
Thanks: 813
Thanked 5,216 Times in 4,089 Posts
Default

Quote:
Originally Posted by Tenaka
I just upgraded too and noticed a problem but I am not sure whether it has to do with this upgrade.

I have a domain zice.ro which has severall users called web5_xxxx. when I try to add a new user it adds a web5_xxx user.

when I add a new database it adds a web8_dbX ??? why web8 ? I have a web8 but thats another site of another customer.

any idea? can somebody help fix this?

###edit###

I can see web8_db2 in both sites hosted on my server, I tried clicking on the web8_db2 from web8 and got this error: if I try to click on the web8_db2 I can change the passw or delete it and I just successfully deleted it.

I just tried to create another db from web5 and indeed now it is called web5_db1.

If this has nothing to do with the upgrade feel free to delete my post.
I think this is not related to the update, it looks like one of the dependency records of this database has the wrong user or group ID settings.

Please let us discuss this in a separate thread.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #18  
Old 9th August 2006, 23:01
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Send a message via Skype™ to Hans
Unhappy location of .autoresponder.rc

Till,

You asked me:

Whats in the file .autoresponder.rc in the home directory of an autoresponder that does not function properly?

My answer is:

I can not find such a file...

What can be wrong?
__________________
Hans

BB-Hosting | Quality Web Hosting since 2005
Reply With Quote
  #19  
Old 9th August 2006, 23:50
todvard todvard is offline
Member
 
Join Date: Aug 2005
Posts: 85
Thanks: 1
Thanked 6 Times in 5 Posts
Default

do you have autoresponder.rc.master file in the /root/ispconfig/isp/conf folder? what is the content of that file? What is happening when you try to update the users rc files by hand? (see Till's post here http://www.howtoforge.com/forums/showthread.php?t=5750)

Last edited by todvard; 10th August 2006 at 00:36.
Reply With Quote
  #20  
Old 10th August 2006, 09:01
Ben Ben is offline
Moderator
 
Join Date: Jul 2006
Posts: 1,029
Thanks: 7
Thanked 62 Times in 56 Posts
 
Default

Well in my case there is a .autoresponder.rc in the users home with the following content:

Quote:
SHELL=/bin/sh # for other shells, this might need adjustment
EMAIL=`formail -zxTo:`

:0 Whc: vacation.lock
# Perform a quick check to see if the mail was addressed to us
#* $^To:.*\<$\LOGNAME\>
# Don't reply to daemons and mailinglists
* !^FROM_DAEMON
# Mail loops are evil
* !^X-Loop: ${EMAIL}
| formail -rD 8192 .vacation.cache

:0 ehc # if the name was not in the cache
| (formail -rI"From: test@get-digital.de" -I"Precedence: junk" \
-A"X-Loop: ${EMAIL}" ; \
cat /home/www/web3/user/w3_test/.vacation.msg \
) | $SENDMAIL -oi -t
If I take a look at the diff of the master and the users file seems like all replacements worked fine.

.vacation.msg exists, .vacation.cache not.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 2.2.4 released till General 25 18th July 2006 13:04
ISPConfig 2.2.3 released till General 16 14th June 2006 00:42
ISPConfig 2.2.1 released till General 11 28th May 2006 10:39
ISPConfig 2.3.1-dev released till General 0 8th May 2006 22:18
ISPConfig 2.0.8 released till General 6 29th August 2005 10:43


All times are GMT +2. The time now is 04:08.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.