Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 13th March 2013, 15:22
dclardy dclardy is offline
Senior Member
 
Join Date: Sep 2009
Location: Dallas, TX
Posts: 347
Thanks: 10
Thanked 47 Times in 28 Posts
Default Theme Change Issues

Is anyone having issues with themes in ISPConfig 3 - 3.0.5.1?

I copied the new default theme to make my version of a theme, and it does not seem to like it. After I logout, it always tries to show me a different theme, and it gives me a compatibility error. I then have to go to Tools -> Interface -> Pick my theme, and it works fine.

Is it not storing something properly? Kind of tired of it always changing.
Reply With Quote
Sponsored Links
  #2  
Old 13th March 2013, 15:36
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,408
Thanks: 834
Thanked 5,496 Times in 4,326 Posts
Default

ensure that you changed the default theme also in the config.inc.php file of the interface as the theme defined there is used for the login.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 13th March 2013, 15:39
dclardy dclardy is offline
Senior Member
 
Join Date: Sep 2009
Location: Dallas, TX
Posts: 347
Thanks: 10
Thanked 47 Times in 28 Posts
Default

Till,

I did that. It tries to revert it back when I login. Not sure what is going on.

It had never done that in the past, but it started happening with 3.0.5.*. It shows the correct logo in the old theme. So it is taking that part.
Reply With Quote
  #4  
Old 13th March 2013, 15:41
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,408
Thanks: 834
Thanked 5,496 Times in 4,326 Posts
Default

There raev 2 places were the theme is storde, the config.inc.php page for the global setting and the settings of the ispconfig system user that you used to login. ensure that you select the same theme in both places.

also ensure that you updated your theme for ispconfig 3.0.5, some of the templates ahve changed from 3.0.4.6.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 13th March 2013, 15:45
dclardy dclardy is offline
Senior Member
 
Join Date: Sep 2009
Location: Dallas, TX
Posts: 347
Thanks: 10
Thanked 47 Times in 28 Posts
Default

Till,

The changes have been made in the Config.inc.php file. I have also made them in the System -> CP Users -> Design section. <- These seem to have no effect.

To get it to work, I have to change Tools -> Interface -> Design. The value is selected there, but it does not show that theme. I have to re-press save to get it to apply.

If you would like, I can give you a login. It is happening for all users.
Reply With Quote
  #6  
Old 13th March 2013, 15:54
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,408
Thanks: 834
Thanked 5,496 Times in 4,326 Posts
Default

Quote:
To get it to work, I have to change Tools -> Interface -> Design.
Thats the exact same setting then System -> CP Users -> Design
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 13th March 2013, 15:59
dclardy dclardy is offline
Senior Member
 
Join Date: Sep 2009
Location: Dallas, TX
Posts: 347
Thanks: 10
Thanked 47 Times in 28 Posts
Default

Alright. Then they both don't work for me. Not sure what I could be doing wrong.
Reply With Quote
  #8  
Old 13th March 2013, 16:01
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,408
Thanks: 834
Thanked 5,496 Times in 4,326 Posts
Default

You can verify if they get applied by looking into the sys_user table with phpmyadmin. If the new theme name is listed there for the user you changed it then this theme is used by the user.

Did you check your theme files that they dont contain any paths to css files or similar inludes of the default theme so thet the css from there is loaded instead of the files of your theme?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 13th March 2013, 16:06
dclardy dclardy is offline
Senior Member
 
Join Date: Sep 2009
Location: Dallas, TX
Posts: 347
Thanks: 10
Thanked 47 Times in 28 Posts
Default

Till,

All links are to my theme. It works after I press save.

The theme settings are correct in the sys_user table.


Last edited by dclardy; 13th March 2013 at 16:09.
Reply With Quote
  #10  
Old 13th March 2013, 18:46
dclardy dclardy is offline
Senior Member
 
Join Date: Sep 2009
Location: Dallas, TX
Posts: 347
Thanks: 10
Thanked 47 Times in 28 Posts
 
Default

Till,

Here is another example of the theme being deactivated at startup. There is nothing wrong with the theme. It is an exact copy of the default theme with some styling changes.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
CentOS 6.3 - Change From Single Private IP To Multiple Public IP Block Unfaiir Installation/Configuration 3 14th February 2013 10:18
Cannot change ISPConfig theme todx General 4 30th April 2012 15:26
Issues with Change SQL Password plugin for Squirrel Mail on Centos 5.4 and ISPConfig3 centosarus Installation/Configuration 6 4th May 2010 15:59
Two FTP Issues: Change Port and Alerts jonwatson Installation/Configuration 3 13th February 2009 13:49
Change the default language and theme Felipe Tips/Tricks/Mods 2 13th December 2005 17:11


All times are GMT +2. The time now is 13:48.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.