#1  
Old 5th August 2013, 03:58
pawan pawan is offline
Senior Member
 
Join Date: Jul 2010
Posts: 222
Thanks: 44
Thanked 6 Times in 6 Posts
Default opt php for php fpm not working

I have installed additional php versions on ubuntu server 12.04 following the how to forge guide.

The PHP FPM is running fine on the server. In ispconfig control panel I am able to select and assign the opt/php fpm to a website. The /etc/pool.d/ folder is correctly getting populated with conf file.

The problem is when I am check in my joomla installation the default php version showing and there is no effect of the change.

But if I apply the opt php for fast-cgi the changed are reflected in joomla installation without any problem.
Reply With Quote
Sponsored Links
  #2  
Old 5th August 2013, 10:17
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
Default

http://www.howtoforge.com/forums/showthread.php?t=58408
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 11th August 2013, 02:01
pawan pawan is offline
Senior Member
 
Join Date: Jul 2010
Posts: 222
Thanks: 44
Thanked 6 Times in 6 Posts
 
Default

Ok Till sorry for not providing the details

Server - ubuntu 12.04
Apache - Apache/2.2.22 (Ubuntu)
PHP default - 5.3.10-1ubuntu3.7
ISPCONFIG - 3.0.5.3

Everything looks ok as I already stated, but the php info in joomla just stays to default php for PHP-FPM.
But if I choose PHP Fast CGI for /opt php it works find.
So the problem is just in using php fpm as /opt


Name:  php-fpm-setting.png
Views: 79
Size:  23.3 KB

Name:  website-setting.png
Views: 76
Size:  9.1 KB

contents of vhost.conf created in pool.d

Code:
[web13]

listen = 127.0.0.1:9022
listen.allowed_clients = 127.0.0.1

user = web13
group = client2

pm = dynamic
pm.max_children = 50
pm.start_servers = 20
pm.min_spare_servers = 5
pm.max_spare_servers = 35
pm.max_requests = 0

chdir = /

php_admin_value[open_basedir] = /var/www/clients/client2/web13/web:/var/www/clients/client2/web13/tmp:/var/www/mywebsolutions.co.in/web:/srv/www/mywebsolutions.co.in/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin:/usr/share/php
php_admin_value[session.save_path] = /var/www/clients/client2/web13/tmp
php_admin_value[upload_tmp_dir] = /var/www/clients/client2/web13/tmp

php_admin_value[output_buffering] = Off;
php_admin_value[allow_url_include] = on;
php_admin_value[max_execution_time] = 60;
php_admin_value[error_reporting] = E_ALL;
php_admin_value[display_errors] = On;
thanks.

Last edited by pawan; 11th August 2013 at 02:06.
Reply With Quote
Reply

Bookmarks

Tags
additional php

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 3.0.3.3 fresh instalation - email tab is empty artur_gib Installation/Configuration 14 28th January 2014 20:02
ubuntu and nginx delgado2061 Installation/Configuration 0 28th November 2011 00:36
Centos 6.0 support Acid_Scorpion Developers' Forum 47 16th September 2011 11:36
ISPConfig3 Debian Squeeze Crontab - Log petrichbg Installation/Configuration 5 22nd March 2011 13:25
Freebsd 6.1 support misterm Installation/Configuration 10 9th April 2009 10:29


All times are GMT +2. The time now is 10:54.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.