Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Tips/Tricks/Mods

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 3rd March 2013, 21:21
JeffryL JeffryL is offline
Member
 
Join Date: Apr 2011
Posts: 36
Thanks: 10
Thanked 0 Times in 0 Posts
Default Ubuntu Multiserver Ispconfig Roundcube Setup Problem

I made two servers both running ISPConfig 3.0.5.1 and Ubuntu 12.04 LTS

Server One:
Web + FTP + DB + Webpanel

Server Two:
Mail + DNS

I want Roundcube to run on Server One and connecting to Server Two. I ran

Code:
apt-get install roundcube
and then:

Code:
dpgk-reconfigure roundcube-core
to set all the settings.

I used the standard config file for apache in conf.d and only changed the alias to webmail:

Code:
# Those aliases do not work properly with several hosts on your apache server
# Uncomment them to use it or adapt them to your configuration
#    Alias /roundcube/program/js/tiny_mce/ /usr/share/tinymce/www/
    Alias /webmail /var/lib/roundcube

# Access to tinymce files
<Directory "/usr/share/tinymce/www/">
      Options Indexes MultiViews FollowSymLinks
      AllowOverride None
      Order allow,deny
      allow from all
</Directory>

<Directory /var/lib/roundcube/>
  Options +FollowSymLinks
  # This is needed to parse /var/lib/roundcube/.htaccess. See its
  # content before setting AllowOverride to None.
  AllowOverride All
  order allow,deny
  allow from all
</Directory>

# Protecting basic directories:
<Directory /var/lib/roundcube/config>
        Options -FollowSymLinks
        AllowOverride None
</Directory>

<Directory /var/lib/roundcube/temp>
        Options -FollowSymLinks
        AllowOverride None
	Order allow,deny
	Deny from all
</Directory>

<Directory /var/lib/roundcube/logs>
        Options -FollowSymLinks
        AllowOverride None
	Order allow,deny
	Deny from all
</Directory>
This works straight away when I approach the server by http://servername/webmail, but not when I approach by approaching different sites setup by ISPConfig. The sites are setup with PHP-FPM. So I figured out that openbase settings might be restricting.

Therefore I changed the openbase settings in ISPConfig and added:
/var/lib/roundcube
/var/lib/roundcube/config
/etc/roundcube
/usr/share/roundcube

This resulted in some effect... I do not longer see a blank page, but now it complains that main.inc.php was not found. While this file is in /etc/roundcube and is configured. (Otherwise the direct approach wouldn't work, right?)

I see the following errors in the error.log:
Code:
[Sun Mar 03 20:15:34 2013] [error] [client xxx] FastCGI: server "/var/www/clients/client1/web9/cgi-bin/php5-fcgi-*-80-site.com" stderr: PHP message: PHP Warning:  include_once(/etc/roundcube/debian-db.php): failed to open stream: Permission denied in /etc/roundcube/db.inc.php on line 19
[Sun Mar 03 20:15:34 2013] [error] [client xxx] FastCGI: server "/var/www/clients/client1/web9/cgi-bin/php5-fcgi-*-80-site.com" stderr: PHP message: PHP Warning:  include_once(): Failed opening '/etc/roundcube/debian-db.php' for inclusion (include_path='/var/lib/roundcube/program/lib:.:/usr/share/php:/usr/share/pear') in /etc/roundcube/db.inc.php on line 19
[Sun Mar 03 20:15:34 2013] [error] [client xxx] FastCGI: server "/var/www/clients/client1/web9/cgi-bin/php5-fcgi-*-80-site.com" stderr: PHP message: PHP Deprecated:  Assigning the return value of new by reference is deprecated in /usr/share/php/MDB2.php on line 393
[Sun Mar 03 20:15:34 2013] [error] [client xxx] FastCGI: server "/var/www/clients/client1/web9/cgi-bin/php5-fcgi-*-80-site.com" stderr: PHP message: PHP Deprecated:  Assigning the return value of new by reference is deprecated in /usr/share/php/MDB2.php on line 2647
[Sun Mar 03 20:15:34 2013] [error] [client xxx] FastCGI: server "/var/www/clients/client1/web9/cgi-bin/php5-fcgi-*-80-site.com" stderr: PHP message: MDB2 Error: not found (-4): no RDBMS driver specified
I'm a bit lost right now... what could be wrong?

Last edited by JeffryL; 3rd March 2013 at 21:24.
Reply With Quote
Sponsored Links
  #2  
Old 4th March 2013, 21:09
JeffryL JeffryL is offline
Member
 
Join Date: Apr 2011
Posts: 36
Thanks: 10
Thanked 0 Times in 0 Posts
 
Default

Ok.. sometimes solutions aren't that hard...

The problem was the permissions on the files in /etc/roundcube. All should be 644 and both debian.db.php and main.inc.php were for some reason different then the others (640).
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 3.0.3.3 fresh instalation - email tab is empty artur_gib Installation/Configuration 14 28th January 2014 19:02
How to upgrade Roundcube 0.3 to 0.7 on Ubuntu 10.04 LTS cbj4074 Tips/Tricks/Mods 1 19th January 2012 19:50
Need some Hints to "The Perfect Server - Debian Lenny (Debian 5.0) [ISPConfig 3]" wahid HOWTO-Related Questions 10 25th August 2010 15:18
ISPconfig setup - DNS, router and general access problems ingvar Installation/Configuration 6 31st July 2010 13:13
ISPConfig3 Mail Warn Errors reason8 General 3 25th November 2009 13:58


All times are GMT +2. The time now is 17:56.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.