Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 1st March 2013, 12:25
trexen trexen is offline
Senior Member
 
Join Date: Jun 2008
Location: Stockholm
Posts: 169
Thanks: 15
Thanked 3 Times in 2 Posts
Default

My suphp.conf
i did have squrillelmail installed before roundqube.
is this file correct?



<IfModule mod_suphp.c>
AddType application/x-httpd-suphp .php .php3 .php4 .php5 .phtml
suPHP_AddHandler application/x-httpd-suphp

<Directory />
suPHP_Engine on
</Directory>


# By default, disable suPHP for debian packaged web applications as files
# are owned by root and cannot be executed by suPHP because of min_uid.
<Directory /usr/share>
suPHP_Engine off
</Directory>

# # Use a specific php config file (a dir which contains a php.ini file)
# suPHP_ConfigPath /etc/php4/cgi/suphp/
# # Tells mod_suphp NOT to handle requests with the type <mime-type>.
# suPHP_RemoveHandler <mime-type>
</IfModule>

//M
Reply With Quote
Sponsored Links
  #12  
Old 2nd March 2013, 00:24
beyerservice beyerservice is offline
Member
 
Join Date: Feb 2011
Location: /dev/null
Posts: 30
Thanks: 10
Thanked 6 Times in 5 Posts
Default

for someone found this after searching google for that error:

Solution:
Add red-Lines if not in your roundcube.conf file.
[...]
<Directory /var/www/roundcubemail>
Options FollowSymLinks

<IfModule mod_php5.c>
AddType application/x-httpd-php .php
php_flag magic_quotes_gpc Off
php_flag track_vars On
php_admin_flag allow_url_fopen Off
php_value include_path .
php_admin_value upload_tmp_dir /var/www/roundcubemail/temp
php_admin_value open_basedir /var/www/roundcubemail:/etc/hostname:/etc/mailname
php_flag register_globals off
</IfModule>



Reply With Quote
The Following 2 Users Say Thank You to beyerservice For This Useful Post:
Captain (4th March 2013), falko (2nd March 2013)
  #13  
Old 5th March 2013, 18:10
JeffryL JeffryL is offline
Member
 
Join Date: Apr 2011
Posts: 36
Thanks: 10
Thanked 0 Times in 0 Posts
Default

Installed roundcube on Ubuntu 12.04 by:

Code:
apt-get install roundcube
Code:
dpkg-reconfigure roundcube-core
I added this lines to apps.vhost:

Code:
  # SSL Configuration
  SSLEngine On
  SSLCertificateFile /usr/local/ispconfig/interface/ssl/ispserver.crt
  SSLCertificateKeyFile /usr/local/ispconfig/interface/ssl/ispserver.key
  #SSLCACertificateFile /usr/local/ispconfig/interface/ssl/ispserver.bundle
This is my roundcube.conf:

Code:
# Those aliases do not work properly with several hosts on your apache server
# Uncomment them to use it or adapt them to your configuration
#    Alias /roundcube/program/js/tiny_mce/ /usr/share/tinymce/www/
    Alias /webmail /var/lib/roundcube
    Alias /roundcube /var/lib/roundcube

# Access to tinymce files
<Directory "/usr/share/tinymce/www/">
      Options Indexes MultiViews FollowSymLinks
      AllowOverride None
      Order allow,deny
      allow from all
</Directory>

<Directory /var/lib/roundcube/>
  Options +FollowSymLinks
  # This is needed to parse /var/lib/roundcube/.htaccess. See its
  # content before setting AllowOverride to None.
  AllowOverride All
  order allow,deny
  allow from all
</Directory>

# Protecting basic directories:
<Directory /var/lib/roundcube/config>
        Options -FollowSymLinks
        AllowOverride None
</Directory>

<Directory /var/lib/roundcube/temp>
        Options -FollowSymLinks
        AllowOverride None
	Order allow,deny
	Deny from all
</Directory>

<Directory /var/lib/roundcube/logs>
        Options -FollowSymLinks
        AllowOverride None
	Order allow,deny
	Deny from all
</Directory>

<IfModule mod_rewrite.c>
  <IfModule mod_ssl.c>
    <Location /webmail>
      RewriteEngine on
      RewriteCond %{HTTPS} !^on$ [NC]
      RewriteRule . https://%{HTTP_HOST}:8081%{REQUEST_URI}  [L]
    </Location>
  </IfModule>

<IfModule mod_rewrite.c>
  <IfModule mod_ssl.c>
    <Location /roundcube>
      RewriteEngine on
      RewriteCond %{HTTPS} !^on$ [NC]
      RewriteRule . https://%{HTTP_HOST}:8081%{REQUEST_URI}  [L]
    </Location>
  </IfModule>

<IfModule mod_php5.c>
AddType application/x-httpd-php .php
php_flag magic_quotes_gpc Off
php_flag track_vars On
php_admin_flag allow_url_fopen Off
php_value include_path .:/usr/share/php:/usr/share/pear
php_admin_value upload_tmp_dir /var/lib/roundcube/temp
php_admin_value open_basedir /usr/share/php:/usr/lib/roundcube:/etc/roundcube:/usr/share/roundcube:/var/lib/roundcube:/var/log/roundcube
php_flag register_globals off
</IfModule>
This works, also on a multiserver setting. Just make sure you enter the correct settings when reconfiguring...

One final question to the experts here... is it safe? My doubt goes out to the way I enabled logging (by including it as open_basedir)

Last edited by JeffryL; 5th March 2013 at 18:54.
Reply With Quote
  #14  
Old 5th March 2013, 19:32
servidoresadmin.com servidoresadmin.com is offline
Junior Member
 
Join Date: Nov 2012
Posts: 23
Thanks: 0
Thanked 2 Times in 2 Posts
Default Final solution roundcube 500 after upgrade to 3.0.5.1

Hi,

If you get roundcube 500 ERROR after the upgrade and you are running php as suphp and cannot disable it, only have to go under ISPCONFIG --> DOMAIN | OPTIONS | APACHE DIRECTIVES

and add

<IfModule mod_php5.c>
AddType application/x-httpd-php .php
php_flag magic_quotes_gpc Off
php_flag track_vars On
php_admin_flag allow_url_fopen Off
php_value include_path .:/usr/share/php:/usr/share/pear
php_admin_value upload_tmp_dir /var/lib/roundcube/temp
php_admin_value open_basedir /usr/share/php:/usr/share/pear:/usr/lib/roundcube:/etc/roundcube:/usr/share/roundcube:/var/lib/roundcube:/var/log/roundcube
php_flag register_globals off
</IfModule>

It's running under debian running suphp with ispconfig 3.0.5.1
You can open ROUNDCUBE with https://www.domain.com/webmail

Tested and running fine.

Thanks,
SERVIDORES DEDICADOS ADMINISTRADOS
Reply With Quote
The Following User Says Thank You to servidoresadmin.com For This Useful Post:
Captain (5th March 2013)
  #15  
Old 6th March 2013, 19:54
beyerservice beyerservice is offline
Member
 
Join Date: Feb 2011
Location: /dev/null
Posts: 30
Thanks: 10
Thanked 6 Times in 5 Posts
Default

this is same solution as in my post
Reply With Quote
The Following User Says Thank You to beyerservice For This Useful Post:
JeffryL (17th March 2013)
  #16  
Old 10th March 2013, 18:34
herophil322 herophil322 is offline
Junior Member
 
Join Date: Mar 2013
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Sloved

After the update 3.5.1, i got the error 500 internal server error or a empty site,
i added those lines to my phpmyadmin.conf and reloaded my apache conf, now it works fine

Code:
<IfModule mod_php5.c>
AddType application/x-httpd-php .php
php_flag magic_quotes_gpc Off
php_flag track_vars On
php_admin_flag allow_url_fopen Off
php_value include_path .:/usr/share/php:/usr/share/pear
php_admin_value upload_tmp_dir /var/lib/phpmyadmin/temp
php_admin_value open_basedir /usr/share/phpmyadmin/:/etc/phpmyadmin/:/var/lib/phpmyadmin/
php_flag register_globals off
</IfModule>
Reply With Quote
  #17  
Old 10th March 2013, 20:37
Horfic Horfic is offline
Senior Member
 
Join Date: Mar 2009
Location: Austria
Posts: 325
Thanks: 55
Thanked 93 Times in 58 Posts
Send a message via Skype™ to Horfic
Default

I solved the roundcube issue with suphp by simple adding

suhosin.session.encrypt=Off

into the custom php.ini field
__________________
web wack creations - We create your custom web application
Mailuser interface for ISPConfig 3
Reply With Quote
  #18  
Old 17th March 2013, 17:32
JeffryL JeffryL is offline
Member
 
Join Date: Apr 2011
Posts: 36
Thanks: 10
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
Which URL do you use to access roundcube? Dont use port 8080 to access any software beside ispconfig, for other softeware there is a apps vhost which is on port 8081 by default.
Hi Till, I've changed the apps vhost file to enable SSL but this might break other apps right? What would you advice to enable/force roundcube over SSL with port 8081?

Thanks in advance!
Reply With Quote
  #19  
Old 26th March 2013, 11:51
Captain Captain is offline
Senior Member
 
Join Date: Feb 2009
Posts: 285
Thanks: 79
Thanked 7 Times in 6 Posts
Question

Hello!

Have one small problem.
I configured roundcube to use over SSL via https.
For that I add to app.vhost:
Code:
 # SSL Configuration
  SSLEngine On
  SSLCertificateFile /usr/local/ispconfig/interface/ssl/ispserver.crt
  SSLCertificateKeyFile /usr/local/ispconfig/interface/ssl/ispserver.key
  #SSLCACertificateFile /usr/local/ispconfig/interface/ssl/ispserver.bundle
But when I change something in ispconfig this file recreates witohout

Code:
 # SSL Configuration
  SSLEngine On
  SSLCertificateFile /usr/local/ispconfig/interface/ssl/ispserver.crt
  SSLCertificateKeyFile /usr/local/ispconfig/interface/ssl/ispserver.key
  #SSLCACertificateFile /usr/local/ispconfig/interface/ssl/ispserver.bundle
How to solve it?

Thank you.
Reply With Quote
  #20  
Old 1st April 2013, 09:00
JeffryL JeffryL is offline
Member
 
Join Date: Apr 2011
Posts: 36
Thanks: 10
Thanked 0 Times in 0 Posts
 
Default

I noticed that since the update to 3.0.5.2 and/or an upgrade of apache (same time more or less) the webmail isn't working anymore by using the procedure above.

In my case I've configured the sites with php-fpm and then the directives put in the apache roundcube file are not applied anymore. No matter what I put in this file (within the conf.d directory) the openbase restriction remains in effect.

Also putting the lines:
Code:
AddType application/x-httpd-php .php
php_flag magic_quotes_gpc Off
php_flag track_vars On
php_admin_flag allow_url_fopen Off
php_value include_path .:/usr/share/php:/usr/share/pear
php_admin_value upload_tmp_dir /var/lib/roundcube/temp
php_admin_value open_basedir /usr/share/php:/usr/lib/roundcube:/etc/roundcube:/usr/share/roundcube:/var/lib/roundcube:/var/log/roundcube
php_flag register_globals off
in either one of the snippets (php or apache) didn't change the open-base settings.

I also added the roundcube lines to the open-basedir settings under the general configuration (php-permissions - server config) but this had no effect either. The open-basedir remains the same...

Anyone experiencing the same difficulties?

Done so far: reconfiguring website, altering roundcube.conf, altering snippets, changing to mod-php, switching back to php-fpm, disable the https/ssl

Does work though when using port 8080... which you didn't recommend...

Last edited by JeffryL; 1st April 2013 at 10:31.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
500 error ispconfig controlepanel after upgrade 3.0.5 nokia80 Installation/Configuration 5 27th February 2013 13:39
nginx & wordpress gives 500 pages EckyBrazz Server Operation 8 24th October 2012 00:06
How to upgrade Roundcube 0.3 to 0.7 on Ubuntu 10.04 LTS cbj4074 Tips/Tricks/Mods 1 19th January 2012 19:50
Roundcube user plugin error next upgrade ispconfig metaldrummer Installation/Configuration 1 10th November 2011 08:48
ispconfig and mambo shajazzi Installation/Configuration 70 28th March 2006 19:29


All times are GMT +2. The time now is 21:52.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.