Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 28th February 2013, 10:10
vaio1 vaio1 is offline
Senior Member
 
Join Date: Jul 2007
Location: Italy
Posts: 664
Thanks: 77
Thanked 12 Times in 7 Posts
Default ISPConfig 3 Updated: Fake Connections

Hi guys,

I have 3 dell servers with debian and I have updated your fantastic software in these three boxes.

I have noticed that the connection to the master db is not correct. I mean that the ispConfig control panel shows me three green rectangles but I have some doubt about the connection between them.

I have tested the connection creating a new email account by the ISPConfig panel and the email account has been NOT created in the mailserver.

Any idea to fix the problem?

Another Question:
Does the API methods have been changed?
Reply With Quote
Sponsored Links
  #2  
Old 28th February 2013, 10:13
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,804
Thanks: 840
Thanked 5,614 Times in 4,425 Posts
Default

Quote:
Any idea to fix the problem?
http://www.howtoforge.com/forums/showthread.php?t=58408

Quote:
Another Question:
Does the API methods have been changed?
The names have not been changed but they are extended of course as new functions in ispconfig require new parameters in the params array.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 28th February 2013, 10:17
vaio1 vaio1 is offline
Senior Member
 
Join Date: Jul 2007
Location: Italy
Posts: 664
Thanks: 77
Thanked 12 Times in 7 Posts
Default

Thanks Till.

- Linux Distribution: Debian Last Version - Kernel 2.6.32-5-686-bigmem
- ISPConfig version: Last Version

Mail Server
- Dovecot
- All the emails are delivered correctly

After creating a new email account I cannot connect to the webmail. Seems to me that the email account has been not created correctly.

thanks
Reply With Quote
  #4  
Old 28th February 2013, 10:26
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,804
Thanks: 840
Thanked 5,614 Times in 4,425 Posts
Default

Thanks for the additional details. The link I posted above contains instructions how to debug your issue "ISPConfig is not writing changes to disk". As you run a multiserver, you have to enable debugging in ispconfig on the master for the slave server (mail server) and then run the server.sh script on the mailserver. You might also want to check the jobqueue and syslog in the ispconfig monitor.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 28th February 2013, 10:49
vaio1 vaio1 is offline
Senior Member
 
Join Date: Jul 2007
Location: Italy
Posts: 664
Thanks: 77
Thanked 12 Times in 7 Posts
Default

I have already tested it by the server.sh script and I get just the message: "finished". So seems to be correct.

At the moment this is the configuration http://i2.minus.com/ijKSXWNLu6R7o.png

So, why the mailserver doesn't create the new account?

thanks
Reply With Quote
  #6  
Old 28th February 2013, 10:53
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,804
Thanks: 840
Thanked 5,614 Times in 4,425 Posts
Default

Quote:
I have already tested it by the server.sh script and I get just the message: "finished". So seems to be correct.
Then you havent enabled debugiing correctly as described in the faq.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 28th February 2013, 11:09
vaio1 vaio1 is offline
Senior Member
 
Join Date: Jul 2007
Location: Italy
Posts: 664
Thanks: 77
Thanked 12 Times in 7 Posts
Default

Right! Now I have enabled it but I get these messages:
Code:
# /usr/local/ispconfig/server/server.sh
28.02.2013-09:08 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
28.02.2013-09:08 - DEBUG - Found 2 changes, starting update process.
28.02.2013-09:08 - DEBUG - Replicated from master: REPLACE INTO spamfilter_users (`id`,`sys_userid`,`sys_groupid`,`sys_perm_user`,`sys_perm_group`,`sys_perm_other`,`server_id`,`priority`,`policy_id`,`email`,`fullname`,`local`) VALUES ('445','1','4','riud','riud','','3','10','5','mytest@mydomain.com','mytest@mydomain.com','Y')
28.02.2013-09:08 - DEBUG - Processed datalog_id 12448
28.02.2013-09:08 - DEBUG - Replicated from master: REPLACE INTO mail_user (`mailuser_id`,`sys_userid`,`sys_groupid`,`sys_perm_user`,`sys_perm_group`,`sys_perm_other`,`server_id`,`email`,`password`,`name`,`uid`,`gid`,`maildir`,`quota`,`cc`,`homedir`,`autoresponder`,`autoresponder_start_date`,`autoresponder_end_date`,`autoresponder_subject`,`autoresponder_text`,`move_junk`,`custom_mailfilter`,`postfix`,`access`,`disableimap`,`disablepop3`,`disabledeliver`,`disablesmtp`,`login`,`disablesieve`,`disablelda`,`disabledoveadm`) VALUES ('461','1','4','riud','riud','','3','mytest@mydomain.com','$1$JwtdHCGu$tp7wrMuciM.Nwj6FtfkWE1','','5000','5000','/var/vmail/mydomain.com/mytest','10485760','','/var/vmail','n','0000-00-00 00:00:00','0000-00-00 00:00:00','Out of office reply','','n','','y','n','n','n','n','n','mytest@mydomain.com','n','n','n')
28.02.2013-09:08 - DEBUG - Calling function 'user_update' from plugin 'mail_plugin' raised by event 'mail_user_update'.
28.02.2013-09:08 - DEBUG - Created Directory: /var/vmail/mydomain.com
28.02.2013-09:08 - DEBUG - Created Maildir /var/vmail/mydomain.com/mytest/Maildir with subfolder: 
28.02.2013-09:08 - DEBUG - Set ownership on /var/vmail/mydomain.com/mytest
28.02.2013-09:08 - DEBUG - Created Maildir /var/vmail/mydomain.com/mytest/Maildir with subfolder: Sent
28.02.2013-09:08 - DEBUG - Created Maildir /var/vmail/mydomain.com/mytest/Maildir with subfolder: Drafts
28.02.2013-09:08 - DEBUG - Created Maildir /var/vmail/mydomain.com/mytest/Maildir with subfolder: Trash
28.02.2013-09:08 - DEBUG - Created Maildir /var/vmail/mydomain.com/mytest/Maildir with subfolder: Junk
28.02.2013-09:08 - DEBUG - Moved Maildir from: /var/vmail/mydomain.com/test to /var/vmail/mydomain.com/mytest
28.02.2013-09:08 - DEBUG - Calling function 'update' from plugin 'maildeliver_plugin' raised by event 'mail_user_update'.
28.02.2013-09:08 - DEBUG - Mailfilter config has been changed
28.02.2013-09:08 - DEBUG - Processed datalog_id 12449
28.02.2013-09:08 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
finished.

Last edited by vaio1; 28th February 2013 at 11:11.
Reply With Quote
  #8  
Old 28th February 2013, 11:18
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,804
Thanks: 840
Thanked 5,614 Times in 4,425 Posts
Default

The output is fine, the mailbox has been creatd on the system. Maybe the cron daemon is not running on your mail server.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 28th February 2013, 11:21
vaio1 vaio1 is offline
Senior Member
 
Join Date: Jul 2007
Location: Italy
Posts: 664
Thanks: 77
Thanked 12 Times in 7 Posts
 
Default

It's really strange but .... now all works!

Maybe I am too fast when I check the editings of the creation of the mailbox.

Best Regards
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 3 - MultiServer Setup - With Dedicated Control Panel - How? SuperJC Installation/Configuration 4 16th October 2012 21:03
around 80 sleeping connections created by ISPConfig bkilinc General 2 1st October 2012 17:12
PHP warnings after upgrade to ISP config 3.03 stevegjacobs Installation/Configuration 5 30th October 2010 15:31
Ftp problems timeout reny2000 General 6 23rd December 2009 12:09
ISPConfig 3.0.0.7 Beta released till General 78 24th December 2008 12:47


All times are GMT +2. The time now is 10:02.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.