Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #41  
Old 27th February 2013, 15:22
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
Default

Quote:
Originally Posted by felipec84 View Post
I had the same problem when I tried to upgrade ISPCONFIG, I'm using "Ubuntu 10.04 on an OpenVZ VPS" and

dovecot --version = 1.2.9

Since it was a production server I had to downgrade ispconfig using the backup...
No need to downgrade ispconfig, the problem is just that your dovecot install seems to be missing a module which is now used in current ispconfig versions. Just copy the /etc/dovecot/dovecot.conf file from the etc backup in /var/backups/ to your current install and restart dovecot.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Sponsored Links
  #42  
Old 27th February 2013, 15:51
cbj4074 cbj4074 is offline
Senior Member
 
Join Date: Nov 2010
Posts: 395
Thanks: 30
Thanked 58 Times in 50 Posts
Default

Quote:
ISPConfig comes with a dovecot configuration file for 1.x and one for 2.x, the dovecot version is queried from the dovecot binary and then the file selected accordingly.

Which Linux distribution do you use?
Whats the output of:

dovecot --version

And what is on line 685 in /etc/dovecot/dovecot.conf
Okay, that approach to selecting the correct configuration template seems very reasonable.

The output of "dovecot --version" is:

Code:
1.2.9
Line 685 of /etc/dovecot/dovecot.conf contains:

Code:
  sieve=~/.dovecot.sieve
Doesn't this need to go inside the plugins {} stanza? My old configuration file has:

Code:
plugin {
    sieve=/var/vmail/%d/%n/.sieve
}
In the new file, this directive is inside a different stanza:

Code:
protocol managesieve {
  sieve=~/.dovecot.sieve
}
Or are these two different entities?

Thanks!

Last edited by cbj4074; 27th February 2013 at 15:54.
Reply With Quote
  #43  
Old 27th February 2013, 17:31
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
Default

@cbj4074

This might be different settings, one global and one for the plugin scope. Which Linux Distribution & version do you use so that I can try to verify the problem?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #44  
Old 27th February 2013, 17:43
cbj4074 cbj4074 is offline
Senior Member
 
Join Date: Nov 2010
Posts: 395
Thanks: 30
Thanked 58 Times in 50 Posts
Default

Thanks for the prompt replies, Till.

I'm on Ubuntu 10.04 and installed Dovecot from the OS's repository.
Reply With Quote
  #45  
Old 27th February 2013, 18:13
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
Default

Ok,I will setup a test system with this version tomorrow. Till then you should be able to use your old dovecot.conf file, it should be compatible with ispconfig 3.0.5.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #46  
Old 27th February 2013, 23:58
cbj4074 cbj4074 is offline
Senior Member
 
Join Date: Nov 2010
Posts: 395
Thanks: 30
Thanked 58 Times in 50 Posts
Default

Thanks, Till. I really appreciate you going to all the trouble.

I performed additional research and in my old configuration, the term "sieve" only appears in two places:

Code:
protocol lda {
  mail_plugins = sieve quota
}

[...]

plugin {
  sieve=/var/vmail/%d/%n/.sieve
}
Yet, in the new configuration that ISPC 3.0.5 created, there are a number of new stanzas and directives that weren't there before, and one of them contains the line that causes the fatal error during Dovecot start-up:

Code:
protocol managesieve {
  # This is the line that causes the fatal error.
  sieve=~/.dovecot.sieve
  
  sieve_storage=~/sieve
}
Is the problem, in essence, the presence of the protocol managesieve block? I have dovecot-pigeonhole installed, but I've never had any reference to it (or managesieve) in my Dovecot configuration file.

To help you reproduce this situation on your own VM:

Code:
# dpkg --list | grep dovecot
ii  dovecot-antispam                 1.2+20090702-1ubuntu0.10.04.1 a Dovecot plugin that helps train spam filte
ii  dovecot-common                   1:1.2.9-1ubuntu6.5            secure mail server that supports mbox and ma
ii  dovecot-imapd                    1:1.2.9-1ubuntu6.5            secure IMAP server that supports mbox and ma
rc  dovecot-pigeonhole               0.3.1-3~rns~lucid             secure mail server - sieve and managesieve s
ii  dovecot-pop3d                    1:1.2.9-1ubuntu6.5            secure POP3 server that supports mbox and ma
Reply With Quote
The Following User Says Thank You to cbj4074 For This Useful Post:
till (28th February 2013)
  #47  
Old 28th February 2013, 00:11
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
Default

The managesieve config syntax seems to have changed between dovecot 1.1 and 1.2

http://wiki.dovecot.org/ManageSieve/Configuration

Maybe we should disable managesieve for dovecot 1.x again as it was in 3.0.4.6, if somebody needs it he can enable it in his own config. iSPConfig has different config file sets only for dovecot 1.x and 2.x and it des not make much sense to start a new set for a old dovecot version just to have managesieve on by default.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #48  
Old 28th February 2013, 03:58
contremaitre contremaitre is offline
Junior Member
 
Join Date: Jul 2011
Posts: 14
Thanks: 0
Thanked 1 Time in 1 Post
Default

i did a smooth upgrade from 3.0.4.6 on a multi server setup. but my global search function is the only thing not working. am i missing something?

let me know guys

thanks
Reply With Quote
  #49  
Old 28th February 2013, 09:21
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
Default

Try to empty the browser cache and reload the page. If you use a custom theme, then you might have to extend it for the global search.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #50  
Old 28th February 2013, 15:41
contremaitre contremaitre is offline
Junior Member
 
Join Date: Jul 2011
Posts: 14
Thanks: 0
Thanked 1 Time in 1 Post
 
Default

using the default theme for ISPConfig, as well this reproduces on all my devices and browsers regardless of cache.
Let me know.

Thanks
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
All files gone after changing quota to 0 spynode General 17 19th January 2012 15:41
ISPConfig 3.0.3 released till General 52 2nd December 2010 18:24
ISPConfig 3.0.1 released till General 36 29th March 2009 15:30
ISPConfig 3.0.0.6 Beta released till General 38 21st September 2008 20:15
ISPConfig 2.3.3-dev released till General 10 12th March 2008 22:08


All times are GMT +2. The time now is 22:43.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.