Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 14th February 2013, 09:25
snowfly snowfly is offline
Member
 
Join Date: Jul 2006
Posts: 91
Thanks: 0
Thanked 4 Times in 3 Posts
Default SMTP Auth just stopped working after Debian upgrade

Today I ran an apt-get update and then apt-get upgrade, and two packages were updated:
libssl0.9.8
openssl

Since this, SMTP auth has stopped working with the following message in /var/log/mail.info:
SASL LOGIN authentication failed: authentication failure

This is a standard ISPConfig 3.0.4.6 system on Debian Squeeze.

Any ideas?
Reply With Quote
Sponsored Links
  #2  
Old 14th February 2013, 09:33
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,046
Thanks: 826
Thanked 5,384 Times in 4,231 Posts
Default

It might be that the debian update overwrote a config file. Please rerun the ispconfig by following the manual update instructions here:

http://www.howtoforge.com/forums/showthread.php?t=57659

and choose to reconfigure services during update.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 14th February 2013, 09:36
snowfly snowfly is offline
Member
 
Join Date: Jul 2006
Posts: 91
Thanks: 0
Thanked 4 Times in 3 Posts
Default

Just managed to fix the problem by restarting sasauthd:
/etc/init.d/saslauthd restart

Weird, now all our clients can send email again via SMTP.
Perhaps the package upgrade didn't restart saslauthd.
Reply With Quote
  #4  
Old 15th February 2013, 18:20
Norman Norman is offline
HowtoForge Supporter
 
Join Date: May 2006
Posts: 242
Thanks: 0
Thanked 18 Times in 14 Posts
Default

Can confirm there's an issue in latest debian repository updates.

Looks like this is caused by libssl / openssl package update breaking something in saslauthd unless you restart it manually.
__________________
http://www.xh.se
Reply With Quote
  #5  
Old 15th February 2013, 19:17
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,034
Thanks: 265
Thanked 152 Times in 132 Posts
Default

Quote:
Originally Posted by snowfly View Post
Just managed to fix the problem by restarting sasauthd:
/etc/init.d/saslauthd restart

Weird, now all our clients can send email again via SMTP.
Perhaps the package upgrade didn't restart saslauthd.
Had the same problem this morning!
__________________
Never execute code written on a Friday or a Monday.
Reply With Quote
  #6  
Old 19th February 2013, 11:38
kurdak kurdak is offline
Junior Member
 
Join Date: Nov 2012
Posts: 19
Thanks: 6
Thanked 0 Times in 0 Posts
Default

Welcome.
I have the same after the upgrade: "libssl0.9.8" and "openssl" emails stopped working: (
Reply With Quote
  #7  
Old 19th February 2013, 13:53
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,046
Thanks: 826
Thanked 5,384 Times in 4,231 Posts
Default

Download the ispconfig tar.gz again, unpack it and run the update.php script in the install folder. Choose to reconfigure services during update.

Some users reported that this fixed the issue.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #8  
Old 19th February 2013, 15:43
kurdak kurdak is offline
Junior Member
 
Join Date: Nov 2012
Posts: 19
Thanks: 6
Thanked 0 Times in 0 Posts
Default

Update does not fix the error. Luckily I had a backup disk
Please help me how to fix it.
Reply With Quote
  #9  
Old 19th February 2013, 16:02
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,034
Thanks: 265
Thanked 152 Times in 132 Posts
Default

I also needed to restart postgrey to make all work again.

Code:
/etc/init.d/postgrey restart
__________________
Never execute code written on a Friday or a Monday.
Reply With Quote
  #10  
Old 27th December 2013, 13:32
otbono otbono is offline
Junior Member
 
Join Date: Feb 2011
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
 
Smile Thank you !

/etc/init.d/saslauthd restart works like a charm !

Thank you !
Regards,
Orlando Tempobono
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SMTP auth. Nickname Installation/Configuration 1 12th December 2011 15:00
My SMTP is not working rutame Installation/Configuration 17 10th February 2010 02:14
Can't seem to get SMTP AUTH working.. ralexpdx HOWTO-Related Questions 3 3rd June 2006 14:20
SMTP Auth failure debian 3.1 sarge dschmid Installation/Configuration 5 3rd April 2006 11:16
e-mail problem!!! Debian 3.1 maroonworks Installation/Configuration 18 6th December 2005 14:42


All times are GMT +2. The time now is 18:32.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.