Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 20th February 2013, 08:40
dbvadmin dbvadmin is offline
Junior Member
 
Join Date: Jul 2011
Posts: 13
Thanks: 1
Thanked 0 Times in 0 Posts
Default SOLVED: no mod_rewrite after folder-protection

Hi.

Yesterday I activated folder protection for testing on one folder. After deactivation of folder protection mod_rewrite was no longer working.

Any suggestions ?

thx & regards,

dbvadmin

Last edited by dbvadmin; 20th February 2013 at 20:05. Reason: Translating to correct language :)
Reply With Quote
Sponsored Links
  #2  
Old 20th February 2013, 09:25
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,446
Thanks: 813
Thanked 5,213 Times in 4,088 Posts
Default

Hi,

please post in english language here. If you like to post in german, please use our german forum at www.howtoforge.de/forum/

To your questions, the folder protection uses .htaccess files and overwrites existing .htaccess files in ISPConfig 3.0.4.6, this has been change din 3.0.5 though. So if you protected the whole web folder in 3.0.4.6, then you have to add your rewrite rules to the .htaccess file again.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 20th February 2013, 11:54
dbvadmin dbvadmin is offline
Junior Member
 
Join Date: Jul 2011
Posts: 13
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Hi Till.

Thx for response and sorry... just translated the post for other users

OK back to the prob with mod_rewrite.

I'm still at ISPConfig 3.0.4.6 and had no changes or entries made to the .htaccess-Files before using folder protection.

Any further hints ?

Rgds.

dbvadmin
Reply With Quote
  #4  
Old 20th February 2013, 11:57
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,446
Thanks: 813
Thanked 5,213 Times in 4,088 Posts
Default

Quote:
I'm still at ISPConfig 3.0.4.6 and had no changes or entries made to the .htaccess-Files before using folder protection.
There must have been entries in the .htaccess file if you had rewrite rules before that were not working anymore now.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 20th February 2013, 20:05
dbvadmin dbvadmin is offline
Junior Member
 
Join Date: Jul 2011
Posts: 13
Thanks: 1
Thanked 0 Times in 0 Posts
 
Thumbs up Solved...

After taking a while looking around I found that there was a .htaccess in the appropriate directory.

For other Users:

Take care to use folder PRotection when using Oxid CE

It'll overwrite the exsting .htacess

Thx for your help.

dbvadmin
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Folder protection issue katasun Feature Requests 1 24th June 2012 14:30
Folder Protection API snowfly General 4 9th January 2012 08:15
Folder protection admins Feature Requests 3 5th November 2010 13:42
Password protection of folder via .htaccess cgick General 2 23rd March 2010 16:07
ISPConfig 2.2.10 released till General 70 7th March 2007 18:25


All times are GMT +2. The time now is 20:43.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.