#1  
Old 23rd July 2012, 01:21
Unfaiir Unfaiir is offline
HowtoForge Supporter
 
Join Date: Jul 2012
Location: Orange County, CA, USA
Posts: 43
Thanks: 14
Thanked 4 Times in 2 Posts
Unhappy Web Server Hangs Randomly

I just did a fresh install of ISPConfig on CentOS 6.3, following the howtoforge guide exactly. The only issue I had was that mailman wasn't recognized during the installation. Oh well I guess.

I have a dedicated website that I've just setup and while browing the site, randomly the page will just load and load until eventually the browser returns the "Cannot connect" message. Once this happens, every site on the server returns the same message when trying to connect, including the ISPConfig panel (I have 3 sites setup).

I checked the /var/httpd/error_log immediately after this happened and saw this:
Quote:
[Sun Jul 22 15:13:45 2012] [error] python_init: Python version mismatch, expected '2.6.5', found '2.6.6'.
[Sun Jul 22 15:13:45 2012] [error] python_init: Python executable found '/usr/bin/python'.
[Sun Jul 22 15:13:45 2012] [error] python_init: Python path being used '/usr/lib64/python26.zip:/usr/lib64/python2.6/:/usr/lib64/python2.6/plat-linux2:/usr/lib64/python2.6/lib-tk:/usr/lib64/python2.6/lib-old:/usr/lib64/python2.6/lib-dynload'.
[Sun Jul 22 15:13:45 2012] [notice] mod_python: Creating 4 session mutexes based on 256 max processes and 0 max threads.
[Sun Jul 22 15:13:45 2012] [notice] mod_python: using mutex_directory /tmp
[Sun Jul 22 15:13:45 2012] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Sun Jul 22 15:13:45 2012] [notice] Apache/2.2.15 (Unix) DAV/2 mod_fcgid/2.3.7 PHP/5.3.3 mod_python/3.3.1 Python/2.6.6 mod_ruby/1.3.0 Ruby/1.8.7(2011-06-30) mod_ssl/2.2.15 OpenSSL/1.0.0-fips configured -- resuming normal operations
[Sun Jul 22 15:18:42 2012] [notice] caught SIGTERM, shutting down
[Sun Jul 22 15:18:43 2012] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Sun Jul 22 15:18:43 2012] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Sun Jul 22 15:18:43 2012] [notice] Digest: generating secret for digest authentication ...
[Sun Jul 22 15:18:43 2012] [notice] Digest: done
After searching about the mod_python errors with ISPConfig 3, I decided to just disabled mod_python, since I'm not using python anyway for any sites. I also disabled mailman at this time since it never was installed into ISPConfig 3. I then restarted the server and the log was much nicer:
Quote:
[Sun Jul 22 16:13:51 2012] [notice] caught SIGTERM, shutting down
[Sun Jul 22 16:13:52 2012] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Sun Jul 22 16:13:52 2012] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Sun Jul 22 16:13:52 2012] [notice] Digest: generating secret for digest authentication ...
[Sun Jul 22 16:13:52 2012] [notice] Digest: done
[Sun Jul 22 16:13:52 2012] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Sun Jul 22 16:13:52 2012] [notice] Apache/2.2.15 (Unix) DAV/2 mod_fcgid/2.3.7 PHP/5.3.3 mod_ruby/1.3.0 Ruby/1.8.7(2011-06-30) mod_ssl/2.2.15 OpenSSL/1.0.0-fips configured -- resuming normal operations
The web server seemed to be behaving better... seemed.. about 10 minutes later the server hung again. There is no error is the error_log. Even restarting apache when this happens has no effect. I must wait several minutes (I've not timed it exactly but I'm estimating about 5). After this time, the server starts to respond again. This keeps happening randomly at least once every 5-10 minutes after coming back up.

I'm not sure what to do? There is no error in the apache log and this is a fresh install, only doing exactly what the howto guide for centos 6.2 said. Can anyone help?
Reply With Quote
Sponsored Links
  #2  
Old 23rd July 2012, 08:53
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,395
Thanks: 833
Thanked 5,490 Times in 4,322 Posts
Default

Which ISPConfig version do you use?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 14th February 2013, 10:08
Unfaiir Unfaiir is offline
HowtoForge Supporter
 
Join Date: Jul 2012
Location: Orange County, CA, USA
Posts: 43
Thanks: 14
Thanked 4 Times in 2 Posts
 
Cool

Quote:
Originally Posted by till View Post
Which ISPConfig version do you use?
This was ISPConfig 3 on an old server.

I'm not sure what the problem was exactly but I think what solved it was to turn up the MaxClients (and ServerLimit) up to 512 or 1024 in /etc/httpd/conf/httpd.conf.
__________________
We are not equal
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Local mail server - final touch Alexhor Installation/Configuration 4 12th April 2012 22:33
php Apps email not going through palkat General 8 21st September 2011 05:35
Statistic not working mzo Installation/Configuration 49 20th April 2011 12:19
Not working emails (DNS and postfix problem?) shekiman Installation/Configuration 9 1st March 2011 16:25
ISPConfig3 mail doesn't work Marr General 6 1st September 2010 09:32


All times are GMT +2. The time now is 05:45.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.