#1  
Old 7th August 2006, 17:45
simplyworks simplyworks is offline
Junior Member
 
Join Date: Jul 2006
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default ssl Certificate Invalid

Hello,

I created the ssl certificate using ISPconfig and this is the only domain using this IP. When I access https://www.example.com I get the security warning stating the name on the certificate does not match the domain.

when veiwing the certificate, it does state issue by: localhost.localdomain which explain the warning.

In veiwing the Vhost file all looks correct.
SSLEngine on
SSLCertificateFile /home/www/web1/ssl/www.example.com.crt
SSLCertificateKeyFile /home/www/web1/ssl/www.example.com.key

From what I can tell, I'm am pulling up this certificate
/etc/pki/tls/private (date matchs build date)

Background info:
Fedora Core 5 built using the How to
Ispconfig
I have restarted the httpd after changes


What should I try next?

Thanks,

Last edited by simplyworks; 7th August 2006 at 19:46.
Reply With Quote
Sponsored Links
  #2  
Old 8th August 2006, 09:34
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,503
Thanks: 813
Thanked 5,264 Times in 4,128 Posts
Default

If you accept the certificae, which page do you see? The same content as for http://example.com (without https) or the shared IP page?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 8th August 2006, 16:03
simplyworks simplyworks is offline
Junior Member
 
Join Date: Jul 2006
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default

When I accept the certificate I do get the correct page for https://example.com.

When I view the certificate it is issued by localhost.localdomain. It should be www.example.com correct?
__________________
Jason

There are only 3 kinds of people in the world
those who can count and those who can not!
Reply With Quote
  #4  
Old 9th August 2006, 15:45
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

What's the hostname and domain name of that web site (it's on the "Basis" tab)?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 11th August 2006, 22:36
simplyworks simplyworks is offline
Junior Member
 
Join Date: Jul 2006
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default

the setting are

Hostname: www
Domain: example.com

thanks,
__________________
Jason

There are only 3 kinds of people in the world
those who can count and those who can not!
Reply With Quote
  #6  
Old 12th August 2006, 18:49
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Then the FQDN in the cert should be www.example.com. Are you sure you're using the right certificate? On the correct site?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 15th August 2006, 20:32
simplyworks simplyworks is offline
Junior Member
 
Join Date: Jul 2006
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes, That is the problem.

When I visit https://www.example.com I am presented with a ssl certificate for the server and NOT the certificate list in the Vhost file path which was created by ISPconfig interface.

I have done a restart of httpd and Ispconfig

I guess, for a work a round I could move the ssl cert. from:
SSLCertificateFile /home/www/web1/ssl/www.example.com.crt
SSLCertificateKeyFile /home/www/web1/ssl/www.example.com.key

TO:
/etc/pki/tls/private (this the key that is presented)

Thanks,
__________________
Jason

There are only 3 kinds of people in the world
those who can count and those who can not!
Reply With Quote
  #8  
Old 15th August 2006, 20:46
simplyworks simplyworks is offline
Junior Member
 
Join Date: Jul 2006
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Question

Quote:
Originally Posted by simplyworks
Yes, That is the problem.

When I visit https://www.example.com I am presented with a ssl certificate for the server and NOT the certificate list in the Vhost file path which was created by ISPconfig interface.

I have done a restart of httpd and Ispconfig

I guess, for a work a round I could move the ssl cert. from:
SSLCertificateFile /home/www/web1/ssl/www.example.com.crt
SSLCertificateKeyFile /home/www/web1/ssl/www.example.com.key

TO:
/etc/pki/tls/private (this the key that is presented)
Well, the above worked. I move the .crt and .key . Then renamed them and restarted.

I still do not know why apache is not following the vhost directive for this domain?
__________________
Jason

There are only 3 kinds of people in the world
those who can count and those who can not!
Reply With Quote
  #9  
Old 16th August 2006, 16:44
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
 
Default

What's in Vhosts_ispconfig.conf?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ispconfig and mambo shajazzi Installation/Configuration 70 28th March 2006 19:29
chgrp: invalid group `admispconfig' wwparrish Installation/Configuration 1 8th February 2006 06:23
Invalid Certificate NoBullMan Installation/Configuration 5 14th December 2005 20:53
from http to https after installation? Mahir Installation/Configuration 25 7th December 2005 20:40
Invalid or Corrupt Certificate g8rbait Installation/Configuration 1 15th November 2005 16:21


All times are GMT +2. The time now is 17:47.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.