Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 6th August 2009, 13:17
bern bern is offline
Junior Member
 
Join Date: Aug 2009
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default SPF not working on IspConfig 3

Hi!
I've followed the perfect server tutorial (debian), and everything seems to be working except for the mail, which keeps getting on the spam mailbox. After some research and reading, i've added an spf record, all the dns configurations seems to be working except for the txt record which doesn't show on query.
Here's the two screenshots: one with my domain dns configuration and the other with the results of a dig command.

Thanks in advance.



Reply With Quote
Sponsored Links
  #2  
Old 7th August 2009, 12:48
falko falko is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

What's the output of
Code:
dig @localhost txt yourdomain.com
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 7th August 2009, 13:25
bern bern is offline
Junior Member
 
Join Date: Aug 2009
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

srv01:~# dig @localhost txt sho...s.com

; <<>> DiG 9.5.1-P3 <<>> @localhost txt sho...s.com
; (2 servers found)
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 38094
;; flags: qr aa rd; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
;; WARNING: recursion requested but not available

;; QUESTION SECTION:
;sho...s.com. IN TXT

;; AUTHORITY SECTION:
sho...s.com. 86400 IN SOA ns1.s...t.com. info.sh...s.com. 2009080703 28800 7200 604800 86400

;; Query time: 2 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Fri Aug 7 12:21:38 2009
;; MSG SIZE rcvd: 90

I've already restarted MyDNS, and also checked on the database if the record was there.

Any thoughts?

Last edited by bern; 7th August 2009 at 13:31.
Reply With Quote
  #4  
Old 8th August 2009, 13:23
falko falko is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

That's strange. Do you see the record in the database?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 10th August 2009, 10:56
bern bern is offline
Junior Member
 
Join Date: Aug 2009
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I was about to answer and show you the screenshot of it, but i've found the error, for some reason it didn't have the dot at the end of the name of the txt on the database, so i've removed and added the txt again: sho...s.com. and everything now everything's fine.
Kinda weird i guess.
I still have another question, even with SPF wish i guess is working, i still get my messages sended to the spam inbox. I'm not on any blacklist, and my SPF is setup what else should i check?
Here's the original from gmail (if that helps). I've just changed the domains and ip's.

Code:
Delivered-To: pits@gmail.com
Received: by 10.239.132.69 with SMTP id 5cs882111hbq;
        Mon, 10 Aug 2009 01:44:59 -0700 (PDT)
Received: by 10.210.39.8 with SMTP id m8mr2788107ebm.11.1249893898549;
        Mon, 10 Aug 2009 01:44:58 -0700 (PDT)
Return-Path: <info@shops.com>
Received: from srv01.netvisao.pt (srv01.netvisao.pt [213.220.220.220])
        by mx.google.com with ESMTP id 19si10232645ewy.70.2009.08.10.01.44.56;
        Mon, 10 Aug 2009 01:44:58 -0700 (PDT)
Received-SPF: pass (google.com: domain of info@shops.com designates 213.220.220.220 as permitted sender) client-ip=213.220.220.220;
Authentication-Results: mx.google.com; spf=pass (google.com: domain of info@shops.com designates 213.220.220.220 as permitted sender) smtp.mail=info@shops.com
Received: from localhost (localhost.localdomain [127.0.0.1])
	by srv01.netvisao.pt (Postfix) with ESMTP id D9A8D38C320
	for <pits@gmail.com>; Mon, 10 Aug 2009 09:44:55 +0100 (WEST)
X-Virus-Scanned: Debian amavisd-new at srv01.netvisao.pt
Received: from srv01.netvisao.pt ([127.0.0.1])
	by localhost (srv01.netvisao.pt [127.0.0.1]) (amavisd-new, port 10024)
	with ESMTP id suK5K9RkuIf7 for <pits@gmail.com>;
	Mon, 10 Aug 2009 09:44:51 +0100 (WEST)
Received: from 192.168.2.200 (localhost.localdomain [127.0.0.1])
	by srv01.netvisao.pt (Postfix) with ESMTP id 2AE4838C2B2
	for <pits@gmail.com>; Mon, 10 Aug 2009 09:44:51 +0100 (WEST)
Received: from 192.168.2.3
        (SquirrelMail authenticated user info@shops.com)
        by 192.168.2.200 with HTTP;
        Mon, 10 Aug 2009 09:44:51 +0100 (WEST)
Message-ID: <e916e864cf22b62bd305d33faa1be044.squirrel@192.168.2.200>
Date: Mon, 10 Aug 2009 09:44:51 +0100 (WEST)
Subject: Hi Here's my portofolio
From: "Info - Shops" <info@shops.com>
To: pits@gmail.com
Reply-To: info@shops.com
User-Agent: SquirrelMail/1.4.15
MIME-Version: 1.0
Content-Type: text/plain;charset=iso-8859-1
Content-Transfer-Encoding: 8bit
X-Priority: 3 (Normal)
Importance: Normal



Thanks a lot for your help falko. Really appreciate it.
Reply With Quote
  #6  
Old 11th August 2009, 15:51
falko falko is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Do you have a correct PTR record?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 11th August 2009, 16:11
bern bern is offline
Junior Member
 
Join Date: Aug 2009
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi,
Well Records kinda confuses me, doing nslookup type PTR on my IP i get the following result:

Code:
Server:         192.168.2.1
Address:        192.168.2.1#53

4x.1xx.2xx.21x.in-addr.arpa     name = xxxxxx-srv01.netvisao.pt.
Even though i've read some articles on it, it still don't get records that well, cause by the above it tells me I have one set that my ISP gave me right? Do i need to insert it somewhere on my server? Like on the dns records of every domain? How does that work. Sorry for all those questions.

Thanks a lot.
Reply With Quote
  #8  
Old 12th August 2009, 13:40
falko falko is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

What's the output of
Code:
dig -x 1.2.3.4
(replace 1.2.3.4 with your server's IP)?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 12th August 2009, 16:23
bern bern is offline
Junior Member
 
Join Date: Aug 2009
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Code:
smol-srv01:~# dig -x 2xx.22x.1xx.4x

; <<>> DiG 9.5.1-P3 <<>> -x 2xx.22x.1xx.4x
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 61207
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 2

;; QUESTION SECTION:
;4x.1xx.22x.2xx.in-addr.arpa.   IN      PTR

;; ANSWER SECTION:
4x.1xx.22x.2xx.in-addr.arpa. 86400 IN   PTR     xxxxxx-srv01.netvisao.pt.

;; AUTHORITY SECTION:
1xx.22x.2xx.in-addr.arpa. 86400 IN      NS      ns.netvisao.pt.
1xx.22x.2xx.in-addr.arpa. 86400 IN      NS      ns2.netvisao.pt.

;; ADDITIONAL SECTION:
ns.netvisao.pt.         86400   IN      A       213.228.128.5
ns2.netvisao.pt.        86400   IN      A       213.228.128.6

;; Query time: 13 msec
;; SERVER: 192.168.2.1#53(192.168.2.1)
;; WHEN: Wed Aug 12 15:15:14 2009
;; MSG SIZE  rcvd: 148
netvisao.pt is our ISP provider.
Reply With Quote
  #10  
Old 12th August 2009, 19:30
atjensen11 atjensen11 is offline
Senior Member
 
Join Date: Dec 2007
Posts: 199
Thanks: 9
Thanked 6 Times in 6 Posts
 
Default

It appears from the message header you posted that you sent the message to a Gmail account. I assume that the message was delivered to the SPAM or JUNK folder in the Gmail account.

I had the same issues until I installed dkimproxy. Gmail uses DKIM signatures and Yahoo uses DomainKeys signatures.

Once I started signing outgoing email messages, mail has a better (although not perfect) record of being delivered to the Inbox rather than a Junk folder.

My base system is a Debian 5 (Lenny) server with ISPConfig3 setup using the How To on this site. For the dkimproxy setup, I had to look to other tutorials available on the Internet. It was a lot of trial and error. Lenny does have dkimproxy in the repositories which can be installed with 'apt-get install dkimproxy', but I had problems getting it to work correctly. I eventually built a version from source using another tutorial.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 3.0.0.8 RC1 released till General 92 22nd February 2010 09:52
ISPConfig 3.0.0.9 RC2 released till General 51 17th April 2009 17:12
ISPConfig 3.0.0.7 Beta released till General 78 24th December 2008 11:47
ISPconfig has stopped working ilchubby General 5 21st November 2008 16:59
ISPConfig Roadmap till Developers' Forum 26 10th June 2007 22:38


All times are GMT +2. The time now is 16:20.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.