Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Technical

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 25th January 2013, 22:00
klocika klocika is offline
Junior Member
 
Join Date: Sep 2008
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default KVM Guest I/O slowness

Hi all,

I have a KVM cluster running on CentOS 6.3. All the guests are CentOS 6.3 also. All hosts are connected to a SAN, the base filesystem is gfs2.

I cloned some mysql cluster nodes from each other, they are on the same LUN, but one of them can do approx. 200 000 IO/sec, the other ones can do only 2-4000 IO/sec.

My guests use LVM with cache='none' io='native' settings.

If you have any idea please help me. I think something went wrong with the blocks, but I really don't know, coz the LVMs are on the same LUN and the IO during clone is more then 500000/sec.

Lorinc
Reply With Quote
Sponsored Links
  #2  
Old 28th January 2013, 14:30
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
 
Default

Have you tried cache='writethrough' and io='threads'?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtualization With KVM On Ubuntu 12.04 LTS - can't bring up guest network interface nzimas HOWTO-Related Questions 0 11th August 2012 12:17
kvm install guest without gui? unclecameron HOWTO-Related Questions 13 11th March 2011 15:38
KVM Guest - Networking problem satimis Server Operation 2 8th May 2010 15:13
KVM Guest Network problem in Ubuntu 8.04 likie Server Operation 1 23rd February 2010 16:42
Fail to create KVM guest satimis Server Operation 1 24th June 2009 21:07


All times are GMT +2. The time now is 16:55.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.