Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 22nd January 2013, 12:24
manarak manarak is offline
Senior Member
 
Join Date: Apr 2009
Posts: 262
Thanks: 32
Thanked 6 Times in 5 Posts
Default http/https error message in plain text

ISPconfig panel works in https mode, so when trying to access via http, an error message is displayed.

Here is the message (I anonymized the domain name):
Quote:
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>400 Bad Request</title>
</head><body>
<h1>Bad Request</h1>
<p>Your browser sent a request that this server could not understand.<br />
Reason: You're speaking plain HTTP to an SSL-enabled server port.<br />
Instead use the HTTPS scheme to access this URL, please.<br />
<blockquote>Hint: <a href="https://blabla.com:8080/"><b>https://blabla.com:8080/</b></a></blockquote></p>
</body></html>
The problem is that this message appears in plain text in the browser, it doesn't get interpreted as HTML by the browser.
What could be the cause of this behavior?
Reply With Quote
Sponsored Links
  #2  
Old 25th January 2013, 13:09
Ben Ben is offline
Moderator
 
Join Date: Jul 2006
Posts: 1,029
Thanks: 7
Thanked 62 Times in 56 Posts
Default

I'd pesonally say that there is something broken in the config. You might check with httpfox (Plugin for firefox) or similar stuff what the delivered content-type is in the http header. But I assume it is plain text and not text/html.
Thus any config setting for serving either the default or custom error pages must be wrong.
Sorry to be so unclear.

You might also check the access / error log while reproducing this behaviour, maybe this might give you a hint as well.

did this beahaviour just appear for specific vhosts and / or out of a sudden or since the first setup?
Reply With Quote
  #3  
Old 25th January 2013, 13:22
manarak manarak is offline
Senior Member
 
Join Date: Apr 2009
Posts: 262
Thanks: 32
Thanked 6 Times in 5 Posts
 
Default

It happens on all servers I installed with Falko's "perfect server" How-to for Debian with Apache and ISPConfig3, when choosing the "secure" option for in the ispconfig installation routine.

All other pages, including error pages, appear fine.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Create text files dynamically from master textfile with sed mangecelle Programming/Scripts 1 21st April 2009 04:16
chroot_ssh_sftp_debian_etch jon HOWTO-Related Questions 0 24th August 2008 00:40
Ubuntu 8.04 Spamsnake - all SA scores 0.00 Thomas_Powers HOWTO-Related Questions 23 24th June 2008 17:37
How to keep in RAM a number of text files? calande Server Operation 2 7th January 2008 17:17
PHP, read values from txt file, and add edge Programming/Scripts 3 4th August 2007 10:01


All times are GMT +2. The time now is 09:27.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.