Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 5th August 2006, 18:27
googlah googlah is offline
Junior Member
 
Join Date: Aug 2006
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Red face Can Send Email, But Not Recieve; Relay access denied

Falko, a big thanks to you for your great support for us who's trying to set up ISPConfig and Linux.

I've just bought http://www.27mhz.se. I have suceeded to forward it to my webserver at 213.112.40.6.

OK, Here is the problem.

I can login to UebiMiau-Webmail and send mails to gmail, hotmail, yes whatever.

BUT WHEN TRYING TO SEND MESSAGES BACK TO MY MAILSERVER, I GET A ERROR,


HTML Code:
This is an automatically generated Delivery Status Notification

Delivery to the following recipient failed permanently:

    snigel@27mhz.se

Technical details of permanent failure:
PERM_FAILURE: SMTP Error (state 9): 554 <snigel@27mhz.se>: Relay access denied


Here is my /etc/postfix/main.cf configuration

Code:
# See /usr/share/postfix/main.cf.dist for a commented, more complete version

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

myhostname = mail.27mhz.se
virtual_maps = hash:/etc/postfix/virtusertable
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
relayhost = smtp.bredband.net
mynetworks = 127.0.0.1
mailbox_command =
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
smtpd_sasl_local_domain = $myhostname
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtpd_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
home_mailbox = Maildir/

Here is my /etc/postfix/virtusertable configuration
Code:
###################################
#
# ISPConfig virtusertable Configuration File
#         Version 1.0
#
###################################
raksu@raksu.27mhz.se    raksu
snigel@snigel.27mhz.se    snigel
w21od005@21od005.27mhz.se    w21od005
#### MAKE MANUAL ENTRIES BELOW THIS LINE! ####
Here is my /etc/local-host-names configuration
Code:
###################################
#
# ISPConfig local-host-names Configuration File
#         Version 1.0
#
###################################
localhost
www.27mhz.se
localhost.27mhz.se
21od005.27mhz.se
raksu.27mhz.se
snigel.27mhz.se
mail.27mhz.se
#### MAKE MANUAL ENTRIES BELOW THIS LINE! ####

Here is my /etc/mailname configuration
Code:
mail.27mhz.se


That's all info needed I think. What could possible be wrong?
Reply With Quote
Sponsored Links
  #2  
Old 6th August 2006, 18:51
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

In /etc/postfix/main.cf this line is missing:
Code:
mydestination = /etc/postfix/local-host-names
Also, you should have
Code:
mynetworks = 127.0.0.0/8
instead if
Code:
mynetworks = 127.0.0.1
in there. Restart Postfix afterwards. Make sure you have enabled "Server requires authentication." in your email client.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 6th August 2006, 20:24
googlah googlah is offline
Junior Member
 
Join Date: Aug 2006
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default OK, It's done.

OK, The settings you told me to change is now changed. I restarted Postfix but I still recieve a error message at Gmail.com.

HTML Code:
This is an automatically generated Delivery Status Notification

Delivery to the following recipient failed permanently:

    snigel@27mhz.se

Technical details of permanent failure:
PERM_FAILURE: SMTP Error (state 9): 554 <snigel@27mhz.se>: Relay access denied

  ----- Original message -----

Received: by 10.78.158.11 with SMTP id g11mr2171366hue;
       Sun, 06 Aug 2006 11:13:30 -0700 (PDT)
Received: by 10.78.156.3 with HTTP; Sun, 6 Aug 2006 11:13:30 -0700 (PDT)
Message-ID: <d54e92120608061113v3b44256ej401979d32e567c78@mail.gmail.com>
Date: Sun, 6 Aug 2006 20:13:30 +0200
From: "=?ISO-8859-1?Q?Fredrik_Tennil=E4?=" <21od005@gmail.com>
To: Snigel <snigel@27mhz.se>
Subject: Re: hej
In-Reply-To: <20060806181318.A5FBA3EE44F@mail.27mhz.se>
MIME-Version: 1.0
Content-Type: multipart/alternative;
       boundary="----=_Part_82218_7483175.1154888010018"
References: <20060806181318.A5FBA3EE44F@mail.27mhz.se>

------=_Part_82218_7483175.1154888010018
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

What is this MX-record all about ??? Maybe that is what is missing!
Reply With Quote
  #4  
Old 7th August 2006, 13:36
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Is 213.112.40.6 your server's public IP address? Is snigel@27mhz.se listed in /etc/postfix/virtusertable?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 7th August 2006, 15:18
googlah googlah is offline
Junior Member
 
Join Date: Aug 2006
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Talking Nope.

Well, not really snigel@27mhz.se, but something likely.

/etc/postfix/virtusertable configuration
Code:
###################################
#
# ISPConfig virtusertable Configuration File
#         Version 1.0
#
###################################
bobban@bobban.27mhz.se    bobban
raksu@raksu.27mhz.se    raksu
snigel@snigel.27mhz.se    snigel
w21od005@w21od005.27mhz.se    w21od005
roligt@roligt.27mhz.se    roligt
#### MAKE MANUAL ENTRIES BELOW THIS LINE! ####

And /etc/postfix/local-host-names looks like this,

Code:
###################################
#
# ISPConfig local-host-names Configuration File
#         Version 1.0
#
###################################
localhost
www.27mhz.se
localhost.www.27mhz.se
localhost.27mhz.se
21od005.27mhz.se
raksu.27mhz.se
snigel.27mhz.se
bobban.27mhz.se
roligt.27mhz.se
#### MAKE MANUAL ENTRIES BELOW THIS LINE! ####

Once again, please don't stop this, we're so close, I'm sure.
Reply With Quote
  #6  
Old 8th August 2006, 09:37
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,488
Thanks: 813
Thanked 5,259 Times in 4,123 Posts
Default

Please add a co-domain 27mhz.se (with empty host field) to the website snigel.27mhz.se
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 8th August 2006, 15:24
googlah googlah is offline
Junior Member
 
Join Date: Aug 2006
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Then I get this error,

The name .27mhz.se is already in use by another site or domain.
The Domain belongs to another client. ?
Reply With Quote
  #8  
Old 8th August 2006, 18:16
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

It seems you're already using 27mhz.se for another web site. Use the search function to find out which one. Also check the recycle bins.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 8th August 2006, 18:23
googlah googlah is offline
Junior Member
 
Join Date: Aug 2006
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

This is how I have set up my clients/sites,

http://www.27mhz.se/ispconfig.jpg


Every client/site I set up already use 27mhz.se as it's primary domain.

Reply With Quote
  #10  
Old 9th August 2006, 15:48
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
 
Default

Quote:
Originally Posted by googlah
Every client/site I set up already use 27mhz.se as it's primary domain.
Yes, but with different hostnames so that's not a problem. Please check the Co-Domains tab of each of these web sites if there's a Co-Domain 27mhz.se without hostname.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can Send Email, But Not Recieve; Relay access denied jazzgillum Installation/Configuration 21 31st May 2007 12:46
Email relay access denied mydeputy Installation/Configuration 4 3rd August 2006 14:18
Sending email problems: Relay access denied jaffaizal HOWTO-Related Questions 35 24th April 2006 10:04
Questions in regards to ISP-Server Setup - Ubuntu 5.10 "Breezy Badger" rbrantley HOWTO-Related Questions 16 10th April 2006 18:26
Relay access denied KamiTsunami Server Operation 6 7th March 2006 10:25


All times are GMT +2. The time now is 18:20.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.