Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 17th January 2013, 15:15
mmckenna mmckenna is offline
Junior Member
 
Join Date: Jan 2013
Posts: 2
Thanks: 1
Thanked 0 Times in 0 Posts
Default Delay in domain name recognition

Hi all,

I'm just wondering if there is a way to reduce the time between creating a site in an ISPConfig server and for it to be recognised as a valid address on a client machine. I am using a local host server which is running nginx. At present I have to restart bind on my server and flush my DNS on a client machine in order to get the site recognised.

Thanks in advance,
M.
Reply With Quote
Sponsored Links
  #2  
Old 17th January 2013, 15:34
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,453
Thanks: 813
Thanked 5,222 Times in 4,092 Posts
Default

The bind restart is not required as bind is restarted / reloaded automatically when the domain gets created in dns. The issue is caused by the dns cache on your client machine or by a caching dns server which is used by your client computer to resolve names. A dns record has a field "ttl" which sets the time that caching servers hold a domain name in its cache vbefore they query your master dns server again. So if you set ttl to a smaller number, the changes will get recognized faster.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
mmckenna (17th January 2013)
  #3  
Old 17th January 2013, 15:43
mmckenna mmckenna is offline
Junior Member
 
Join Date: Jan 2013
Posts: 2
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default

Thanks Till, I'll have a look at reducing the ttl, makes sense.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Issues with Baruwa - The Perfect Spamsnake Ubuntu 10.10 neofire HOWTO-Related Questions 44 31st May 2011 15:09
Postfix queue problem? murunix Server Operation 7 2nd May 2011 01:55
Postfix not forwarding for some domains flappy Installation/Configuration 3 21st November 2010 17:57
freebsd 7, samba 3, domain controller alexdimarco Suggest HOWTO 6 5th November 2010 16:54
ERROR: Connection dropped by IMAP server. [Centos 5.4, courier imap,squirrel, etc] darevil HOWTO-Related Questions 7 9th June 2010 14:49


All times are GMT +2. The time now is 16:22.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.