Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 11th January 2013, 20:34
nox nox is offline
Junior Member
 
Join Date: Jan 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default When trying to install Nginx or Varnish

Regardless which I use (Nginx or Varnish, I use one or the other, never both), running them as a proxy (port 80) with Apache (port 8008, opened in iptables and all vhosts changed). All config files have Apache2 as backend, but I get "404, Not Found" errors.

Any way to fix this?

Thank you in advance!
Reply With Quote
Sponsored Links
  #2  
Old 11th January 2013, 20:44
nox nox is offline
Junior Member
 
Join Date: Jan 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

To add:

Error log reads:

script '/var/www/x.php' not found or unable to stat, referer: http://www.domain.com/x.php

Or

File does not exist: /var/www/admin, referer: http://domain.com/admin

So it is a path issue. In vhost for x domain, it contains the full path.

Code:
<Directory /var/www/x.com>
    AllowOverride None
    Order Deny,Allow
    Deny from all
</Directory>

<VirtualHost 1.1.1.1:8008>
      DocumentRoot /var/www/x.com/web
Seems like the path in the error is wrong. Stopping short... example: /var/www/[looking here] instead of /var/www/x.com/web/[looking here]. How do I go about fixing this?

Thanks!

Last edited by nox; 11th January 2013 at 21:34.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
how to install ? nginx into kloxo onel0ve Installation/Configuration 2 18th February 2012 09:23
update services on ubuntu kwickcut HOWTO-Related Questions 3 12th February 2011 01:45
Install failure -- Apache 1.3 missing? Allen15 Installation/Configuration 11 24th February 2009 09:53
problem install perl modules Cirox Installation/Configuration 10 16th May 2007 16:04
/usr/bin/make install install HTML::Parser -- NOT OK oddo Installation/Configuration 4 14th March 2006 18:32


All times are GMT +2. The time now is 07:28.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.