#1  
Old 7th January 2013, 13:34
teves teves is offline
Senior Member
 
Join Date: Oct 2006
Posts: 149
Thanks: 27
Thanked 13 Times in 10 Posts
Default Postfix configuration problem

Hello,

I have a small problem with my postfix configuration.
In the /var/log/mail.log file I get warnings like the following:
warning: 127.0.0.1: address not listed for hostname localhost.localdomain
very regularly.
I searched this issue in the forum and it has already been discussed, but not solved seemingly.
After trying some things I spotted the detail in the master.cf which is responsible for those messages:
content_filter = amavis:[127.0.0.1]:10024
After commenting out this line I get no warnings any more. But this can not be the solution....
Any ideas what I cound do about it?

Thank you!
Regards, Tom
Reply With Quote
Sponsored Links
  #2  
Old 7th January 2013, 13:59
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,504
Thanks: 813
Thanked 5,266 Times in 4,129 Posts
Default

Ensure that you have the line:

127.0.0.1 localhost localhost.localdomain

in your /etc/hosts file. Do not comment out theline content_filter = amavis:[127.0.0.1]:10024 because your mail system will stop working then.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 7th January 2013, 15:57
tafkaz tafkaz is offline
Member
 
Join Date: Sep 2007
Posts: 32
Thanks: 0
Thanked 9 Times in 3 Posts
 
Default

Hi Till,
we had this in our hosts-file already, but i think we found the problem.
As we are using an openVZ guest for ISPConfig our ifconfig looks like this:

Code:
lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:11007 errors:0 dropped:0 overruns:0 frame:0
          TX packets:11007 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:997376 (974.0 KiB)  TX bytes:997376 (974.0 KiB)

venet0    Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
          inet addr:127.0.0.2  P-t-P:127.0.0.2  Bcast:0.0.0.0  Mask:255.255.255.255
          UP BROADCAST POINTOPOINT RUNNING NOARP  MTU:1500  Metric:1
          RX packets:9581 errors:0 dropped:0 overruns:0 frame:0
          TX packets:9086 errors:0 dropped:21 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:908263 (886.9 KiB)  TX bytes:2444074 (2.3 MiB)

venet0:0  Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
          inet addr:123.123.666.666  P-t-P:123.123.666.666  Bcast:0.0.0.0  Mask:255.255.255.255
          UP BROADCAST POINTOPOINT RUNNING NOARP  MTU:1500  Metric:1
So i guess i will have to add

Code:
127.0.0.2 localhost.localdomain localhost
to my hosts-file?

can i leave
Code:
127.0.0.1 localhost.localdomain localhost
in it as well, or should that line be replaced totally?

Thank you very much
Sascha
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sending mails: fine > recive: bad Moundy General 1 19th June 2012 23:40
All my mail is going to /var/mail/vmail _sluimers_ Installation/Configuration 21 10th January 2011 13:21
Mail server using Postfix, Dovecot, Mysql... Postfix virtual maps doesn't work?? tarasbuljba HOWTO-Related Questions 33 28th May 2010 14:33
Cannot send or receive mail farbrorc Installation/Configuration 6 24th January 2010 11:56
localhost postfix/master: fatal: bind 127.0.0.1 port 125: Permission denied g18c Installation/Configuration 4 24th March 2009 17:39


All times are GMT +2. The time now is 14:02.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.