Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 27th March 2013, 12:58
dusandevic dusandevic is offline
Junior Member
 
Join Date: Mar 2013
Posts: 8
Thanks: 1
Thanked 1 Time in 1 Post
Default Roundcube Soap Error: Error Fetching http headers

I have problems with Debian Squeeze/ISPConfig 3.0.5.1 and Roundcube mail client. Sending and receiving works fine, but I can't change my password, set e-mail forwarding (from RoundCube, ISPConfig mail fw works).

I tried a few things I've found online for this problem, but really can't step off "Soap Error: Error Fetching http headers".

I do not have certificate for SSL.

I've found this:
Q: I get an error "Soap Error: fetching http headers"
A: This happens when the plugins are trying to reach your interface under http but you have it run it under https. So just change it in the config file.

Tried to play with force https variables (true/false), no luck.

Any ideas?
Reply With Quote
Sponsored Links
  #2  
Old 27th March 2013, 15:39
Horfic Horfic is offline
Senior Member
 
Join Date: Mar 2009
Location: Austria
Posts: 325
Thanks: 55
Thanked 95 Times in 60 Posts
Send a message via Skype™ to Horfic
Default

do you have the newest version of the plugins?
__________________
web wack creations - We create your custom web application
Mailuser interface for ISPConfig 3
Reply With Quote
  #3  
Old 27th March 2013, 15:42
dusandevic dusandevic is offline
Junior Member
 
Join Date: Mar 2013
Posts: 8
Thanks: 1
Thanked 1 Time in 1 Post
Default

Yes, i have the newest versions.
Reply With Quote
  #4  
Old 27th March 2013, 15:43
Horfic Horfic is offline
Senior Member
 
Join Date: Mar 2009
Location: Austria
Posts: 325
Thanks: 55
Thanked 95 Times in 60 Posts
Send a message via Skype™ to Horfic
Default

are you using, https on ispconfig or http? which port are you using? default?
__________________
web wack creations - We create your custom web application
Mailuser interface for ISPConfig 3
Reply With Quote
  #5  
Old 27th March 2013, 15:45
dusandevic dusandevic is offline
Junior Member
 
Join Date: Mar 2013
Posts: 8
Thanks: 1
Thanked 1 Time in 1 Post
Default

I am using https on ispconfig, default port.
Reply With Quote
  #6  
Old 27th March 2013, 15:47
Horfic Horfic is offline
Senior Member
 
Join Date: Mar 2009
Location: Austria
Posts: 325
Thanks: 55
Thanked 95 Times in 60 Posts
Send a message via Skype™ to Horfic
Default

so your config would be

https://<<YOUR SERVER>>:8080/remote/
__________________
web wack creations - We create your custom web application
Mailuser interface for ISPConfig 3
Reply With Quote
  #7  
Old 27th March 2013, 15:51
dusandevic dusandevic is offline
Junior Member
 
Join Date: Mar 2013
Posts: 8
Thanks: 1
Thanked 1 Time in 1 Post
Default

I am accessing ISPconfig login panel via https://server1.dusandevic.com:8080 and not sure what /remote means.
Reply With Quote
  #8  
Old 27th March 2013, 16:00
Horfic Horfic is offline
Senior Member
 
Join Date: Mar 2009
Location: Austria
Posts: 325
Thanks: 55
Thanked 95 Times in 60 Posts
Send a message via Skype™ to Horfic
Default

install instruction, step 5

http://bugs.web-wack.at/documents/1
__________________
web wack creations - We create your custom web application
Mailuser interface for ISPConfig 3
Reply With Quote
The Following 2 Users Say Thank You to Horfic For This Useful Post:
dusandevic (27th March 2013), nenad (27th March 2013)
  #9  
Old 27th March 2013, 16:02
dusandevic dusandevic is offline
Junior Member
 
Join Date: Mar 2013
Posts: 8
Thanks: 1
Thanked 1 Time in 1 Post
Default

Thanks a lot, I will take care of that. My friend installed ISPConfig for me so I don't have a lot of experience with that settings.
Reply With Quote
  #10  
Old 27th March 2013, 17:26
dusandevic dusandevic is offline
Junior Member
 
Join Date: Mar 2013
Posts: 8
Thanks: 1
Thanked 1 Time in 1 Post
 
Default

Set this to https and now everything is great:

$rcmail_config['soap_url'] = 'https://<<YOUR SERVER>>:8080/remote/';

Thanks a lot!
Reply With Quote
The Following User Says Thank You to dusandevic For This Useful Post:
nenad (27th March 2013)
Reply

Bookmarks

Tags
mail error, roundcube, soap error

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Soap Error: Error Fetching http headers Olgierd General 14 14th March 2012 17:25
How to upgrade Roundcube 0.3 to 0.7 on Ubuntu 10.04 LTS cbj4074 Tips/Tricks/Mods 1 19th January 2012 20:50
HTTP POST request over GPRS doesn't work. hiharsh Technical 2 23rd July 2008 17:52
How to hide web server configuration from HTTP headers? calande Installation/Configuration 2 9th May 2006 23:59
KErnel not showing all my memory Jorem Kernel Questions 8 13th April 2006 13:59


All times are GMT +2. The time now is 06:03.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.