#1  
Old 18th December 2012, 21:49
kendel kendel is offline
HowtoForge Supporter
 
Join Date: Aug 2010
Posts: 132
Thanks: 4
Thanked 1 Time in 1 Post
Default Unusual Problem

Server domain does not want to resolve the nameserver but all other domains work fine.

so domain example.com that are using my nameservers ns1.example.com & ns2.example.com don't work.

But thissite.com and mysite.com work fine, using the same dns records. I ran intoDNS and example.com gives dns errors.

How can I fix this or what might be the problem?
Reply With Quote
Sponsored Links
  #2  
Old 19th December 2012, 11:55
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

Sounds as if you need a glue record: https://en.wikipedia.org/wiki/Domain...d_glue_records
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 20th December 2012, 02:55
kendel kendel is offline
HowtoForge Supporter
 
Join Date: Aug 2010
Posts: 132
Thanks: 4
Thanked 1 Time in 1 Post
Default

I already have a glue record for ns1.lampxserver.com and ns2.lampxserver.com


but domain lampxserver.com dosnt work... intodns gives an error...


but using same dns records... domain gbpserver.com works fine...

if I switch the ns1 and ns2 to the internal ip address it somehow resolves..
Reply With Quote
  #4  
Old 20th December 2012, 10:33
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

Check the log for bind / named errors with:

grep named /var/log/syslog
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 22nd December 2012, 07:29
kendel kendel is offline
HowtoForge Supporter
 
Join Date: Aug 2010
Posts: 132
Thanks: 4
Thanked 1 Time in 1 Post
Default

I see the errors
Code:
Dec 22 00:22:01 ns1 named[899]: reloading zones succeeded
Dec 22 00:22:01 ns1 named[899]: zone ahostgroup.com/IN: sending notifies (serial                                                                                                                      2012122201)
Dec 22 00:22:01 ns1 named[899]: zone gbpserver.com/IN: sending notifies (serial                                                                                                                      2012122201)
Dec 22 00:22:41 ns1 named[899]: client 93.113.174.225#35315: query (cache) 'adob                                                                                                                     e.com/A/IN' denied
Dec 22 00:22:41 ns1 named[899]: client 93.113.174.225#10349: query (cache) 'adob                                                                                                                     e.com/A/IN' denied
Dec 22 00:22:57 ns1 named[899]: client 93.113.174.225#34026: query (cache) 'adob                                                                                                                     e.com/A/IN' denied
Dec 22 00:22:57 ns1 named[899]: client 93.113.174.225#15481: query (cache) 'adob                                                                                                                     e.com/A/IN' denied
Dec 22 00:23:02 ns1 named[899]: received control channel command 'reload'
Dec 22 00:23:02 ns1 named[899]: loading configuration from '/etc/bind/named.conf                                                                                                                     '
Dec 22 00:23:02 ns1 named[899]: reading built-in trusted keys from file '/etc/bi                                                                                                                     nd/bind.keys'
Dec 22 00:23:02 ns1 named[899]: using default UDP/IPv4 port range: [1024, 65535]
Dec 22 00:23:02 ns1 named[899]: using default UDP/IPv6 port range: [1024, 65535]
Dec 22 00:23:02 ns1 named[899]: sizing zone task pool based on 8 zones
Dec 22 00:23:02 ns1 named[899]: using built-in root key for view _default
Dec 22 00:23:02 ns1 named[899]: Warning: 'empty-zones-enable/disable-empty-zone'                                                                                                                      not set: disabling RFC 1918 empty zones
Dec 22 00:23:02 ns1 named[899]: reloading configuration succeeded
Dec 22 00:23:02 ns1 named[899]: zone lampxserver.com/IN: NS 'ns1.lampxserver.com                                                                                                                     ' has no address records (A or AAAA)
Dec 22 00:23:02 ns1 named[899]: zone lampxserver.com/IN: NS 'ns2.lampxserver.com                                                                                                                     ' has no address records (A or AAAA)
Dec 22 00:23:02 ns1 named[899]: zone lampxserver.com/IN: not loaded due to error                                                                                                                     s.
Dec 22 00:23:02 ns1 named[899]: reloading zones succeeded
Dec 22 00:23:02 ns1 named[899]: zone ahostgroup.com/IN: loaded serial 2012122202
Dec 22 00:23:02 ns1 named[899]: zone gbpserver.com/IN: loaded serial 2012122202
Dec 22 00:23:02 ns1 named[899]: zone gbpserver.com/IN: sending notifies (serial                                                                                                                      2012122202)
Dec 22 00:23:02 ns1 named[899]: zone ahostgroup.com/IN: sending notifies (serial                                                                                                                      2012122202)
Reply With Quote
  #6  
Old 22nd December 2012, 09:10
kendel kendel is offline
HowtoForge Supporter
 
Join Date: Aug 2010
Posts: 132
Thanks: 4
Thanked 1 Time in 1 Post
 
Default

This has been solved.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sending mails: fine > recive: bad Moundy General 1 20th June 2012 00:40
Courier Imap is not working HellMind General 5 12th April 2012 02:04
Strange email problem for one of my domains... any help appreciated paulrobert_a Installation/Configuration 5 9th August 2010 15:15
ISPConfig3 Mail Warn Errors reason8 General 3 25th November 2009 14:58
BIG Problem Postfix issue admins Installation/Configuration 11 13th November 2009 11:05


All times are GMT +2. The time now is 12:56.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.