Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 5th July 2006, 16:23
jenjen jenjen is offline
Junior Member
 
Join Date: Jul 2006
Posts: 18
Thanks: 1
Thanked 0 Times in 0 Posts
Default ProFTP cannot login with 3rd party utils.

Regarding PROFTP problems, here is a new post:
I have been following the thread posted by tarndt June 28th and I have tried most of the suggestions by falko. One of the interesting tests is to login through putty to ftp localhost. The usernames and passwords work, the same usernames and passwords work with web-FTP through ISPConfig. Unfortunately, when logging in using smart FTP get "login incorrect".

Netstat -tap returns:

tcp 0 0 *:ftp *:* LISTEN 22907/proftpd: (acc

If I set the site to anonymous login, I can login with SmartFTP.
The users are in /etc/passwd although there is also another file /etc/passwd- and the users are also in it.

I have turned off the ISPConfig firewall as I have some rules that it cannot duplicate, but whethor it is on or off, same result. ISPconfig also has the FTP service enabled. I don't think there is a problem here, as it can connect anonymously.

I have looked at proftp.conf and proftp_ispconfig.conf and compared them with another server that all of this works on, they look similar.
So I am stumped, if there are any other suggestions, I would appreciate hearing them!

Last edited by jenjen; 5th July 2006 at 16:25.
Reply With Quote
Sponsored Links
  #2  
Old 6th July 2006, 12:43
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Have you tried both active and passive transfers in SmartFTP?
What's the output of
Code:
netstat -tap
and
Code:
iptables -L
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 17th July 2006, 19:53
jenjen jenjen is offline
Junior Member
 
Join Date: Jul 2006
Posts: 18
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Thank you for replying to my query. I have tried both passive FTP and it also will not work.
The output of netstat -tap is in my first post, it appears that FTP is listening on all interfaces.
Iptables -L yields:
ACCEPT tcp -- anywhere anywhere tcp dpt:ftp state NEW
which to me looks like it should work.
Reply With Quote
  #4  
Old 18th July 2006, 13:09
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Can you turn off the firewall and try again?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 18th July 2006, 22:36
jenjen jenjen is offline
Junior Member
 
Join Date: Jul 2006
Posts: 18
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
Can you turn off the firewall and try again?
I have tried this now with the firewall off on the Linux box and Off in ISPConfig. I can't get access.
I have also been using for most of my testing, the Linux firewall on and the ISPConfig firewall off.

Now I have turned off Linux firewall and restarted the ISPConfig firewall....
and that doesn't work either.
This is just not making sense!
I added the user for this website to the Secondary group ftp, and I have looked into the logs and I see:

Jul 18 16:33:45 web05 proftpd[8366]: 209.104.160.5 (209.104.160.30[209.104.160.30]) - PAM(web11_th
eatre): Authentication failure.

So I am now going through and trying to see if there is some access list that these users need to be in and are not.
Please write back with any suggested areas I need to check in, I will be reviewing your other posts as well.
Thanks!
Reply With Quote
  #6  
Old 18th July 2006, 22:52
jenjen jenjen is offline
Junior Member
 
Join Date: Jul 2006
Posts: 18
Thanks: 1
Thanked 0 Times in 0 Posts
Default more information on proftp with ISPConfig

I noticed in one of the other posts, you had looked at the contents of the /etc/proftp_ispconfig.conf files, mine appear to be slightly different, rather than one virtual host, there are 2:

<VirtualHost 209.104.160.22>
DefaultRoot ~
AllowOverwrite on
Umask 002
</VirtualHost>
<VirtualHost 209.104.160.5>
DefaultRoot ~
AllowOverwrite on
Umask 002
</VirtualHost>
Reply With Quote
  #7  
Old 19th July 2006, 14:18
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Quote:
Originally Posted by jenjen
Now I have turned off Linux firewall and restarted the ISPConfig firewall....
Never use two different firewalls at the same time. It will mess up your firewall rules, resulting in unforeseeable behaviour! Either use your Linux firewall, or use the ISPConfig firewall, but not both at the same time.

Which distribution do you use?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 20th July 2006, 15:36
jenjen jenjen is offline
Junior Member
 
Join Date: Jul 2006
Posts: 18
Thanks: 1
Thanked 0 Times in 0 Posts
Default

I am generally only using the Linux firewall but in this case on this server I am trying anything to see if I have done something wrong, in other words I am desperate! (-:

Could you please explain what you need to know regarding distribution? do you mean distribution of ISPConfig or Linux firewall?
Reply With Quote
  #9  
Old 21st July 2006, 13:42
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Quote:
Originally Posted by jenjen
Could you please explain what you need to know regarding distribution? do you mean distribution of ISPConfig or Linux firewall?
I want to know if you use Debian, Fedora, SuSE, Mandriva, CentOS, ..., and which version of that distribution.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #10  
Old 21st July 2006, 14:41
fobicodam fobicodam is offline
Senior Member
 
Join Date: Apr 2006
Location: Argentina
Posts: 346
Thanks: 0
Thanked 1 Time in 1 Post
Send a message via MSN to fobicodam
 
Default

I know its a stupid idea, but... are you writing the username/passwords right? are you using webXX_XXX ? what about password capital letters? linux is case sensitive.

you said you can log in anonymously, so, i dont believe its firewall problem..

Try disable pasive transfer or using the ftp command under windows.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
kann keine mails empfangen odin1 Installation/Configuration 5 6th July 2006 12:13
Problem with POP3 Login masterkain Installation/Configuration 6 15th January 2006 18:11
authdaemon LOGIN: REJECT dgradzik Tips/Tricks/Mods 2 22nd September 2005 00:09
authdaemon LOGIN: REJECT dgradzik Installation/Configuration 2 21st September 2005 18:03
Total Frustration-HELP palkat Installation/Configuration 17 3rd September 2005 17:28


All times are GMT +2. The time now is 23:12.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.