Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 29th May 2013, 10:24
jboud jboud is offline
Member
 
Join Date: Dec 2010
Posts: 45
Thanks: 10
Thanked 8 Times in 3 Posts
Default

Hello, I'm trying for days now to collect bits and bytes from all successful stories and tutorials and I'm stuck.

I have Debian squeeze installed with perfect server setup and ispconfig 3 and I'm trying to install additional vesrion of php 5.2.17(or any 5.2). This thread comes closer to my attempts but I also used the guide you have linked earlier Falko. I'm stuck on ./configure with the error:

configure: error: libjpeg.(a|so) not found.

I tried some generic hints from searching google but I've had no success.
I'm asking for any kind of help regarding this error, or If anyone has any success story with my setup.

Thank you!
Reply With Quote
Sponsored Links
  #12  
Old 29th May 2013, 11:41
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

The libjpeg library or dev package from debian seems to be missing.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #13  
Old 29th May 2013, 11:47
jboud jboud is offline
Member
 
Join Date: Dec 2010
Posts: 45
Thanks: 10
Thanked 8 Times in 3 Posts
Default

Hey Thanks for the reply.

They do look like they're missing but have a look:

apt-get install libjpeg-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'libjpeg62-dev' instead of 'libjpeg-dev'
libjpeg62-dev is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

apt-get install libjpeg62
Reading package lists... Done
Building dependency tree
Reading state information... Done
libjpeg62 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

root@somwhere:/usr/lib# ls -l libjp*
-rw-r--r-- 1 root root 221942 Jun 30 2010 libjpeg.a
-rw-r--r-- 1 root root 918 Jun 30 2010 libjpeg.la
lrwxrwxrwx 1 root root 17 May 29 02:07 libjpeg.so -> libjpeg.so.62.0.0
lrwxrwxrwx 1 root root 17 May 17 02:55 libjpeg.so.62 -> libjpeg.so.62.0.0
-rw-r--r-- 1 root root 145048 Jun 30 2010 libjpeg.so.62.0.0

Also have symlinks, I read something about that. I also make symlinks on /opt, read about such solution on another place.
Reply With Quote
  #14  
Old 29th May 2013, 12:13
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

This seems to be fine indeed. Then I've no idea why it complains about that missing library.

When I compiled multiple php versions the last few times I used phpfarm for that:

http://cweiske.de/tagebuch/Introducing%20phpfarm.htm
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #15  
Old 29th May 2013, 12:20
jboud jboud is offline
Member
 
Join Date: Dec 2010
Posts: 45
Thanks: 10
Thanked 8 Times in 3 Posts
Default

Thank you for quick response once again.

I don't care that much on why I can't install it or fix it. Could you point me on some direction for that phpfarm? A successful tutorial for installing it on debian squeeze and how to use it with ispconfig 3?

I know there are a bunch out there, but I trust you more in pointing me to the best

Thank you once again.
Reply With Quote
  #16  
Old 29th May 2013, 12:47
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

The link that I posted above are the instructions that I used to install and use it. There is nothing special regarding ispconfig except that you just have to add the path to the newly compiled php binary in ispconfig as additional php version.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #17  
Old 29th May 2013, 12:59
jboud jboud is offline
Member
 
Join Date: Dec 2010
Posts: 45
Thanks: 10
Thanked 8 Times in 3 Posts
Default

okey, doing it already. Compile take long enough for me to write here. I'll post my feedback and hopefully my success story.
Reply With Quote
  #18  
Old 30th May 2013, 08:49
jboud jboud is offline
Member
 
Join Date: Dec 2010
Posts: 45
Thanks: 10
Thanked 8 Times in 3 Posts
Default

Ok, I did it. The first time it crashed my server. Maybe because it's a live installation and I did it during prime time Anyway, the second time it compiled my php 5.2.17 version successfully. Now, the million dollar quetion. What are the paths I should include in ispconfig?
Reply With Quote
  #19  
Old 30th May 2013, 08:58
jboud jboud is offline
Member
 
Join Date: Dec 2010
Posts: 45
Thanks: 10
Thanked 8 Times in 3 Posts
Default

I tried:
/opt/phpfarm/inst/php-5.2.17/bin and
/opt/phpfarm/inst/php-5.2.17/lib

but I'm getting internal server error on the website I activated it.
Reply With Quote
  #20  
Old 4th June 2013, 09:52
jboud jboud is offline
Member
 
Join Date: Dec 2010
Posts: 45
Thanks: 10
Thanked 8 Times in 3 Posts
 
Default

Hello, I still haven't solve this. My phpfarm compiles fine whatever version of php I ask it for, but my website is always giving me Internal Server Error when I activate it on ISPConfig 3.

Do my paths look ok like that or I need to look somewhere else in my system to solve this issue?

Thanks.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Only Problems since Updating from 3.0.3.3 to 3.0.4.1 mbay General 4 17th May 2012 12:56
ubuntu and nginx delgado2061 Installation/Configuration 0 27th November 2011 23:36
Problem with services!! banzaiwebstudio.com Installation/Configuration 7 19th May 2010 21:13
Unable to install ISPConfig bdonecker Installation/Configuration 21 26th May 2009 08:20
Apache2 Freezes celtic Server Operation 31 28th May 2007 17:18


All times are GMT +2. The time now is 00:50.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.