Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 26th November 2012, 13:33
kurdak kurdak is offline
Junior Member
 
Join Date: Nov 2012
Posts: 19
Thanks: 6
Thanked 0 Times in 0 Posts
Default PHP Multiple versions

Hello !
I installed ISPConfig 3.0.5.
Please help me how to install Debian 6 php version 5.2 and how to configure ISPConfig.

Regards.
Reply With Quote
Sponsored Links
  #2  
Old 27th November 2012, 12:46
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

Take a look at chapter 14.3 on http://www.howtoforge.com/perfect-se...ispconfig-3-p4 . This should work for PHP 5.2 as well. Please note that you can only use FastCGI with PHP 5.2, not PHP-FPM because PHP-FPM has a different syntax in 5.2 compared to 5.3 and 5.4.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 27th November 2012, 12:58
kurdak kurdak is offline
Junior Member
 
Join Date: Nov 2012
Posts: 19
Thanks: 6
Thanked 0 Times in 0 Posts
Default

Okay, so I made so far these commands:
Code:
mkdir /opt/php-5.2.17
mkdir /usr/local/src/php5-build
cd /usr/local/src/php5-build
wget http://de.php.net/get/php-5.2.17.tar.bz2/from/this/mirror -O php-5.2.17.tar.bz2
tar jxf php-5.2.17.tar.bz2
cd php-5.2.17/
Now I need to configure PHP 5.2.17:
Code:
./configure \
--prefix=/opt/php-5.2.17 \
--enable-fastcgi \
--disable-rpath \    - If this setting is turned on I get the same extras as the main PHP?
--with-mysql
I made:
Code:
make
make install
cp /usr/local/src/php5-build/php-5.2.17/php.ini-recommended /opt/php-5.2.17/lib/php.ini
In ISPConfig setting Additional PHP Versions:
Additional PHP Versions: /opt/php-5.2.17/bin/php
Path to the php.ini directory: /opt/php-5.2.17/lib

And now if I go to the my sub.domian.com I get: ERROR 500 - Internal Server Error
Now what I have to do?

Last edited by kurdak; 29th November 2012 at 11:15.
Reply With Quote
  #4  
Old 28th November 2012, 14:31
kurdak kurdak is offline
Junior Member
 
Join Date: Nov 2012
Posts: 19
Thanks: 6
Thanked 0 Times in 0 Posts
Default

I get the following errors:
error.log:
Code:
(104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server
Premature end of script headers: index.php
suexec.log:
Code:
[2012-11-28 13:26:17]: uid: (5008/web12) gid: (5006/client0) cmd: .php-fcgi-starter
When I type this command in shell:
/opt/php-5.2.17/bin/php /var/www/sub.domain.com/web/index.php
Shows me correctly script written in php.
Please help me !

Last edited by kurdak; 28th November 2012 at 14:35.
Reply With Quote
  #5  
Old 28th November 2012, 18:06
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

I'm getting the same error. I'm currently investigating this...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 28th November 2012, 19:36
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

I've found the problem and have updated the instructions on http://www.howtoforge.com/perfect-se...ispconfig-3-p4
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
kurdak (28th November 2012)
  #7  
Old 28th November 2012, 22:47
kurdak kurdak is offline
Junior Member
 
Join Date: Nov 2012
Posts: 19
Thanks: 6
Thanked 0 Times in 0 Posts
Default

In Debian Squeeze to configure on clear install:
Code:
./configure \
--prefix=/opt/php-5.2.17 \
--with-mysql --enable-cgi \
--with-zlib-dir \
--with-freetype-dir \
--enable-mbstring \
--with-libxml-dir=/usr \
--enable-soap \
--enable-calendar \
--with-zlib \
--with-gd \
--disable-rpath \
--enable-inline-optimization \
--with-bz2 \
--enable-sockets \
--enable-sysvsem \
--enable-sysvshm \
--enable-pcntl \
--enable-mbregex \
--enable-zip \
--with-pcre-regex \
--with-pdo-mysql \
--with-mysqli
Of course, we also need:

apt-get build-dep php5
apt-get install libfcgi-dev libfcgi0ldbl libjpeg62-dbg libmcrypt-dev libssl-dev

Last edited by kurdak; 29th November 2012 at 10:42.
Reply With Quote
  #8  
Old 29th November 2012, 11:29
kurdak kurdak is offline
Junior Member
 
Join Date: Nov 2012
Posts: 19
Thanks: 6
Thanked 0 Times in 0 Posts
Default

Okay, so once again I installed Debian 6 and ISPConfig third
I did everything as we wrote above.
Dlaej the same error 500: (

Respect for help.

Last edited by kurdak; 29th November 2012 at 12:39.
Reply With Quote
  #9  
Old 29th November 2012, 13:09
kurdak kurdak is offline
Junior Member
 
Join Date: Nov 2012
Posts: 19
Thanks: 6
Thanked 0 Times in 0 Posts
Default

Code:
./configure \
--prefix=/opt/php-5.2.17 \
--with-libdir=/usr/lib
--with-freetype \
--enable-cgi \
--enable-mbstring \
--with-libxml \
--enable-soap \
--enable-calendar \
--with-curl \
--with-mcrypt \
--with-zlib \
--with-gd \
--disable-rpath \
--enable-inline-optimization \
--with-bz2 \
--with-zlib \
--enable-sockets \
--enable-sysvsem \
--enable-sysvshm \
--enable-pcntl \
--enable-mbregex \
--with-mhash \
--enable-zip \
--with-pcre-regex \
--with-mysql \
--with-pdo-mysql \
--with-mysqli \
--with-jpeg \
--with-png \
--enable-gd-native-ttf \
--with-openssl
But still:
Code:
ERROR 500

Last edited by kurdak; 29th November 2012 at 13:31.
Reply With Quote
  #10  
Old 30th November 2012, 16:59
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
 
Default

For PHP 5.2, you need to add

--enable-fastcgi

Configure options have changed between PHP 5.2 and 5.3.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Only Problems since Updating from 3.0.3.3 to 3.0.4.1 mbay General 4 17th May 2012 13:56
ubuntu and nginx delgado2061 Installation/Configuration 0 28th November 2011 00:36
Problem with services!! banzaiwebstudio.com Installation/Configuration 7 19th May 2010 22:13
Unable to install ISPConfig bdonecker Installation/Configuration 21 26th May 2009 09:20
Apache2 Freezes celtic Server Operation 31 28th May 2007 18:18


All times are GMT +2. The time now is 04:42.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.