#1  
Old 17th September 2005, 20:20
jmroth jmroth is offline
ISPConfig Developer
 
Join Date: Sep 2005
Posts: 191
Thanks: 1
Thanked 6 Times in 6 Posts
Default problem in interface for users

If I login as a site administrator/user, then click on the site on the left panel, then goto User&Email, it will display "Unlimited" in the Webspace MB field. If I try to switch tabs it complains that "Umlimited" is not a number (it complains in German, even if the language is set to English).
Also, if the user I have logged in as is the Administrator of the site itself), it will no longer be after I exit and look at the user again as the ISPConfig admin. All flags like Spamfilter, Antivirus, Catchall, Mailscan have also been reset. :-(
Last but not least: Can I configure the language in which the interface is displayed to the user in some other way except logging in as the user and selecting another language. Is there a default setting somewhere (I'd prefer English)?

Goodie: (Bug: see attached picture)
I called the hostname "mx" and it displayed this
Attached Images
 
Reply With Quote
Sponsored Links
  #2  
Old 18th September 2005, 11:02
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
 
Default

Quote:
Originally Posted by jmroth
If I login as a site administrator/user, then click on the site on the left panel, then goto User&Email, it will display "Unlimited" in the Webspace MB field. If I try to switch tabs it complains that "Umlimited" is not a number (it complains in German, even if the language is set to English).
Also, if the user I have logged in as is the Administrator of the site itself), it will no longer be after I exit and look at the user again as the ISPConfig admin. All flags like Spamfilter, Antivirus, Catchall, Mailscan have also been reset. :-(
This will be fixed in the next release. For now, simply uncomment the lines 652 - 656 in /home/admispconfig/ispconfig/web/isp_kunde/edit/edit.php. That's the following block:

PHP Code:
if($value == '-1'$value $go_api->lng("Unbegrenzt");
       if(
$element_val->name != 'web_mysql_anzahl_dbs' && $element_val->name != 'web_anonftplimit' && $element_val->name != 'server_id' && $element_val->name != 'web_speicher' && $element_val->name != 'web_traffic' && $element_val->name != 'web_userlimit' && $element_val->name != 'web_domainlimit' && $element_val->name != 'web_traffic_ueberschreitung' && $element_val->name != 'web_traffic_status'){
          if(
$value == '0'$value '<font color="#FF0000"><b>'.$go_api->lng("Nein").'</b></font>';
          if(
$value == '1'$value '<font color="#009F00"><b>'.$go_api->lng("Ja").'</b></font>';
        } 
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FTP very slow in LAN, "fast" from WAN-> Firewall problem? Pasco Server Operation 6 7th March 2006 15:17
Problem with WebFTP mystix General 7 7th October 2005 20:22
Installation problem xma Installation/Configuration 15 26th September 2005 13:22
Problem with webmail MyLinux General 10 17th September 2005 14:31
Installation problem: PHP problem? hgoor Installation/Configuration 7 21st August 2005 22:15


All times are GMT +2. The time now is 05:19.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.