Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 20th November 2012, 16:49
waltereyanu waltereyanu is offline
Junior Member
 
Join Date: Sep 2012
Posts: 10
Thanks: 0
Thanked 2 Times in 2 Posts
Default unison load balancing not keeping file permissions

Hello, am building a load balancer with unison, however though the files are coped file from one server to the other, their file permissions are reset to root:root. Is there a way of keeping file permissions intact and also how do i copy users from main server to back-up server?
Reply With Quote
Sponsored Links
  #2  
Old 20th November 2012, 16:55
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

Did you take a look at the configuration described in the debian 6 ispconfig 3 cluster Tutorial? The unsison configuration used in that guide keeps the file permissions during sync.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 21st November 2012, 07:34
waltereyanu waltereyanu is offline
Junior Member
 
Join Date: Sep 2012
Posts: 10
Thanks: 0
Thanked 2 Times in 2 Posts
Default

Yes i did follow the settings, this the tutorial i was following:http://www.howtoforge.com/installing...ispconfig-3-p5
Reply With Quote
  #4  
Old 21st November 2012, 10:59
waltereyanu waltereyanu is offline
Junior Member
 
Join Date: Sep 2012
Posts: 10
Thanks: 0
Thanked 2 Times in 2 Posts
Default

Hey Till, i have configured my domains with 2 A records, for testing purposes i switch off server1 and the websites now show:
Quote:
Welcome to nginx!

If you see this page, the nginx web server is successfully installed and working. Further configuration is required.

For online documentation and support please refer to nginx.org.
Commercial support is available at nginx.com.

Thank you for using nginx.
Further investigations show that in the folder /etc/nginx/sites-enabled/ on server1 are not the same with server2 do i also have to sync them just as the /var/www/ folder?
Reply With Quote
  #5  
Old 21st November 2012, 11:02
waltereyanu waltereyanu is offline
Junior Member
 
Join Date: Sep 2012
Posts: 10
Thanks: 0
Thanked 2 Times in 2 Posts
Default

Even if i do a copy those files have got links attacked to them and this is a sample:
Quote:
lrwxrwxrwx 1 root root 37 Nov 19 18:44 000-apps.vhost -> /etc/nginx/sites-available/apps.vhost
lrwxrwxrwx 1 root root 34 Nov 19 18:25 default -> /etc/nginx/sites-available/default
Reply With Quote
  #6  
Old 21st November 2012, 11:30
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
 
Default

These are links and have to be links and not files. The owner of the link shall be root and the permissions are fine as well.

Quote:
Further investigations show that in the folder /etc/nginx/sites-enabled/ on server1 are not the same with server2 do i also have to sync them just as the /var/www/ folder?
No, they are synced by ispconfig. Dont apply any other sync like unison on them or you will break the server!

If they dont get mirrored by ispconfig, then your slave server is not setup correctly or you did not add the salve server before you added the first website on the master. The most likely reason is that the slave can not connect to the master due to wrong host settings. See here for debug instructions:

http://www.howtoforge.com/forums/showthread.php?t=58408

Reagrding the unison sync problem, if your slave server is not connected correctly to the master or you added sites on the master before you added the slave, then the users that own the files dont exist on the slave which will explain why unison has to store the files as root.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ioncube install kwickcut Installation/Configuration 6 17th May 2013 22:00
ISPConfig 2: Firewall function not working gragus Installation/Configuration 10 5th March 2012 21:11
ISPConfig 3.0.3.3 Autoresponder, adding subdomain problem BlackHat Installation/Configuration 4 18th October 2011 15:24
rkhunter warnings esezako General 7 27th September 2011 08:28
Problem with services!! banzaiwebstudio.com Installation/Configuration 7 19th May 2010 22:13


All times are GMT +2. The time now is 10:39.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.