Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 25th March 2010, 05:36
abubin abubin is offline
Member
 
Join Date: Mar 2010
Posts: 81
Thanks: 0
Thanked 2 Times in 2 Posts
Default cannot open www.website.com

I have created a new website.com for test.

http://website.com --> can access
http://www.website.com --> cannot access

Quote:
Forbidden

You don't have permission to access / on this server.

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.
When I check the error log for website.com, I found as below:
Quote:
[Thu Mar 25 12:32:41 2010] [crit] [client xx.xx.xx.xx] (13)Permission denied: /var/www/website.com/web/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable
Everything is default. Inside .htaccess, it's empty.

Created another sites and same problem.

Deleted "default" website that comes with ubuntu and same problem.
Reply With Quote
Sponsored Links
  #2  
Old 25th March 2010, 05:43
abubin abubin is offline
Member
 
Join Date: Mar 2010
Posts: 81
Thanks: 0
Thanked 2 Times in 2 Posts
Default

hmm..ok solved the problem by chmod 755 web directory.

But the directory permission was default created by ispconfig at
Quote:
drwxr-x--x 2 web7 client1 4.0K 2010-03-25 12:42 cgi-bin
lrwxrwxrwx 1 web7 client1 34 2010-03-25 12:42 log -> /var/log/ispconfig/httpd/bbbbb.org
drwxr-x--x 2 web7 client1 4.0K 2010-03-25 12:42 ssl
drwxrwxrwx 2 web7 client1 4.0K 2010-03-25 12:42 tmp
drwx--x--- 4 web7 client1 4.0K 2010-03-25 12:42 web
So, I have to chmod the web folder to 755 everytime I create a website?

Something must be wrong with my setup?
Reply With Quote
The Following User Says Thank You to abubin For This Useful Post:
Toucan (2nd April 2010)
  #3  
Old 2nd April 2010, 06:12
abubin abubin is offline
Member
 
Join Date: Mar 2010
Posts: 81
Thanks: 0
Thanked 2 Times in 2 Posts
Default

can someone help me to trace this problem? I do no want to have to chmod the web folder each time I create a new site.

Thanks.
Reply With Quote
  #4  
Old 2nd April 2010, 09:48
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Quote:
So, I have to chmod the web folder to 755 everytime I create a website?
no.

Quote:
Something must be wrong with my setup?
yes.


1) Which linux distribution?
2) Which php mode?
3) Suexec enabled?
You should check if the apache user is
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 5th April 2010, 08:34
abubin abubin is offline
Member
 
Join Date: Mar 2010
Posts: 81
Thanks: 0
Thanked 2 Times in 2 Posts
Default

1) ubuntu 8.04.4 LTS
2) php fast-cgi
3) suexec enable (follow guide from http://www.howtoforge.com/perfect-se...ntu8.04-lts-p6)

skipped installing DNS server
skipped installing Postfix With SMTP-AUTH And TLS (cause the server not using emails)
Reply With Quote
  #6  
Old 6th April 2010, 15:08
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Did you install ISPConfig 2 or 3? Because the tutorial is for ISPConfig 2, but you posted this in the ISPConfig 3 forum...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 7th April 2010, 09:13
abubin abubin is offline
Member
 
Join Date: Mar 2010
Posts: 81
Thanks: 0
Thanked 2 Times in 2 Posts
Default

sorry, this is what i followed : http://www.howtoforge.com/perfect-se...10-ispconfig-3

It is ispconfig3.
Reply With Quote
  #8  
Old 21st April 2010, 07:21
abubin abubin is offline
Member
 
Join Date: Mar 2010
Posts: 81
Thanks: 0
Thanked 2 Times in 2 Posts
Default

ok, i have looked at my installation of ispconfig 3 in another server running 3.0.1.6. This one also have the web folder's permission at drwx--x--- (710). So I am assuming this is the default permission created by ispconfig.

Problem is, this one works fine. I can create files even with root user and it will work if I use browser to open the file. Eg, test.html.

But the other which is running 3.0.2.1 still have this problem, I must chmod 755 the web folder only it will work. I also encountered a problem when I tried to access the stats folder. After a few times I tried to key in the password wrongly, somehow the web folder will get reset back to 710.

Please help....
Reply With Quote
  #9  
Old 26th July 2010, 08:01
abubin abubin is offline
Member
 
Join Date: Mar 2010
Posts: 81
Thanks: 0
Thanked 2 Times in 2 Posts
Default

anyone can help? The problem still persist. Everytime I make changes to any website, the web folder will be rwx--x--- again. I keep on have to chmod web folder to 755.

I know this is the default method and rwx--x--- should work on normal installation.

Apache is running as www-data.

Appreciate any help on this matter.
Reply With Quote
  #10  
Old 26th July 2010, 10:21
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
 
Default

The permissions rwx--x--- are correct and it is correct that ISPConfig changes them to rwx--x---. You should check the owner of your files. Chown then to the website user and client group of this website.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem 100% CPU ispconfig_httpd -DSSL Captain Installation/Configuration 7 8th March 2010 21:50
High on Lenny - Lvm Mount Problem Serverman Technical 1 23rd June 2009 16:26
ERROR: The PHP binary coming with ISPConfig does not work properly on your system! qvindesland Installation/Configuration 22 21st May 2007 16:05
Howto suggestion suse PhP ver 4 + Ver 5 wwparrish Suggest HOWTO 11 7th August 2006 13:29
open ports rayit General 6 18th January 2006 14:23


All times are GMT +2. The time now is 09:25.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.