Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #21  
Old 22nd January 2007, 15:05
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by Andee63
Yes I did

The output of uname -m is i686
So you have a 32bit system, not a 64bit one. The tutorial was written for 64bit systems. The only difference between the systems is that you must put

Code:
pwcheck_method: saslauthd
mech_list: plain login
into /usr/lib/sasl2/smtpd.conf instead of /usr/lib64/sasl2/smtpd.conf.

Please do that now and restart Postfix and saslauthd.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Sponsored Links
  #22  
Old 22nd January 2007, 16:48
Andee63 Andee63 is offline
HowtoForge Supporter
 
Join Date: Jan 2007
Location: Bradford, UK
Posts: 40
Thanks: 5
Thanked 0 Times in 0 Posts
Default

Thanks falko
I had already gathered the difference between the two was the folder so I had already made the swap
Reply With Quote
  #23  
Old 22nd January 2007, 17:29
Andee63 Andee63 is offline
HowtoForge Supporter
 
Join Date: Jan 2007
Location: Bradford, UK
Posts: 40
Thanks: 5
Thanked 0 Times in 0 Posts
Default

This is how I think I need to set up the mx records and dns



SETTINGS AT ISP SIDE
bookowl.co.uk mxrecord points to server1.elmtreedesign.co.uk

I then have a A record which points to 194.106.43.87 which is my public ip address

SETTINGS IN ISPCONFIG
bookowl.co.uk mx record points to mail.bookowl.co.uk

mail.bookowl.co.uk then points to pop.bookowl.co.uk c-name

pop.bookowl.co.uk then points to 127.0.0.1 a-record


This is my understanding of it. Am I right? If not can you put me right.
Reply With Quote
  #24  
Old 23rd January 2007, 11:06
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,788
Thanks: 840
Thanked 5,612 Times in 4,423 Posts
Default

Why dont you setup ISPConfig as you described the ISP side?

This setup is correct for ISPConfig too:

Quote:
bookowl.co.uk mxrecord points to server1.elmtreedesign.co.uk

I then have a A record which points to 194.106.43.87 which is my public ip address
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #25  
Old 23rd January 2007, 22:01
Andee63 Andee63 is offline
HowtoForge Supporter
 
Join Date: Jan 2007
Location: Bradford, UK
Posts: 40
Thanks: 5
Thanked 0 Times in 0 Posts
Default

Thanks till for that. I am still not getting any incoming. I did a port check at grc.com using shields up and they report that the port is stealth proberbly just times out. I have also done a check at canyouseeme.org and they report the connection timed out but occasionally reports that connection was refused. Is there anyway of opening the port easily to do a simple test so that I can iliminate all other external areas ie router/firewall (although this is off at moment). My isp has confirmed they dont block port 25.
Reply With Quote
  #26  
Old 24th January 2007, 11:12
Andee63 Andee63 is offline
HowtoForge Supporter
 
Join Date: Jan 2007
Location: Bradford, UK
Posts: 40
Thanks: 5
Thanked 0 Times in 0 Posts
Default

Finally got incoming connection to email server. The problem turned out to be a typo in the ip address on my router. I had 182.169.#.# instead of 192.168.#.#
You can imagine what I called myself lol.

Just to check over everything now.

Thanks guys for your help
Reply With Quote
  #27  
Old 15th April 2008, 03:22
schenkman schenkman is offline
Junior Member
 
Join Date: Mar 2007
Posts: 1
Thanks: 0
Thanked 2 Times in 1 Post
Default

I know this is an old post but in my search of trying to find out why I had that exact error of:

Code:
Apr 14 18:03:08 flamingweasel postfix/smtp[17932]: fatal: specify a password table via the `smtp_sasl_password_maps' configuration parameter
Is due to a typo in your configuration that goes undetected (very similar to writing C or C++ code and doing variable assignment with '=' where you meant to do conditional testing with '=='). The line you have is:

Code:
smtp_sasl_auth_enable = yes
Where you want it to be:

Code:
smtpd_sasl_auth_enable = yes
The omission of the letter 'd' there has made my life very difficult, but that's the answer to the fatal error in the log file.

-schenkman
Reply With Quote
The Following 2 Users Say Thank You to schenkman For This Useful Post:
krizze (31st May 2010), Versus (1st October 2010)
  #28  
Old 31st May 2010, 22:05
krizze krizze is offline
Junior Member
 
Join Date: May 2010
Posts: 1
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default

@schenkman:

Thanks for saving my day
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Email box problems... slighty_sykotic Installation/Configuration 1 3rd August 2006 15:59
Relay forward all outgoing email simplyworks Installation/Configuration 3 20th July 2006 19:06
Email problems lead to apache problems natewlew Installation/Configuration 7 10th July 2006 09:53
Sending email problems: Relay access denied jaffaizal HOWTO-Related Questions 35 24th April 2006 11:04
Problems on setting new site always www on email!!! lyndros Installation/Configuration 3 14th March 2006 06:45


All times are GMT +2. The time now is 22:54.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.