Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 1st November 2012, 16:53
IrishDoc IrishDoc is offline
Member
 
Join Date: Nov 2012
Posts: 38
Thanks: 6
Thanked 0 Times in 0 Posts
Default Ip goes directly to webmail instead of isp3 HELP please

I followed the tutorial on how to setup isp3 for ubuntu 12.04lts and when I go to the ip address it shows the login screen for webmail and not isp3. I am not sure what I have done or how to fix it.
Reply With Quote
Sponsored Links
  #2  
Old 1st November 2012, 17:10
sjswarts sjswarts is offline
Senior Member
 
Join Date: May 2011
Location: Australia
Posts: 135
Thanks: 17
Thanked 5 Times in 5 Posts
Default

Quote:
Originally Posted by IrishDoc View Post
I followed the tutorial on how to setup isp3 for ubuntu 12.04lts and when I go to the ip address it shows the login screen for webmail and not isp3. I am not sure what I have done or how to fix it.
G'day IrishDoc,

In the URL did you use the port that was chosen at the ISPConfig setup section of that tutorial? I believe that ISPConfig defaults to port 8080

So if you choose SSL access type into your favourite web browser

https://example.com:8080 or https://192.168.1.1:8080

If you didn't choose SSL type into your favourite web browswer

http://example.com:8080 or http://192.168.1.1:8080

Obviously change the IP and domain to what you have set!

Regards,
Steven Swarts
Reply With Quote
  #3  
Old 1st November 2012, 17:16
IrishDoc IrishDoc is offline
Member
 
Join Date: Nov 2012
Posts: 38
Thanks: 6
Thanked 0 Times in 0 Posts
Default

I have it on 8080, you can see here 91.121.156.14:8080, if you just enter the ip it goes to webmail. It goes to the webmail no matter what I enter.
Reply With Quote
  #4  
Old 1st November 2012, 17:29
sjswarts sjswarts is offline
Senior Member
 
Join Date: May 2011
Location: Australia
Posts: 135
Thanks: 17
Thanked 5 Times in 5 Posts
Default

Quote:
Originally Posted by IrishDoc View Post
I have it on 8080, you can see here 91.121.156.14:8080, if you just enter the ip it goes to webmail. It goes to the webmail no matter what I enter.
1) Please show link to tutorial you used
2) Post contents of files:
a) /etc/apache2/sites-available/ispconfig.vhost
b) /etc/apache2/conf.d/squirrelmail.conf (I think its here, don't use it so it might have a different name or location)

Regards,
Steven Swarts
Reply With Quote
  #5  
Old 1st November 2012, 17:35
sjswarts sjswarts is offline
Senior Member
 
Join Date: May 2011
Location: Australia
Posts: 135
Thanks: 17
Thanked 5 Times in 5 Posts
Default

More specifically are you running Nginx or Apache2?
__________________
Regards,
Steven Swarts
Reply With Quote
  #6  
Old 1st November 2012, 17:35
IrishDoc IrishDoc is offline
Member
 
Join Date: Nov 2012
Posts: 38
Thanks: 6
Thanked 0 Times in 0 Posts
Default

Here is the link to the tutorial
http://www.howtoforge.com/perfect-se...ot-ispconfig-3

The files you asked me to check are showing permission denied, really not sure why that is, I have root access to my server and thats how I installed everything using putty.
Reply With Quote
  #7  
Old 1st November 2012, 17:38
IrishDoc IrishDoc is offline
Member
 
Join Date: Nov 2012
Posts: 38
Thanks: 6
Thanked 0 Times in 0 Posts
Default

apache2 (I believe), sorry I didn't specify that to my provider but when using the apache restart commands they worked perfectly.


Just verified with my provider that apache2 is being used

Last edited by IrishDoc; 1st November 2012 at 17:43.
Reply With Quote
  #8  
Old 1st November 2012, 17:46
sjswarts sjswarts is offline
Senior Member
 
Join Date: May 2011
Location: Australia
Posts: 135
Thanks: 17
Thanked 5 Times in 5 Posts
Default

Quote:
Originally Posted by IrishDoc View Post
The files you asked me to check are showing permission denied, really not sure why that is, I have root access to my server and thats how I installed everything using putty.
What happens when you do:

Code:
cat /etc/apache2/conf.d/squirrelmail.conf
that file should look like this to begin with:

Code:
Alias /squirrelmail /usr/share/squirrelmail
Alias /webmail /usr/share/squirrelmail
__________________
Regards,
Steven Swarts
Reply With Quote
  #9  
Old 1st November 2012, 17:47
sjswarts sjswarts is offline
Senior Member
 
Join Date: May 2011
Location: Australia
Posts: 135
Thanks: 17
Thanked 5 Times in 5 Posts
Default

Is it a VPS?
Do you have actual root access? or did they just make you an account and add you to the sudoers file?
__________________
Regards,
Steven Swarts
Reply With Quote
  #10  
Old 1st November 2012, 17:48
IrishDoc IrishDoc is offline
Member
 
Join Date: Nov 2012
Posts: 38
Thanks: 6
Thanked 0 Times in 0 Posts
 
Default

yes it does

Code:
Alias /squirrelmail /usr/share/squirrelmail
Alias /webmail /usr/share/squirrelmail

<Directory /usr/share/squirrelmail>
  Options FollowSymLinks
  <IfModule mod_php5.c>
    AddType application/x-httpd-php .php
    php_flag magic_quotes_gpc Off
    php_flag track_vars On
    php_admin_flag allow_url_fopen Off
    php_value include_path .
    php_admin_value upload_tmp_dir /var/lib/squirrelmail/tmp
    php_admin_value open_basedir /usr/share/squirrelmail:/etc/squirrelmail:/var/lib/squirrelmail:/etc/hostname:/etc/mailname:/var/spool/squirrelmail
    php_flag register_globals off
  </IfModule>
  <IfModule mod_dir.c>
    DirectoryIndex index.php
  </IfModule>

  # access to configtest is limited by default to prevent information leak
  <Files configtest.php>
    order deny,allow
    deny from all
    allow from 127.0.0.1
  </Files>
</Directory>

# users will prefer a simple URL like http://webmail.example.com
<VirtualHost 91.121.156.14>
  DocumentRoot /usr/share/squirrelmail
  ServerName webmail.kustomhosting.net
</VirtualHost>

# redirect to https when available (thanks omen@descolada.dartmouth.edu)
#
#  Note: There are multiple ways to do this, and which one is suitable for
#  your site's configuration depends. Consult the apache documentation if
#  you're unsure, as this example might not work everywhere.
#
#<IfModule mod_rewrite.c>
#  <IfModule mod_ssl.c>
#    <Location /squirrelmail>
#      RewriteEngine on
#      RewriteCond %{HTTPS} !^on$ [NC]
#      RewriteRule . https://%{HTTP_HOST}%{REQUEST_URI}  [L]
#    </Location>
#  </IfModule>
#</IfModule>
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Webmail on ISPConfig 3 Master One Installation/Configuration 8 6th June 2013 10:27
Horde Groupware Webmail Edition ByteMe Networking Tips/Tricks/Mods 17 20th December 2012 11:12
Login Screen goes directly to webmail not ispconfig3 IrishDoc Installation/Configuration 2 3rd November 2012 01:24
ISPConfig 3 Single server issues on POP3/IMAP/ MyDNS vk1003 Installation/Configuration 7 17th July 2012 16:25
Pointing Webmail and Postfix Mail Server to Static IP Address need_a_linux_brain Installation/Configuration 0 12th May 2009 23:28


All times are GMT +2. The time now is 19:41.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.