Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 18th April 2014, 22:14
vestport vestport is offline
Member
 
Join Date: Aug 2007
Posts: 45
Thanks: 1
Thanked 0 Times in 0 Posts
Default How can I delete and reinstall ISPCONFIG3 or just Apache2 on CentOS 6.4

I am having an issue with Apache2 not working right with domains and would like to try to remove and reinstall it to see that resolves the problem first before also removing and reinstalling ISPCONFIG3. Can someone please give me the procedures or link that explains how to completely remove and then reinstall Apache2. Also a procedure on how to remove and reinstall ISPCONFIG3. I just don't want to have to reformat drives, create mirror partitions etc. as everything else is fine.

Thanks in advance for any replies!


Art
Reply With Quote
Sponsored Links
  #2  
Old 21st April 2014, 09:34
srijan srijan is offline
HowtoForge Supporter
 
Join Date: Feb 2014
Location: New Delhi, India
Posts: 498
Thanks: 4
Thanked 62 Times in 60 Posts
Send a message via Skype™ to srijan
Default

Hi

Quote:
I am having an issue with Apache2 not working right with domains
I don't recommend to completely remove & then reinstall apache or ISPConfig3.

What error you are getting while using the apache?
Please paste the error logs for apache.

Br//
Srijan
Reply With Quote
  #3  
Old 21st April 2014, 13:55
vestport vestport is offline
Member
 
Join Date: Aug 2007
Posts: 45
Thanks: 1
Thanked 0 Times in 0 Posts
Default

I looked in the following 2 directories for clues to domain issues:

Code:
/etc/httpd/conf/sites-available

and

/etc/httpd/conf/sites-enabled


There are only 3 domains on this server. The DNS server itself (ns1.mydomain.com) and 2 other domains. When creating new domains I was get the following error in the domain vhost files:

Code:
# Apache did not start after modifying this vhost file.
# Please check file /etc/httpd/conf/sites-available/domain2.com.vhost.err for syntax errors.
I forget how I eliminated it sorry.

Tried restarting apache with errors for port 80 & 443 initially and also now there is no more https security now for the main site. Apache is screwed.

I get the following warning error restarting apache currently:

Code:
Starting httpd: [Mon Apr 21 07:41:30 2014] [warn] NameVirtualHost *:443 has no VirtualHosts
There are no more .vhost errors.

and here is the end of the conf file that may be relevant:

Code:
#NameVirtualHost *:80
NameVirtualHost *:443
Include /etc/httpd/conf/sites-enabled/
Art
Reply With Quote
  #4  
Old 1st May 2014, 15:34
vestport vestport is offline
Member
 
Join Date: Aug 2007
Posts: 45
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default Can anyone tell me how to remove ISPCONFIG3 and reinstall?

Need to reinstall ISPCONFIG3 and Apache without installing the whole OS. Can anyone help? System runs fine but too many issues with Apache and ISPCONFIG. Just want to start over.


Thanks in advance for any replies!


Art
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Install ISPConfig on CentOS Server, in brief gfts Tips/Tricks/Mods 11 4th April 2006 08:29


All times are GMT +2. The time now is 05:20.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.