#1  
Old 2nd August 2006, 01:10
tac tac is offline
Junior Member
 
Join Date: Aug 2006
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default No Virtual Hosts

When creating new websites using ISPConfig, all of the folders and user accounts are setup, but no virtual hosts are created. The Vhosts_ispconfig.conf file is left blank. When I connect to any of the domains pointing to my webserver they simply default to the default /var/www/html/ directory for apache.

How do I get the ISPConfig to properly write to the virtual hosts file? What information do you need to help me?
Reply With Quote
Sponsored Links
  #2  
Old 2nd August 2006, 02:10
tac tac is offline
Junior Member
 
Join Date: Aug 2006
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I am not quite sure what happened, but now the Vhosts.conf file is there and filled in what looks to be correctly. Unfortunately, all of the websites are still being directed to the /var/www/ direction, instead of their respective directory such was /var/www/web1/web/.
Reply With Quote
  #3  
Old 2nd August 2006, 05:46
tac tac is offline
Junior Member
 
Join Date: Aug 2006
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Just so others know how I got this working over the course of 5 hours.

The Virtual Servers were defined as being linked to a given IP 123.123.123.123, but by adding the wildcard IP * to the list of available addresses. I was able to select * and then all of the virtual hosts worked properly based on an alias from the domain name.
Reply With Quote
  #4  
Old 3rd August 2006, 14:50
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

This means you used the wrong IP address before in ISPConfig. You should have used the IP address you see when you run
Code:
ifconfig
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 4th August 2006, 02:45
tac tac is offline
Junior Member
 
Join Date: Aug 2006
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I wish the installation instructions had been more clear on this. The ifconfig IP address for me is my LAN IP not my WAN IP. It looks like 192.168.1.123.
Reply With Quote
  #6  
Old 5th August 2006, 16:02
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
 
Default

Quote:
Originally Posted by tac
It looks like 192.168.1.123.
Then change your ISPConfig settings to use this IP address.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual Hosts SSL 443 DaddyFix Installation/Configuration 16 9th May 2012 19:51
403 errors and virtual hosts tommywds Server Operation 3 27th June 2006 07:09
Custom directives automatically added to ftpd virtual hosts whitty Feature Requests 2 16th May 2006 23:15
Duplicate virtual hosts bosei General 13 22nd December 2005 17:48
postfix config jmroth Installation/Configuration 6 18th September 2005 15:58


All times are GMT +2. The time now is 16:52.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.