Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd May 2009, 12:58
reason8 reason8 is offline
Senior Member
 
Join Date: Aug 2008
Posts: 141
Thanks: 2
Thanked 0 Times in 0 Posts
Default ISPConfig 3 and .html files

Does ISPConfig 3 handle .html files differently than ISPConfig 2? I am trying to load a default page of index.html and it is not working. Its giving me an error of:

Forbidden

You don't have permission to access /index.html on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Apache/2.2.10 (Linux/SUSE) Server at amsico.com Port 80

I have added index.html to the /etc/apache2/httpd.conf, run SuSeconfig and restarted apache with no success. I've even renamed the file index.htm and tried to reload the page and it gives me the same error even though there is no index.html file.

Thanks!
Reply With Quote
Sponsored Links
  #2  
Old 2nd May 2009, 21:38
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,461
Thanks: 813
Thanked 5,243 Times in 4,109 Posts
Default

ISPconfig handles html files correctly of course, there must a misconfiguration on the server. Please take a look at the error log of the website for a detailed error message.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 2nd May 2009, 22:00
reason8 reason8 is offline
Senior Member
 
Join Date: Aug 2008
Posts: 141
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
ISPconfig handles html files correctly of course, there must a misconfiguration on the server. Please take a look at the error log of the website for a detailed error message.
I see no errors. What exactly am I looking for?

I deleted everything in the folder and updated an .htm file and now I get the error:

Forbidden

You don't have permission to access / on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Apache/2.2.10 (Linux/SUSE) Server at kernbits.com Port 80

I do get the following after restarting apache2:

/etc/init.d/apache2 restart
[Sat May 02 12:59:29 2009] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
Syntax OK
Shutting down httpd2 (waiting for all children to terminate) done
Starting httpd2 (prefork) [Sat May 02 12:59:31 2009] [warn] _default_ VirtualHost overlap on port 80, the first has precedence
done

What is this virtualhost overlap on port 80?
Reply With Quote
  #4  
Old 3rd May 2009, 05:36
reason8 reason8 is offline
Senior Member
 
Join Date: Aug 2008
Posts: 141
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Ok. I figured it out. The files in the /web folder by default do not allow permissions to the public to view. I had to set public permissions to READ for either the individual file OR apply those permissions to the folder itself and select include contest for either ALL folders (in the /web dir) or ALL files.

This brings me to a another question: Should the /web folder (and all of its contents) be set to READ and/or EXECUTE by the public? There are other folder in the directory by default such as STATS and ERRORS. Should these be set to public READ and/or EXECUTE?

I didnt have to do this in ISPC2 but maybe this is a security feature in version 3.

Thanks!
Reply With Quote
  #5  
Old 3rd May 2009, 10:37
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,461
Thanks: 813
Thanked 5,243 Times in 4,109 Posts
Default

The default pertmissions that ispconfig sets for the directories should be fine. They work for me on all supported linux distributions. If you changed them manually just set them back to the defaults (chmod 755).
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 3rd May 2009, 22:18
reason8 reason8 is offline
Senior Member
 
Join Date: Aug 2008
Posts: 141
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
The default pertmissions that ispconfig sets for the directories should be fine. They work for me on all supported linux distributions. If you changed them manually just set them back to the defaults (chmod 755).
Well they didnt work for me in version 3. The default index.html file will display but when I copy my index.html file over it will not. It tells me either I do not have permissions to "/" or to "/index.html". Setting the permission on the index.html for public allows me to view it.
Reply With Quote
  #7  
Old 4th May 2009, 01:38
reason8 reason8 is offline
Senior Member
 
Join Date: Aug 2008
Posts: 141
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Update:
It looks like initially I have to set public permissions on the folder for any NEW files and folders that I ftp over to the /web folder. Is this normal? I never had this issue with version 2 but like I said before, maybe it is a upgrade in functionality for security reasons. My only concern is that users will have to do this also.
Reply With Quote
  #8  
Old 4th May 2009, 08:04
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,461
Thanks: 813
Thanked 5,243 Times in 4,109 Posts
Default

Yes, thats normal and it is the same then in ISPConfig 2. Take a look at the permissions of your files in ispconfig 2, they have to be world readable as apache will not be able to read them otherwise. Looks as if you upload your files with the wrong chmod settings.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 4th May 2009, 08:19
reason8 reason8 is offline
Senior Member
 
Join Date: Aug 2008
Posts: 141
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
Yes, thats normal and it is the same then in ISPConfig 2. Take a look at the permissions of your files in ispconfig 2, they have to be world readable as apache will not be able to read them otherwise. Looks as if you upload your files with the wrong chmod settings.
I did have this problem with persmissions in version 2 and I have already uninstalled it but I will take your word for it
Reply With Quote
  #10  
Old 4th May 2009, 13:57
reason8 reason8 is offline
Senior Member
 
Join Date: Aug 2008
Posts: 141
Thanks: 2
Thanked 0 Times in 0 Posts
 
Default

When you said that I uploaded the files with the wrong chmod permissions, were you implying with ISPConfig 2 or ISPConfig 3? As I said before 2 uploaded with no problems using FireFTP for mozilla firefox. Using the same FTP client and ISPConfig 3, its a different story.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
apache2 won't connect to localhost or 127.0.0.1 anw Server Operation 6 19th March 2009 18:51
AddType Application .html .htm rutame Installation/Configuration 2 16th November 2008 15:56
FTP cannot open remote folder!?! andysm849 Server Operation 23 16th October 2008 23:34
Can't start apache Musty Server Operation 12 9th March 2008 13:58
Change .html files msource Installation/Configuration 4 26th January 2008 16:49


All times are GMT +2. The time now is 09:14.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.