Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 30th October 2012, 13:12
softstein softstein is offline
Junior Member
 
Join Date: Apr 2012
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default SSH Users outsite website_docroot

Hi! My ISPconfig3 has the problem that SSH users are not generated. The error message is

Quote:
WARNING - Directory of the shell user is outside of website docroot.
Digging in the sourcecode it turns out that the paths are different:
/home/www/clients/client11/web15 != /var/www/clients/client11/web15

This comes because all websites are located in /var/www (which is symlinking to /home/www ). Sure I changed all paths in Server Config accordingly.

What I do not know yet is: Where is the path in $data['new']['dir'] (line 77 in http://fossies.org/unix/privat/ISPCo...plugin.inc.php ) been taken from?

Changing the homedir of the SSH user does not make a difference. Did I overlook a configuration option here?

Any help is appreciated. Thanks!
Reply With Quote
Sponsored Links
  #2  
Old 30th October 2012, 13:40
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,457
Thanks: 813
Thanked 5,239 Times in 4,107 Posts
Default

The directories of the ssh users are based on the directory of the website.

Quote:
This comes because all websites are located in /var/www (which is symlinking to /home/www ). Sure I changed all paths in Server Config accordingly.
This can not work with a symlink as the real path is not the same then the website path. Remove the symlink and mount the directory with mount --bind instaed.

http://backdrift.org/how-to-use-bind-mounts-in-linux
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 30th October 2012, 15:21
softstein softstein is offline
Junior Member
 
Join Date: Apr 2012
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default solved :)

That made it. Man muss nur darauf kommen...
Thank you very much, Till!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
cannot create new ssh users for one client wildnux Server Operation 0 9th February 2011 01:10
Problem with Clamav + samba configuration wammy28 HOWTO-Related Questions 8 31st January 2009 19:12
Cacti and ISPConfig: Monitoring Tool VMartins Tips/Tricks/Mods 11 9th August 2008 18:37
Can't enable SSH access for users TheFuzzy0ne Installation/Configuration 3 8th August 2008 16:53
Junk mail and spamassassin... sthompson Installation/Configuration 4 27th December 2006 16:11


All times are GMT +2. The time now is 03:41.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.