Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 25th October 2012, 20:40
ispix ispix is offline
Junior Member
 
Join Date: Oct 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default OpenVZ issues : Container config file does not exist

Hello,

I tried to install ISPConfig3 on a clean minimal debian install following this guide.

Unfortunately, I failed to create a vm altought it appears in the vserver tab of ispconfig3.

Code:
root@fitzroya:~# vzctl enter 101
Container config file does not exist
I read several posts with the same error message but still can't solve my problem.
I may miss something in the config files, but what ?

Code:
root@fitzroya:~# ls -l /vz | tail -1
lrwxrwxrwx 1 root root 11 25 oct.  17:44 /vz -> /var/lib/vz
I added this template in ISPConfig3:
Code:
root@fitzroya:~# ls /vz/template/cache/
debian-6.0-amd64-minimal.tar.gz
and because it's often asked :
Code:
root@fitzroya:~# /usr/local/ispconfig/server/server.sh 
25.10.2012-18:38 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
25.10.2012-18:38 - DEBUG - Found 3 changes, starting update process.
Container config file does not exist
25.10.2012-18:38 - DEBUG - Unable to register function 'soa_insert' from plugin 'bind_plugin' for event 'dns_soa_insert'
25.10.2012-18:38 - DEBUG - Unable to register function 'soa_update' from plugin 'bind_plugin' for event 'dns_soa_update'
25.10.2012-18:38 - DEBUG - Unable to register function 'soa_delete' from plugin 'bind_plugin' for event 'dns_soa_delete'
25.10.2012-18:38 - DEBUG - Unable to register function 'slave_insert' from plugin 'bind_plugin' for event 'dns_slave_insert'
25.10.2012-18:38 - DEBUG - Unable to register function 'slave_update' from plugin 'bind_plugin' for event 'dns_slave_update'
25.10.2012-18:38 - DEBUG - Unable to register function 'slave_delete' from plugin 'bind_plugin' for event 'dns_slave_delete'
25.10.2012-18:38 - DEBUG - Unable to register function 'rr_insert' from plugin 'bind_plugin' for event 'dns_rr_insert'
25.10.2012-18:38 - DEBUG - Unable to register function 'rr_update' from plugin 'bind_plugin' for event 'dns_rr_update'
25.10.2012-18:38 - DEBUG - Unable to register function 'rr_delete' from plugin 'bind_plugin' for event 'dns_rr_delete'
25.10.2012-18:38 - DEBUG - Processed datalog_id 24
25.10.2012-18:38 - DEBUG - Processed datalog_id 25
25.10.2012-18:38 - DEBUG - Processed datalog_id 26
25.10.2012-18:38 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
finished.
If anyone have any idea ?

Thx in advance.
Reply With Quote
Sponsored Links
  #2  
Old 26th October 2012, 08:23
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,202
Thanks: 829
Thanked 5,422 Times in 4,264 Posts
Default

the server.sh output above does not contain the creation of a vm.

1) Disable the server.sh cript in cron as described in the faq.
2) Create a new openvz vm in ispconfig.
3) run the server.sh script on the shell as root.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 26th October 2012, 12:11
ispix ispix is offline
Junior Member
 
Join Date: Oct 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Thx a lot for your answer,

As I played a lot with openvz (manually) and changed too many parameters on ISPConfig3, I started again with a clean install before looking at your explanation.

Now I can create VM without any problems so it looks like I missed something on my 1st install.

I now have networking config issues but this is another problem. I will look forward that later.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Combination of postfix and courier failing Xaymar Server Operation 3 7th March 2012 17:28
Can't receive mails baicunko Server Operation 12 3rd August 2011 22:02
Internet Explorer won't connect to my server wctaelectronics Server Operation 10 27th October 2008 21:14
Spamsnake - Problem with spamassassin, FuzzyOcr and MySQL debuguser HOWTO-Related Questions 6 16th September 2008 18:37
spamassasin/clamAV not working Daisy Installation/Configuration 32 15th February 2007 00:09


All times are GMT +2. The time now is 19:15.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.