Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 16th January 2012, 11:56
WilyeECoyote WilyeECoyote is offline
Junior Member
 
Join Date: Jan 2012
Location: Skive, Denmark
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Postfix compile error

Figured it out. Needed a couple of -lresolv in the Makefile.in a couple of places.

Hello

I got this problem when compiling postfix 2.8.5 on Ubuntu 11.10

../../lib/libdns.a: error: undefined reference to '__dn_expand'
../../lib/libdns.a: error: undefined reference to '__res_search'

Anyone know how to fix this??

Lars Fisker

Last edited by WilyeECoyote; 16th January 2012 at 19:44. Reason: Resolved
Reply With Quote
Sponsored Links
  #2  
Old 23rd February 2012, 11:03
Icon Icon is offline
Junior Member
 
Join Date: Feb 2012
Posts: 9
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by WilyeECoyote View Post
Figured it out. Needed a couple of -lresolv in the Makefile.in a couple of places.

Hello

I got this problem when compiling postfix 2.8.5 on Ubuntu 11.10

../../lib/libdns.a: error: undefined reference to '__dn_expand'
../../lib/libdns.a: error: undefined reference to '__res_search'

Anyone know how to fix this??

Lars Fisker
Got same problem, but don't know howto do "a couple of -lresolv in the Makefile.in a couple of places". Can anyone tell what exactly must be done to fix, please?
Reply With Quote
  #3  
Old 17th May 2012, 06:12
Icelake Icelake is offline
Junior Member
 
Join Date: Apr 2012
Location: Nacka (Stockholm), Sweden
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default Re. building error: Postfix VDA 2.9.1

Can anyone with the right knowledge please describe the process of fixing the above problem,

../../lib/libdns.a: undefined reference to `__res_search'
../../lib/libdns.a: undefined reference to `__dn_expand'

that makes the building process with the VDA 2.9.1 patch end in error?
I think it might be useful for many members.

Best regards/Icelake

Last edited by Icelake; 17th May 2012 at 21:34. Reason: did write wrong version number of vda
Reply With Quote
  #4  
Old 17th May 2012, 08:40
medved medved is offline
Junior Member
 
Join Date: May 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Postfix VDA 2.9.1

make: *** [maildir.o] Error 1
make: Leaving directory `/usr/src/postfix-2.9.1/src/virtual'
make[1]: *** [update] Error 1
make[1]: Leaving directory `/usr/src/postfix-2.9.1'
make: *** [build] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2


somebody knows as to solve a problem?
Reply With Quote
  #5  
Old 18th May 2012, 16:27
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Did you use the correct VDA patch for your Postfix version?

Which distribution do you use?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 19th May 2012, 10:03
Icelake Icelake is offline
Junior Member
 
Join Date: Apr 2012
Location: Nacka (Stockholm), Sweden
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi, Falko!

On my behalf I tested as you suggested and got the answer:
mail_version = 2.9.1
milter_macro_v = $mail_name $mail_version
so I fetched the patch: postfix-vda-v11-2.9.1.patch with wget as you described in your Howto.

I use Ubuntu 12.04 swedish version.

Rgds/Dagge
Reply With Quote
  #7  
Old 21st May 2012, 10:33
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Not sure if this helps, but you can try to install the package binutils-gold. Then try to build Postfix again.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 21st May 2012, 15:09
Icelake Icelake is offline
Junior Member
 
Join Date: Apr 2012
Location: Nacka (Stockholm), Sweden
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks, Falko!
I erased everething and downloaded the files fresh (just in case).
It didn't work out with the new linker either.
So I just sit on the problem for the moment.
Wonders however...
Is it possible to use the resulting mailserver without the qutoa patch?
Or will it kick back at you, if it not finds the quota information in the database?

Rgds/Dagge
Reply With Quote
  #9  
Old 28th May 2012, 19:43
gaborojo gaborojo is offline
Junior Member
 
Join Date: May 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Hi Falko!!

When I try to build package got the same error, I´ve been following your how to from this web site. Is it posible use mail server without patch?

I tried with Ubuntu 12.04 LTS (64 bits and 32 bits)

Best Regards!
Reply With Quote
  #10  
Old 29th May 2012, 12:34
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
 
Default

Yes, but quota won't work then.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix SMTP Auth to Dovecot Not Working -- HELP! Scratchpad Server Operation 6 12th April 2011 13:29
compile cp210x drivers in Ubuntu9.10 cigogo Kernel Questions 1 15th December 2009 16:27
localhost postfix/master: fatal: bind 127.0.0.1 port 125: Permission denied g18c Installation/Configuration 4 24th March 2009 17:39
Installation Fails... :( cyberstorm Installation/Configuration 1 15th January 2006 18:07
Install stop at uuwish, UUDeview SeaWolf Installation/Configuration 6 4th October 2005 23:53


All times are GMT +2. The time now is 16:03.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.